Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DLL Talk / XGUI (extends) does not work

Author
Message
JDforce
15
Years of Service
User Offline
Joined: 27th Jul 2004
Location: Some rainforest
Posted: 30th Jun 2009 18:24
I am having problems with the xgui part of extends since I reinstalled the OS in my PC. I reinstalled DBPRO and plugins, checking for the most recent version. In my order page, 1.3 is the extends version.
All other plugins seem to work fine.

All extends samples work fine, except for the ones that use xgui. I tried all initialization fixes found along the forum, and also found that oddissey creators is no longer in business, so hope anyone from tgc or freddix can help me.
When attempting to run the extends version of the scrolling ship (2pkshoot) from the 2dplugin kit, it crashes unless I REM all lines that use Xfont. The music from eXtends play ok in that sample.
The advancedSprites.dll version of that program, also included with 2dplugin, works perfectly.

The problem symptom is simple: the program crashes when entering the xgui part or initializing xgui.
I tried every initialization fix found in this forum, but none seem to work.
Also noticed that xgui commands are not anywhere in the context help system.

My pc is a laptop with vista home premium sp2, with the latest directXsdk, ATI HD2600 mobility card, 2GB ram.

Windows shows a message saying that the program stopped working, and these are the technical details lines:

Problem signature:
Problem Event Name: APPCRASH
Application Name: AlphaSHOOT.exe
Application Version: 1.0.0.0
Application Timestamp: 49126fbe
Fault Module Name: ntdll.dll
Fault Module Version: 6.0.6002.18005
Fault Module Timestamp: 49e03821
Exception Code: c0000005
Exception Offset: 00066739
OS Version: 6.0.6002.2.2.0.768.3
Locale ID: 1033
Additional Information 1: fd00
Additional Information 2: ea6f5fe8924aaa756324d57f87834160
Additional Information 3: fd00
Additional Information 4: ea6f5fe8924aaa756324d57f87834160

Any help is well received.

May the 3d force B with U
Fitz marc ade
12
Years of Service
User Offline
Joined: 1st Jan 2007
Location: Somewhere near the Milkyway...
Posted: 4th Jul 2009 16:11

Hi JDforce, Ive also noticed this problem.

Its a compatabilty problem from what i can gather so far. The Plugin Works fime on an XP Operating System, but the XGUI and XFONT commands will not work on vista for some reason. Also the Plugin is now at 1.4, check tour Order History and redownload latest, but firstly u need to Un-Install the old Plugin.
Anyways the rest of the Plugin commands seem to work. If you need to use Bitmap fonts there are a few Code snippets in the Forums, just search at bottom of page.

I dont know if this plugin will ever be updated as Odyssey Creators are no longer supporting there products. Its now TGC who are selling them.

Hope this answer your questions and maybe it helps....
James H
12
Years of Service
User Offline
Joined: 21st Apr 2007
Location: St Helens
Posted: 4th Jul 2009 17:06
Just posted some links to threads with info on this issue in the vista compatability thread stickied on the dbpro board
Fitz marc ade
12
Years of Service
User Offline
Joined: 1st Jan 2007
Location: Somewhere near the Milkyway...
Posted: 4th Jul 2009 17:54
Ok gonna put a link to the post here for others to find.

http://forum.thegamecreators.com/?m=forum_view&t=104612&b=1

Basically u gotta compile and create the exe 1st then set compatability to 98/Me to get it to run.
Freddix
AGK Developer
17
Years of Service
User Offline
Joined: 19th Sep 2002
Location: France
Posted: 5th Jul 2009 23:37 Edited at: 5th Jul 2009 23:38
Hi All,

I did notice this issue with eXtends under some Windows VISTA systems. Using compatibility mode on the .EXE DBPro generate should fix this issue.

I have also seen that on my computer (dual boot with Windows XP pro and Windows VISTA business), with the latest PureBASIC, XGUI and XFont does no more crash on my own Windows VISTA system ... I will prepare a release that I'll submit to TheGameCreators, compiled with latest PureBASIC.
I hope it will also fix this issue for other users.

This problem was linked to something related on how Windows VISTA handle STRINGS. I don't know if it's due to PureBASIC upgrades or DarkBASIC Pro ones ... But I hope this release will fix this issue.

Kindest Regards,
Frédéric Cordier

Gandalf said: "All we have to decide is what to do with the time that is given to us"
Odyssey-Creators - X-Quad Editor - 3DMapEditor
JDforce
15
Years of Service
User Offline
Joined: 27th Jul 2004
Location: Some rainforest
Posted: 6th Jul 2009 06:52
Thanks everyone.
Freddix, I have tested the generated exe with compatibility mode, even with desktop composition disabled and other settings, but none seem to work.
Tomorrow I will test the program on a windows XP sp2 I have at the office, and will post the result.


JD

May the 3d force B with U
Freddix
AGK Developer
17
Years of Service
User Offline
Joined: 19th Sep 2002
Location: France
Posted: 6th Jul 2009 10:54
JDForce,

Don't forget that compatibility mode must be set to Windows 98/ME and not to Windows XP one ...

Kindest Regards,
Frédéric Cordier

Gandalf said: "All we have to decide is what to do with the time that is given to us"
Odyssey-Creators - X-Quad Editor - 3DMapEditor
JDforce
15
Years of Service
User Offline
Joined: 27th Jul 2004
Location: Some rainforest
Posted: 7th Jul 2009 19:35
Freddix,
With windows 98/me settings, results are:

XfontScrolltext> runs fine.
XguiWindowsdemo> runs but upon showing the xwindow it crashes.
Asteroids> crashes.

Thanks,

JD

May the 3d force B with U
Freddix
AGK Developer
17
Years of Service
User Offline
Joined: 19th Sep 2002
Location: France
Posted: 13th Jul 2009 00:45
Ok

I hope the next release will fix this issue as it does no more crash for me on Windows VISTA Business 64

Kindest Regards,
Fred

Gandalf said: "All we have to decide is what to do with the time that is given to us"
Odyssey-Creators - X-Quad Editor - 3DMapEditor

Login to post a reply

Server time is: 2019-10-18 23:13:50
Your offset time is: 2019-10-18 23:13:50