Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Program Announcements / QuickODE - Physics for DarkGDK

Author
Message
Limit8
9
Years of Service
User Offline
Joined: 22nd Aug 2011
Location:
Posted: 23rd Aug 2011 12:43
I've included everything

I've written in this:



AND i also included the libs into the additional lib configs
Matty H
11
Years of Service
User Offline
Joined: 7th Oct 2008
Location: England
Posted: 23rd Aug 2011 15:14


Pauli will probably need to compile QuickODE with VC++ 2010. Don't worry about the errors being in German, something tells me Pauli will understand

Pauli is currently away, I think he said he will be back on 28th.

Clonkex
Forum Vice President
10
Years of Service
User Offline
Joined: 20th May 2010
Location: Northern Tablelands, NSW, Australia
Posted: 24th Aug 2011 01:00
Quote: "I've included everything"


Ok then I have no idea. Maybe it does need to be compiled for 2010.

Clonkex

_Pauli_
AGK Developer
11
Years of Service
User Offline
Joined: 13th Aug 2009
Location: Germany
Posted: 3rd Sep 2011 20:26
Quote: "Please, could you compile QuickODE for Visual C++ 2010"


Well, don't know, I don't have Visual C++ 2010. Could this really be the issue? I have no idea what's going on behind the scenes of Visual Studio. I thought it doesn't really matter and that the IDE would be backwards-compatible with compiled libs...

Quote: "In english it means something like: "Unresolved external symbol" "


Exactly. I have to take a deeper look into this error though.

@Everyone:

Just as a reminder: QuickODE is constantly under development, I'm working on it from time to time when it fits in my schedule (quite busy at the moment). So please be patient for updates
Also I think I will drop the support for QuickODE to be compatible with non-TGC engines. The core functionality may remain cross-compatible though... It just makes it easier to focus on DarkGDK right now (and eventually port to DBPro).

Matty H
11
Years of Service
User Offline
Joined: 7th Oct 2008
Location: England
Posted: 3rd Sep 2011 20:59
Quote: "Well, don't know, I don't have Visual C++ 2010. Could this really be the issue?"


Yes, I had the same errors from someone using Dark Imposters with VC++ 2010.

There is an express version, you can then convert your project over and compile a VC++ 2010 version of your lib. Although I had a few problems getting DarkGDK working with VC++ 2010 at first, can't remember why.

Login to post a reply

Server time is: 2020-09-29 06:14:50
Your offset time is: 2020-09-29 06:14:50