Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / my dbpro crashes!!!!!! :(

Author
Message
Crappycoder
17
Years of Service
User Offline
Joined: 12th Sep 2002
Location:
Posted: 12th Sep 2002 15:09
i have installed dbpro and the patch from the site, i start to compile, just as it is about to run the code it crashes and gives me this error:

DBPCOMPILER caused an invalid page fault in
module DBPCOMPILER.EXE at 0177:00413419.
Registers:
EAX=00fade40 CS=0177 EIP=00413419 EFLGS=00010202
EBX=00fade60 SS=017f ESP=0069f934 EBP=00faded0
ECX=00000001 DS=017f ESI=00000000 FS=194f
EDX=00fade3c ES=017f EDI=00fadf80 GS=0000
Bytes at CS:EIP:
8b 56 08 85 d2 75 05 ba b0 ee 43 00 52 8b c8 e8
Stack dump:
0000000a 000019cd 00fab8a0 00000000
000103e8 007d89b0 00faa560 000004bb
000004bb 00fadc50 00000000 00fac830
00000001 00fac830 00000002 000004d8




i have a:

1.4ghz thunderbird
512mb DDR ram
voodoo3 PCI 16mb


thanx alot

Crappycoder
MrTAToad
17
Years of Service
User Offline
Joined: 26th Aug 2002
Location: United Kingdom
Posted: 12th Sep 2002 15:23
I think the Voodoo is causing the problem...

You could wait and see if anyone else has the same problem, or contact support.

Yes, I really am THAT good...
dannywartnaby
17
Years of Service
User Offline
Joined: 27th Aug 2002
Location:
Posted: 12th Sep 2002 15:31
CC, I've had that a couple of times, but only when attempting to compile older source files (DB1.X Files). I'm not sure exactly what this issue is get. Any new files created with DBPro work like a treat.

Are you getting that error EVERY time your try to compile?.

www.dannywartnaby.co.uk
Fireburst
17
Years of Service
User Offline
Joined: 26th Aug 2002
Location: United Kingdom
Posted: 12th Sep 2002 17:14
1) Check the code your compiling.
2) Make sure you have DX8.1 installed correctly.

If that fails PANIC !!!

In theory, there is no difference between theory and practice. But in practice, there is.
Crappycoder
17
Years of Service
User Offline
Joined: 12th Sep 2002
Location:
Posted: 12th Sep 2002 20:05
done all that, i tried every dbpro example and game and it did it to all of them!!!

directx 8.1 is installed properly.....

i might try installing dbpro again and not patch it, see if that works....

thanx alot

Crappycoder

Fireburst
17
Years of Service
User Offline
Joined: 26th Aug 2002
Location: United Kingdom
Posted: 12th Sep 2002 20:22
I was going to suggest trying to run in emulation mode but this isn't available in DBpro.

In theory, there is no difference between theory and practice. But in practice, there is.
Chroma
17
Years of Service
User Offline
Joined: 11th Sep 2002
Location: - Please Select -
Posted: 13th Sep 2002 01:40
Does it crash all the time?

Blimey Mate!
WarWolf
17
Years of Service
User Offline
Joined: 27th Aug 2002
Location: Sweden
Posted: 13th Sep 2002 17:37
This can be because of two things:

* You have your screen color depth set to 24 bit
* You've got old graphic-card drivers

Try setting the color-depth to 16 bit or 32 bit.
If that doesn't work, then download the latest voodoo-drivers...

If it still doesn't work, then I suggest contacting DarkBASIC software...

I didn't steal it!
MrTAToad
17
Years of Service
User Offline
Joined: 26th Aug 2002
Location: United Kingdom
Posted: 13th Sep 2002 18:02
You dont say what OS your using.

Yes, I really am THAT good...
Mike Johnson
TGC Developer
17
Years of Service
User Offline
Joined: 13th Sep 2002
Location: United Kingdom
Posted: 13th Sep 2002 19:50
What is it that you're trying to compile? Does this happen every time you compile?

Mike

Crappycoder
17
Years of Service
User Offline
Joined: 12th Sep 2002
Location:
Posted: 13th Sep 2002 20:42
i was trying to compile all the dbpro examples and projects. I bought a new graphics card, Geforce 3 ti 500 from a friend and it works well now

MrTAToad
17
Years of Service
User Offline
Joined: 26th Aug 2002
Location: United Kingdom
Posted: 14th Sep 2002 02:13
good

Yes, I really am THAT good...
Ian T
17
Years of Service
User Offline
Joined: 12th Sep 2002
Location: Around
Posted: 14th Sep 2002 04:51
Ah man, I'm stuck here feeling stupid with my GeForce 2 MX ...

--Mouse
Nikkoz
17
Years of Service
User Offline
Joined: 31st Aug 2002
Location: Sweden
Posted: 14th Sep 2002 14:28
you are...
Ian T
17
Years of Service
User Offline
Joined: 12th Sep 2002
Location: Around
Posted: 14th Sep 2002 20:51


--Mouse

Login to post a reply

Server time is: 2020-08-04 04:21:50
Your offset time is: 2020-08-04 04:21:50