Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / Constantly jiggling dynamic objects

Author
Message
GrumpyOne
11
Years of Service
User Offline
Joined: 27th Nov 2007
Location: London, UK
Posted: 6th Jul 2010 18:37
Dear All,

I have a problem. When I create dynamic objects and allow them to drop onto a static rigid body mesh they won't stop jiggling (bouncing with small amplitude).

I've tried setting phy set bounce threshold to a arbitarily high value (-1000.0) but it makes no difference to any of the collision responses. In fact it this command doesn't seem to be working at all. In anycase I've monitored the linear velocity of the dynamic objects and they seem to be well below the default bounce threshold.

Any suggestions are welcome.

Thanks,
Mr Grumpy

GrumpyOne - the natural state of the programmer
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 6th Jul 2010 18:48
try the sleep threshold.


phy sleep rigid body ID
or
phy set rigid body angular damping ID, value#

Dark Physics makes any hot drink go cold.
GrumpyOne
11
Years of Service
User Offline
Joined: 27th Nov 2007
Location: London, UK
Posted: 6th Jul 2010 19:05
Thanks HowDo but still doesn't work.

I've tried initialising with very high values for the sleep thresholds but it doesn't have any affect on the jiggling.

phy set bounce threshold -6.0
PHY SET DEFAULT SLEEP LINEAR VELOCITY SQUARED 100.0
PHY SET DEFAULT SLEEP ANGULAR VELOCITY SQUARED 100.0

I've tried damping both linear and angular velocity and the only affect is to make by dynamic objects fall slowly! They continue to jiggle like mexican beans.

GrumpyOne - the natural state of the programmer
GrumpyOne
11
Years of Service
User Offline
Joined: 27th Nov 2007
Location: London, UK
Posted: 6th Jul 2010 19:42
I've tried several things now.

I was running at a sync rate of 30 fps, I've increased this to 60 fps and reduced the gravity. All this does it decrease the amplitude of the jitter it doesn't stop it. I've also tried increasing the skin width, this seems to have no affect.

I'm guessing that the rigid body should be going to sleep but for some reason isn't. It sounds like a bug.

Mr Grumpy

GrumpyOne - the natural state of the programmer
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 6th Jul 2010 20:15
if you want to post your code, I might be able to see where you are going wrong.

any media will not be needed as I just make it a box or cube.

Dark Physics makes any hot drink go cold.
GrumpyOne
11
Years of Service
User Offline
Joined: 27th Nov 2007
Location: London, UK
Posted: 6th Jul 2010 21:45
That's good of you to offer but it would take you forever! There's a lot of media.

I've come up with a work around (not a solution...the dynamic objects won't go to sleep on their own). If I monitor the velocities of all dynamic objects I can send them to sleep manually once their change in velocity falls below a certain limit. It's not ideal.

I'll chase this up with support. It may be because some of my objects are scaled.

Thanks, Mr Grumpy

GrumpyOne - the natural state of the programmer
GrumpyOne
11
Years of Service
User Offline
Joined: 27th Nov 2007
Location: London, UK
Posted: 6th Jul 2010 21:54
Oh I should mention that whilst following the y velocity of my jittering object it varies each timestep between -10^6 and 1.633. The positive velocity is very strange initially it drops to about 0.5 then increases again and stabilises at 1.633.

GrumpyOne - the natural state of the programmer
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 6th Jul 2010 22:00
Mr Grumpy have looked at it through the Nvidia debugger, some times that will show you what may going on.

plus have you checked that the faces on your model that won't stay still are the right way round, I use to have a problem with AC3D x export and it would not make the models right, when I found the correct way all was ok, did this by making the model I had a 3ds one, this would work how I expected, so it was just a matter of find the correct setting for x model.

plus if you just put in a demo of it own, ground and drop it does stop or creep around, if it stays still then it might be something is waking up again in your main code.

had this type of problem with the penny falls I was making they would not stay still, thinking back it may have been the model.

Dark Physics makes any hot drink go cold.

Login to post a reply

Server time is: 2019-08-22 01:21:22
Your offset time is: 2019-08-22 01:21:22