Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Program Announcements / Indigo - A DBPro IDE Alternative

Author
Message
DrTorte
8
Years of Service
User Offline
Joined: 31st May 2010
Location:
Posted: 31st Dec 2010 19:15
Ah yes, sorry, forgot to mention that. Running Windows 7 Ultimate, 64-bit. Trying to run the 32-bit version of the program just leads to an instant crash.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 4th Jan 2011 04:56
Version 1.1.2 has been uploaded.
Change log:
> Intellisense - Corrected defect that prevented keyword from being detected when preceded by a '('.
> Several defect fixes - Corrected defect that would cause the source to scroll unwantingly. Corrected defect that prevented complied EXE's from being detected if source and Indigo were not on the same drive.
> Misc - Changed how the use of the DirectX dll is handled. In short, it means being back to one version for me to manage.

You can get latest download on the Indigo Site.


DrTorte,

I don't know if this will fix the error that you're getting. Are you running a non-English version of Windows?

Regards,

nnndohh
12
Years of Service
User Offline
Joined: 12th Aug 2006
Location: netherlands
Posted: 4th Jan 2011 21:50
this last version works on my dutch windows 7 system, thanks
tiresius
16
Years of Service
User Offline
Joined: 13th Nov 2002
Location: MA USA
Posted: 8th Jan 2011 22:21 Edited at: 8th Jan 2011 22:23
Hi Balid-

Using Windows 7 64 bit. My Darkbasic pro installation is here (the default from Dark Game Studio I believe):
C:\Program Files (x86)\The Game Creators\Dark Basic Professional

For some reason it can't find the Help folder. I see this popup in the beginning:

Web Browser
Cannot find
...:/Program%20Files%20(x86)/The%20Game%20Creators/Dark%20Basic%20Professional//H...
Make sure the path or Internet address is correct.

If I type F1, it goes nuts with this popup several dozen times until it crashes (probably too many windows generated or something).

It has to do with the double // , I'm sure of it. But my install path in Tools->Options doesn't have a \ after the directory.

Any ideas what I can do?


A 3D marble platformer using Newton physics.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 10th Jan 2011 19:07
tiresius,

I sent an email to you directly.

But since then, I will have Indigo do more verify of the address being passed.

If you are not able to get Indigo to load now, because the Help window is active when Indigo starts. You will need to delete the 'DockPanel.config' file in the config folder.

Regards,

tiresius
16
Years of Service
User Offline
Joined: 13th Nov 2002
Location: MA USA
Posted: 11th Jan 2011 05:24
Hi Balid-

The registry looked okay to me at the time. Upon a recent reboot it seems to work now. I don't know if I fixed it in a previous running of Indigo via the Tools->Options menu and it just took a reboot to make a difference.

I think making Indigo handle a bad DBPro path better would be a good change.

Everything looks good in Win7 64 Home Premium for me.


A 3D marble platformer using Newton physics.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 11th Jan 2011 18:31
tiresius,

Good to hear that Indigo is working as expected after the reboot.

I admit that there isn't as much error checking on somethings as there should be. Mostly on the parts coded very early as Indigo was meant as a personal editor. I did just enough testing to make sure things worked for me. I'm sure that a few more little defects like that exist. But like Micro$oft and others I will focus on defects in areas that people actually use. Rather than comb through all of the code to fix something that's not being used.


On a side note. I am now having problems compiling 64 bit versions. Once I get that resolved I will post another v1.1.2 beta (that include the extra path check).

Regards,

Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 13th Jan 2011 17:54 Edited at: 13th Jan 2011 18:44
I have just be coding merrily away and I suddenly got a "Display is not supported by available hardware at line 0". This now happens at every compile. I presume line 0 refers to the .dbpro file. But the only references to display modes are:

fullscreen resolution=1024x768x16
window resolution=1280x720


... and both are most definitely supported by my hardware.

Any suggestions?

[EDIT] It works fine after a reboot, so it was more likely to be an issue with my PC rather than Indigo



Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 13th Jan 2011 23:46
Quote: "[EDIT] It works fine after a reboot, so it was more likely to be an issue with my PC rather than Indigo "


end yet another happy customer.

My only other thought would be if you are setting the resolution in the code. I know many do (well so do I for that matter .)


For everyone, I fixed my issue with not being able to compile 64 bit version. Do to work and life, I probably won't have the next v1.1.2 beta out before the weekend. And thanks to only having internet access at work for now it will most likely Monday that I can post the latest version.

Regards,

Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 14th Jan 2011 17:06 Edited at: 14th Jan 2011 17:41
I have a couple of suggestions:

1. Could you add the functionality for Ctrl+Alt+K to enter just the scancode number with no keywords? At the moment Ctrl+K enters keystate(##) and Ctrl+Shift+k enters scancode(##). Both of which are extremely useful but I have functions that require scancode values to be passed as parameters and it would be nice not to have to delete the keywords.

2. I have DBP installed on an external Hard Drive so that I can use it at university. This also means that I have to install Indigo each time I use it (due to the university's deep freeze). Not a problem itself but every time I install Indigo it fails to find the DBP install location, so I have to put it in manually ... again not a problem but having done that, it still doesn't find the keywords until I close Indigo and run it again. So, could you either have Indigo re-scan for the keywords when you enter the DBP install path or add the option to re-scan in the Tools menu?

Thanks

... and a code folding bug that isn't obvious why, perhaps you can see.
This is my code as I had it originally and as you can see the folding fails:


So, I tried it like this instead to see if that worked but again the folding failed:


However, in the process of trying to see why it failed I got the folding to work but obviously the code is wrong:


Like I said, I can't see what the problem is but maybe the images give you a clue as to what is going wrong?



Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 14th Jan 2011 20:00
Scraggle,

Thank you for the suggestions. Expect to see those in v1.2.0 (as well as an option to help with your university scenario).

The defect with 'next' not folding should be corrected with v1.1.2. I noticed it in one of my projects as well. Is there a space after the 'y' of the 'next y' line? (You must be running the latest v1.1.2 beta. I believe the defect was introduced in that release.)

Regards,

Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 14th Jan 2011 20:40 Edited at: 14th Jan 2011 20:52
That was it. A swift podge of the delete key after next y and everything was fixed.

Thank you for the promise of including my suggestions. This is without doubt the best IDE available and your continued support and willingness to add suggestions is fantastic!

So, here's another suggestion for you:
When double clicking on a number to select it, if the number is negative could you add the sign aswell?
Thanks



Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 14th Jan 2011 22:58
Quote: "This is without doubt the best IDE available"

I like the way you think Scraggle {more humbly} Thank you (not that you haven't helped make it that way).

Quote: "When double clicking on a number to select it, if the number is negative could you add the sign as well?"

Will add that to the v1.2.0 list. I hope to get a preview of v1.2.0 to you the first week of February.

Regards,

DrTorte
8
Years of Service
User Offline
Joined: 31st May 2010
Location:
Posted: 16th Jan 2011 21:35
Hello Balid, just thought I'd let you know my problem has been solved with the 1.1.2 beta and I'm now taking the program for a spin. Thanks!
Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 18th Jan 2011 11:34
I have only just discovered the "Auto Suggest After ## Characters" feature and must say I think it is fantastic!

It does have a frustrating feature though which I think could be improved:
Let's say I have a global variable called myVariable. When I type in my then myVariable is highlighted and I can enter it by pressing [Return] or [Tab]. This is great!
However, if I type the whole variable name in and then hit [Return] to enter a new line. I don't get a new line, instead the "variable/keyword selector box" disappears. The same thing happens if I type my [TAB] then [Return].

What would make this feature much better is if the "variable/keyword selector box" disappeared whenever [Tab] is hit (like it does with [Return]) or when the full variable name is entered.

At the moment globals and constants suffer this problem.
Keywords are fine when hitting [Tab] but still siffer the issue if you type the full word in.

Is this something that could be fixed?

Thanks



Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 20th Jan 2011 18:36 Edited at: 20th Jan 2011 18:37
I have uploaded the latest v1.1.2 beta. The major difference is an adjustment to the fold marking of lines with 'next' in them. I still need to come up with a full fix. But at least for now, an extra space shouldn't be a problem (though, two will reproduce the error).

Indigo Site.


Scraggle,

I will look into making intellisence more intelligent. Like turning off if the user has entered the full keyword.

Regards,

Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 20th Jan 2011 19:16
Good man

Ankhranum
8
Years of Service
User Offline
Joined: 6th Jul 2010
Location:
Posted: 22nd Jan 2011 00:03
I've a strange error about the compiler everythime I compile:
(See attachment)

Attachments

Login to view attachments
Falconsoft Industries
8
Years of Service
User Offline
Joined: 22nd Jan 2011
Location: No.
Posted: 22nd Jan 2011 09:13
sounds great, sorry to be off topic but will i be able to write anything like a dock with this and reshape the window of my dialogue and give it a skin and by skin i mean template, and shape it like an eclipse?

you see I have been working on a dock with game maker and a few dlls and friends but now i am not sure what is the best programming language to use and the simplest to use.

I need to know if this language can make a IM program and antivirus, anti rootkit, anti malware, anti spyware, anti keylogger, anti mouse logger, and anti worming program complete with a media player.

also complete with a system tray and taskbar, sort of something to replace the big bulky windows task bar/ dock i think it needs to be smaller on size but larger on features and have a calendar, and to do list.

As well as a template editor and redesigner and organiser with a clock both digital and analog every aspect must be customisable including the brightness and color of the dock, it even needs a calculator and clock maker and if any one has any ideas for this dock called "The Hawk's Dock" i will accept them, and put your name in the credits.

You even will have a cd eject button and play and pause and stop and skip track back and forth you can even save and load configuration files as '.smes' files to load groups of 48 shortcuts horizontal in 2 rows 24 at the top and 24 below.

I am new to 3d game maker so any advise on how to make a rpg with 3d game maker would be nice i have used game maker in the past but i feel 3d is where i need to go for the time being...
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 22nd Jan 2011 22:19
Ankhranum,

Reading the error message provided shows that your problems is that you have two dll's that contain a function that is named the some (or a duplicate command). I would suggest changing the suffix of the free dll to something like dll.exclude. Then the compiler will ignore it and resolve your issue.


Falconsoft Industries,

In short, your question would be best asked in the DBPro forum as not every who could help will read this one.

Regards,

Dark Goblin
12
Years of Service
User Offline
Joined: 19th May 2006
Location:
Posted: 25th Jan 2011 00:28
It would be nice if you could speed up the IDE because it is very slow with bigger source codes.
For example if I edit the FPS Creator Source Code (which is available) I am not able to search for something, as it needs ages to find it.
Also I can not quickly scroll to the bottom of the code as the whole IDE does not respond.
Hope you can fix that issue too.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 25th Jan 2011 00:45 Edited at: 25th Jan 2011 00:46
Dark Goblin,

I think I might have a copy of the FPS Creator Source Code lying around on my hard drive. I'll dust it off and give it a spin in Indigo and see what I can do. I don't know how many lines there are in that source but I think its all in one file. My largest source file is over 4000 lines and is only slow when it first loads. The overall project has almost 11,000 lines and searching the whole project is fairly quick the systems that I've tested on. Mind telling your spec's for comparison?

Quote: "Also I can not quickly scroll to the bottom of the code as the whole IDE does not respond."

Have you tried [Crtl + End]? It will take you to the last line of code. At what point is the whole IDE non-responsive or is it always non-responsive with large source files?

Regards,

JamesOH
8
Years of Service
User Offline
Joined: 19th Dec 2010
Location:
Posted: 27th Jan 2011 11:43
Hello,

I do love Indigo. However, related to Scraggle's intellisense problem - I have a UDT called map. If I type map then 'dot' Indigo thinks I want map file to bank (the first intellisese option). Could you change things so a dot does not auto-complete for you?

Cheers
JamesOH
8
Years of Service
User Offline
Joined: 19th Dec 2010
Location:
Posted: 27th Jan 2011 20:23
Also, sometimes the code window has a habit of jumping horizontally for no reason if I click in the middle of a block of text. Which is a bit infuriating.
Brendy boy
13
Years of Service
User Offline
Joined: 17th Jul 2005
Location: Croatia
Posted: 28th Jan 2011 07:51 Edited at: 28th Jan 2011 07:53
I have found a bug (don't know if it's already reported).

Here's the code, go to line 254 and fold a type called "type T_stair" and watch what happens with the rest of the code (it vanishes)



Scraggle
Moderator
15
Years of Service
User Offline
Joined: 10th Jul 2003
Location: Yorkshire
Posted: 28th Jan 2011 12:30 Edited at: 28th Jan 2011 15:01
JamesOH
Turning off the Auto Case Fixup will stop that problem (code jumping) until a permanent fix comes along.

@Brendy Boy
The problem is at line 192
You have a variable called type$. Indigo is seeing that as the keyword TYPE and that is causing your folding problems.
If you rename the variable type$ to something else (style$?) you will find the problem will go away.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 28th Jan 2011 21:35
JamesOH,

You must be on 64 bit? I was able to fix the problem on 32 bit but it is obviously more persistent on 64 bit OS. Hopefully Scraggle's suggestion works for you as well.

Brendy Boy,

I will update how Indigo is determining the start of a TYPE statement (and others was well). Scraggle is right, Indigo doesn't recognize that '$' is part of the word. So it sees that the line starts with 'type' and triggers the start of a fold. A fairly easy fix. I really should have seen that scenario . Can't see the forest for the trees sometimes. I should have that fix in the next v1.1.2 beta.

Scraggle,

Thank you very much. I should be able to look into your emails tonight.

Regards,

gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 30th Jan 2011 21:09
Hi

I have run it but I get one error when I try and compile a file

I know there is one command in the program that is not working
so it should tell me that

I've got version 7.7 r2 of DBP
On windows xp sp3

If a thought is Just a thought ~ so whats the main thought ?

Attachments

Login to view attachments
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 4th Feb 2011 18:43 Edited at: 4th Feb 2011 18:45
Resourceful,

Do you get that error for every project?
Quote: "I know there is one command in the program that is not working
so it should tell me that "
It would but the compiler is erring long before that point. Your getting an error from the Compiler. I would get that error when Indigo failed while trying to make the full source DBA file.


For everyone,

Progress update. I was looking to post the last v1.1.2 release but I found a defect with intellisense that was introduced in v1.1.1 that needs to be corrected first. If all goes well, I will be posting v1.1.2 (still as beta) on Monday and it will contain many defect fixes.

Regards,

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 5th Feb 2011 04:11
v1.1.2 is released and posted
The problem that I thought was from v1.1.1 was actually from me today. A quick change back and everything seems to be back as expected.

Final change log for v1.1.2:
> Help - Added path validation to prevent repeat page load errors.
> Line Folding - Corrected defect with false end fold points being created for keywords containing 'next'. Corrected defect with 'type$' triggering a fold point.
> Intellisense - Corrected defect that prevented keyword from being detected when preceeded by a '('. Corrected defect that prevented similar user defined keywords from being detected.
> Several defect fixes - Corrected defect that would cause the source to scroll unwantingly when 'Auto Fix Case' option was selected (corrected in 32 bit only). Corrected defect that prevented complied EXE's from being detected if source and Indigo were not on the same drive.
> Misc - Changed how the use of the DirectX dll is handled. In short, it means being back to one version for me to manage.


You can get latest download on the Indigo Site.


Regards,

CodemanV
13
Years of Service
User Offline
Joined: 25th Aug 2005
Location: South Wales Valleys, UK
Posted: 5th Feb 2011 05:17
Hello

Been away from game development for a while and BlueIDE was my number 1 choice for DBPro projects, so thanks for all your efforts on developing a decent DBPro IDE.

Currently, I am waiting to have an operation, so I have loads of spare time and decided to dig out my DBPro projects and continue on them.

I have just a downloaded the latest 1.1.2 version of this new Indigo IDE and it's my new number 1 !)

But, there is a minor problem which is mainly to do with the way I organise my projects.

PROBLEM - Indigo doesn't accept fixed paths in project "Executable Filename" box.

Indigo uses a registry entry "initaldir" to set the compile folder to the <CURRENT PROJECT FOLDER>

<HKEY_CURRENT_USER\Software\Indigo\Core\>
initialDir=<CurrentProjectFolder>


If the project "Executable Filename" within Indigo is set to something like "C:\temp\temp.exe" or any path, on compiling, an error is returned .....

COMPILER ERROR
Could not create <CurrentProjectFolder>C:\temp\temp.exe


As the error output suggests, it's appending the "executable filename" to the "initialdir" registry entry but the "initialdir" folder isn't necessarily going to be the same folder as the desired executable folder.

Possible Solution
If the "executable filename" contains a path then use that otherwise append the "executable filename" to the "initialdir" registry entry

The issue isn't really a biggy but it would be appreciated if this could be implemented.

Again, thanks for your IDE's over the years.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 6th Feb 2011 05:00
CodemanV,

Glad to have you back. I hope your operation is nothing serious and goes well.

Your assumptions on how Indigo works are not correct. Indigo only uses the 'initialDir' value to determine where to point the OpenFile dialog window. And Indigo is not appending the <CurrentProjectFolder> to the Executable Filename, the compiler is. All Indigo does is tell the Dark BASIC Compiler where to find the dbpro file. And so it would be the compiler not liking the fixed path in the Executable Filename.

This does not mean that I can not make an adjustment to Indigo to get to a solution. In fact this enhancement is now already a part of v1.2.0. I needed to make a copy of the dbpro file and modify it so the compiler would be able to create the exe. I believe that that is something similar to what the default IDE does as well.

However your observations are correct. The 'initialDir' value is the same as <CurrentProjectFolder> and there have been other issues with Indigo and absolute paths before. And Indigo was previously set up to use <CurrentProjectFolder> (or something similar) as the default location for all project related material.

Thank you for your comments and expect an email in the near future .

Regards,

Neodelito
13
Years of Service
User Offline
Joined: 29th Jul 2005
Location:
Posted: 6th Feb 2011 18:27 Edited at: 6th Feb 2011 18:28
Wow nice Idle..
only one bug..
Windows XP SP3
when you time "remove" in any line..




Attachments

Login to view attachments
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 6th Feb 2011 22:47 Edited at: 6th Feb 2011 23:41
Neodelito,

Thank you for the compliment and a screenshot of the error. I was able to find and correct the issue.

I will put together a v1.1.2a release. I should have it ready for upload in a couple of hours.

[edit] or sooner. I just uploaded the v1.1.2a release. [/edit]

Regards,

Neodelito
13
Years of Service
User Offline
Joined: 29th Jul 2005
Location:
Posted: 7th Feb 2011 04:16
thanks for your response..

only logo need some upgrade..






CodemanV
13
Years of Service
User Offline
Joined: 25th Aug 2005
Location: South Wales Valleys, UK
Posted: 7th Feb 2011 07:24 Edited at: 7th Feb 2011 07:26
Hello again

My operation is only a minor one, I have to have my Gallbladder removed via keyhole surgery and a load of Gallstones blasted out - I say blasted, they just use some sort of Dr Who sonic screwdriver thingy to dissolve them.

But once it's done, I will be able to once again to eat pizza, bacon & egg & cheese sandwiches, fried Chinese and drink very milky, creamy coffee (all of which are essential ingredients to aid my software development) so I can't wait. At the moment, just drinking some full cream milk can give me a seizure and cramps so I am on a "healthy" diet until then

Thanks for asking though

On Indigo, when I open my old projects, most of the executables are set to "C:\temp\tempDBP.exe" so I just have to remove the path . I'm just too impatient for my own good sometimes

Something that I noticed but is not a bug, with BlueIDE Snippets, you can use subfolders and it creates a tree of them but Indigo doesn't. Will that ever be impletemented?

Again, not really much of an issue as I keep BlueIDE open in the background anyway. Then, when a snippet is required, a simple cut and paste is all it takes.

Anyway, I've got loads of old projects to sift through and test so I can upload some Code Snippets.

Keep up the good work
All the best
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 7th Feb 2011 22:56
Neodelito,

Nice logo. Did you take the picture of the Indigo or is it off the web?

No te ofendas a tu comentario sobre que necesitan un logo actualizado. (I hope that's right.)


CodemanV,

A subfolder / treeview for the code snippets could be an addition to v1.2.0.

Regards,

Admiral MH
8
Years of Service
User Offline
Joined: 10th Feb 2011
Location: TX, USA
Posted: 11th Feb 2011 02:51
Balid,

I get a instant crash when I start the program.

Windows 7 64 Bit
Indigo 1.1.2

Besides that, this works on my old computer and works great. Looks really nice, I will test this some more when its fixed with my current system.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 11th Feb 2011 03:51 Edited at: 11th Feb 2011 03:52
Admiral MH,

Glad to have you as part of the community. Did you join just so you could post about Indigo? I'm flattered if you did.

Could you provide a copy of the Indigo log file as well as a copy of the actual error message?

Regards,

Admiral MH
8
Years of Service
User Offline
Joined: 10th Feb 2011
Location: TX, USA
Posted: 11th Feb 2011 19:12
Balid,

Quote: "Glad to have you as part of the community. Did you join just so you could post about Indigo? I'm flattered if you did."


Thank you for the warm welcome, I have been viewing the forums for over one year now, so I joined in part, to post about some bugs I have had. And also to make some plugins/programs to help people out in the future. So I guess you could say that joined to post on Indigo.

Quote: "Could you provide a copy of the Indigo log file as well as a copy of the actual error message?"


I did not get a error log, when I start the program, it crashes immediately. ("Indigo has stop working...")

I started the program on administrator mode, and compatibility mode with admin permissions, and still does not work.



Neodelito,

By the way, nice job on that logo, it does look really good.
budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 1st Mar 2011 17:18 Edited at: 1st Mar 2011 17:46
For some reason, every time I try to open up my project file (which I could open before), Indigo crashes. I keep getting this error on it:


And here's the info from details.


Also, why is the "save project as" feature in the file menu grayed out?


Mystic-Mod: Putting the fear back into sliced bread since 4th May 2010
gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 1st Mar 2011 23:59
ummm budokaiman which windows are you running ?

If a thought is Just a thought ~ so whats the main thought ?
budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 2nd Mar 2011 14:41
W7 64 bit.


Mystic-Mod: Putting the fear back into sliced bread since 4th May 2010
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 2nd Mar 2011 15:18
budokaiman,

What happens if you select continue? And could you provide the Indigo log file?

Quote: "Also, why is the "save project as" feature in the file menu grayed out?"

It's a feature that's still not working the way that I would like it too. IE - creating / coping a whole project to a new one. Not just creating a renamed 'dbpro' file. I want Indigo to be smart enough to know when and what to copy. As well as which parts need to be renamed.


Thank you and regards,

budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 3rd Mar 2011 19:48
When I hit continue, the code window just grays out.
Here's the log:



Mystic-Mod: Putting the fear back into sliced bread since 4th May 2010
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 3rd Mar 2011 22:08
budokaiman,

Thanks. It looks like you have the "Open most recent project' optioned turned on. Have you tried opening Indigo with that turned off? Or tried reopening the project after clicking on continue?

Also, I trust that the project opens in other IDE's?

Regards,

budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 3rd Mar 2011 22:39
Quote: "It looks like you have the "Open most recent project' optioned turned on."

Just looked and it isn't on.

Quote: " Or tried reopening the project after clicking on continue?"

I've tried, it still crashes.

Quote: "Also, I trust that the project opens in other IDE's?"

Yes it does.


Mystic-Mod: Putting the fear back into sliced bread since 4th May 2010
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 4th Mar 2011 00:04
budokaiman,

Ok. (it's not a good sign when I miss read my own log report.)

Now I'm really stumped. Could you by any chance upload your 'dbpro' file? And yes, I'm grabbing at straws here.

The 'duplicate key value' is really throwing me.

Regards,

budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 4th Mar 2011 00:49 Edited at: 4th Mar 2011 00:50
dbpro file attached

Quote: "The 'duplicate key value' is really throwing me."

I seem to get that about 40% of the time. Sometimes I get this instead:



Mystic-Mod: Putting the fear back into sliced bread since 4th May 2010

Attachments

Login to view attachments
gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 6th Mar 2011 05:19
every thing I test on Indigo works fine

I've got a couple of tweaks

the boarder size for the help menu is bigger than it needs to be

please see attached picture

and the option to word wrap in the edit window

when I played around with much older dbp demo
it had the that and was nice to use

If a thought is Just a thought ~ so whats the main thought ?

Attachments

Login to view attachments

Login to post a reply

Server time is: 2019-04-20 21:12:50
Your offset time is: 2019-04-20 21:12:50