Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Program Announcements / Indigo - A DBPro IDE Alternative

Author
Message
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 15th Nov 2011 22:23 Edited at: 15th Nov 2011 22:23
Chris Tate,

Could you send me the Indigo log file? Please make sure that logging is turned on before opening the project though.


DarkDiscussion,

I'm currently using Visual Studio and some free controls.


All the best,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 16th Nov 2011 01:51
Ok, I emailed it.

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 16th Nov 2011 12:46
For your information, I managed to create a new project with the same source files; and it re-opened the project file succesfully.

However, when the program itself is closed and reopened, the "Index and length" error occurs again.

Mika
14
Years of Service
User Offline
Joined: 30th Jun 2004
Location: South of France
Posted: 22nd Nov 2011 23:32
Hi everybody,

I am an old user of blueIDE with DB Pro and I recently acquired AGK.

Any chance that Indigo IDE will support AppGameKit also?

Regards

Michel

Michel
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 23rd Nov 2011 02:24
Mika,

At this point, no. I don't use AppGameKit, nor do I currently have plans to use it.

Indigo was created as my own IDE for DBPro and is a hobby project of mine.

If I do venture into AppGameKit, I may look at expanding Indigo. The AppGameKit IDE seems to look good. Though it is probably missing the additional syntax highlighting that Indigo has.

All the best,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 23rd Nov 2011 16:21
Hi Balid

The latest update corrects the project load and save issue. I did do a re-install of the system as well, so I am not sure if the computer caused any issues. All but the keystate tool is working well so far, I will continue to use it to see how well everything else works.

Thanks for the work

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 25th Nov 2011 03:25
Chris,

That's great news. In doing some tests today I was able to replicate an error with the Keystate insert functionality. I also believe that I have a very simple solution as well. Which is to include the config file that I needed to create to prevent me from getting the error in the first place. All this time it wasn't part of the installer. And since it's already on my test machines I never noticed. I will hopefully have the latest beta ready for upload on Saturday.

All the best,

Grasmann
10
Years of Service
User Offline
Joined: 1st Sep 2008
Location:
Posted: 26th Nov 2011 11:50 Edited at: 26th Nov 2011 13:07
Hi

I really like Indigo very much. The best editor I ever used for
dark basic .

But lately I ran in some problems here. At some point of
development I got some crashes when scrolling through my code with
1.3.0 so I updated to 1.3.1 and this version seems to fix my
issues but replaces them with a rather broken intellisense. >_>

My Intellisense Problems in 1.3.1 beta 1:

- Intellisense seems to automatically close now if a keyword like
"if" is finished ... not that big of a problem ... I would prefer
it if the list would stay open

- I can´t choose from the Intellisense with the arrow keys ... now
this is a big problem for me XD. If I press an arrow key with the
Intellisense list open Indigo seems to refresh several components
of the whole IDE instead of just updating the selection cursor,
and then the first Intellisense entry is selected. The result is
that the first entry is always selected and Im only able to choose
from the list with the mouse.




Maybe it´s just the way I set up the whole editor, like
dependencies in the editor options ... but like this the editor is
much less useable for me :/, which is sad because it is so awesome.


EDIT:
I just realized if I hold the arrow keys pressed while in
Intellisense list it really scrolls down but as soon as I release
the arrow key the list jumps back to the top and selects the first
entry.

EDIT2:
I further tested a bit:
- It also effects the Intellisense when choosing from UDT-attributes.
- No combination of options in the editor seem to fix this for me,
neither does a compatibility mode with windows xp sp3 or launching
Indigo as admin.

EDIT3:
I switched back to 1.3.0 for now and actually found a way to avoid
the crashes
I experienced. It seems like the crashes occur when
the editor tries to color local variable declarations without the
keyword "LOCAL" in front . I mostly write it ... but forgot it
in several functions. Funny thing is that the editor seems to
accept a certain amount of such declarations. But if there are to
many of them the editor says nope.
Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 27th Nov 2011 10:19
G'day Balid,

Been coding a bit lately, and was thinking of the Indigo "Extra" default relative path system.

The problem I face is via the use of Dropbox on 3 different computers, all used at some stage during the week for DBpro.

Dropbox shares my DBPro & DBA files to each computer as per the following;

Computer 1:
"F:\Dropbox\DBPro Projects"

Computer 2:
"C:\Users\Burningfeetman\Dropbox\DBPro Projects"

Computer 3:
"C:\Users\Domain.WorkLoL\Dropbox\DBPro Projects"

From there, the following directory exists which contains what I consider "library" source files. Code which is common to all my programs;

"Dropbox\DBPro Projects\Common Code\"

But the problem with DBPro projects is that they're constantly hardcoding directories, such as the below example;



You can see that this project would work fine on Computer 1, but would fail when loaded on the other two computers.

So at the moment, I'm struggling to get the Indigo "default relative path" to work, with my above work flow in mind.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 27th Nov 2011 22:46
Grasmann and Burning Feet Man,

This latest demo should correct issues for both of you.

Indigo site

Regards,

Grasmann
10
Years of Service
User Offline
Joined: 1st Sep 2008
Location:
Posted: 28th Nov 2011 16:31 Edited at: 28th Nov 2011 17:54
First of all when I tried to open my current project I got this error:

Error translation by me: Object reference not set to an object instance.

After that the loading process is canceled even if I press the continue button. This could be a very small problem and I guess it´s fixed rather easy, therefore I further tested intellisense with a new project but there´s still something broken.
-------------------------------------------------------------------
1.
I tried to write:


I selected "IF" from the intellisense and hit enter -> worked
I selected "IMAGE EXIST" and hit enter and it ended up like this:


I doesn´t write the selected line, instead it writes the last line in the intellisense list apart from that it also adds the "ENDIF" for the unfinished "IF" and does a oddly placed return. This issue seems to occur only if I try to use it in an unfinished IF-Statement. It worked when I added the "ENDIF" first. Also the issue that the last entry in the list is selected just occured in this If-scenario.
EDIT: It seems to occur with all loops, too. Except "FOR". If I begin a for-loop after writing "FOR" intellisense is closing automatically on this line ( maybe because there is no keyword left beginning with "for" ).
EDIT: Also it fails to complete the "FOR", it doesn´t write the next by pressing enter if there is only written "FOR" ( I guess that´s because you expect a variable name to be there to add it to the "NEXT" command ).

Repeat is working ( I guess that´s because you use the "UNTIL" for everything else, so the loop is already finished ).
While:

Select:

-------------------------------------------------------------------
2.
If I write "make object " with intellisense open, right after making the last space, after "object", there occurs another error:

Error translation by me: Index out of range.
Same happens for a space after "case" with intellisense open.
-------------------------------------------------------------------
3.
If I write "DO", select "DO" from the intellisense list and press enter it ends up like this:

Interesting thing: "DOWNKEY" was the last entry in the intellisense list. Obviously it selected this instead of "DO" and added the "LOOP" for the "DO" ^^.
Seems to be connected to the issue under point 1.
EDIT: Actually it creates "DOWNKEYLOOP" no matter what I select from the list in this scenario -> I tried to select "DOUBLE FLOAT".
-------------------------------------------------------------------
4.
Also the intellisense still closes after the keyword is finished, which is odd for me since I disabled the "Auto Case Fixup" ... I had some problems with that: It tended to scroll some lines through my code after I selected text to copy/paste. Because of that I often write my commands completely but still select them from the intellisense list just to have them capitalized.

To make this clearer:
In 1.3.0 I wrote "if" -> intellisense still open -> then selected "IF" from intellisense and had my "IF" capitalized.
In 1.3.1 I write "if" -> intellisense closes after writing "f"

Not really an error but somehow annoying to me XD.

I would suggest an option whether the intellisense list should be closed or not.
If you choose the list not to close it should only be closed if the user is pressing enter to select a chosen command. That would be awesome ... at least for me XD.
-------------------------------------------------------------------
PS: Sorry for swamping you in errors and issues ^^" ... I just want the editor to be the best it can be. For now I will stick with v 1.3.0.
PS2: Overall there seem to be some problems with intellisense in combination with loops and ifs.
-------------------------------------------------------------------
EDIT: I just realized Im still using 1.3.0 beta 3 XD omg ...
My favorite version so far
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 28th Nov 2011 18:42 Edited at: 28th Nov 2011 18:43
Grasmann,

Quote: "Sorry for swamping you in errors and issues ^^""

No worries. I appreciate the fact that you give examples. It's not helpful when people just say "it doesn't work". I can test your examples before posting the next beta.

When you say "select" are you using the arrow keys or mouse?

I will be adding an option to close auto-complete if you completely type in the selection. As well as make some adjustments to that functionality based on what you are describing.

Thank you and all the best,

Grasmann
10
Years of Service
User Offline
Joined: 1st Sep 2008
Location:
Posted: 28th Nov 2011 21:09
Quote: "When you say "select" are you using the arrow keys or mouse?"


Yes Im using the arrow keys imo it´s much faster then mouse.
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 29th Nov 2011 01:20
Quote: "Yes Im using the arrow keys"

So that issue has been fixed.

Regards,

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 29th Nov 2011 04:02
Hopefully you got my email Balid, regarding the strange Options window size. Not too sure what's causing this problem on my work computer, but since the Options window is static by nature, I can't resize it.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Space Dream Studios
Competition Prize Winner 2014
8
Years of Service
User Offline
Joined: 3rd Mar 2010
Location:
Posted: 30th Nov 2011 16:37 Edited at: 30th Nov 2011 16:37
Hi have the same error message, like Grasmann, when opening my project file with more than 5800 lines of code
It crashs!
When will it be fixed and the new download available???
Thanx!!!

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 2nd Dec 2011 02:40
I have been using the IDE alot over the past week.

A few feature requests here; when there is time.

Save All button; or menu item which saves all the open files including the project file. Sometimes when you add a new file to the project and exit; when you load the project back the added file is not loaded into the project. Also, when working with 50+ source files, saving 10 or 20 opened files one by one isn't ideal.

Also, a Save Project menu item / or button. In line with the above issue, sometimes you need to change the compile order or a setting and need to save what you did to the project.

The next one is trivial;

Find (Ctrl+F) command; this is probably my most used tool in the IDE, it is really good, the project scope search and replace is a time saver; but it would be even better if it highlighted all of the text in the field. When you are doing a search in a selection; the entire selection may be a large function, this gets put into the textbox; it just slows down the workflow having to clear this unwanted text before confirming; rather than using the Ctrl+F > keystrokes > Enter routine.

Again, it is a useful tool.

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 2nd Dec 2011 06:30
Balid, did some coding and quick checks today;



Bloody brilliant!!! Will do some more testing over the coming days, but I think you've solved the multi-desktop library, different directory library problem!

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 2nd Dec 2011 20:50
Chris Tate,

When you save, all open source files that have been modified are saved and if you made a change that would affect the project file then it is saved as well. Also, when you close Indigo without saving it should ask if you want to save. If a file has been modified and needs to be saved, it is marked with an '*' at the end of the tab name.

BFM,


Regards,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 2nd Dec 2011 22:48
I understand your point.

I tested the process today and when I press save, it did save the project correctly.

So I will watch out for the problem if it happens again and I will see if it is something I am doing wrong. What ever happened, took place after creating new source files.

I did modify and save the source files on a number of occasions then closed the program. When I reopened the project, the newly added files were not included added. I found this out because of compiler errors based on an undeclared functions and arrays.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 3rd Dec 2011 00:35
Chris Tate,

I will do some more experiments of my own around adding includes both new and existing.

Regards,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 3rd Dec 2011 21:41
The following is just a report of what may be related to my problem posted above. It may not be entirely to do with Indigo, but it may be a clue to what is happening.

Sometimes the compiler creates more than one include of the same file. This happened three times this week. When I reload the project each time; everything is fine.

Here is today's example; I compiled the project and got a duplicated #constant error. However the saved project file is correct:


When I look at the source code dump; the content of SF Text & SF Character Text were duplicated. So who knows, maybe sometimes the compiler duplicates and other times it misses the file out.

The missing file problem did not happen today however.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 4th Dec 2011 02:53 Edited at: 4th Dec 2011 02:56
Chris Tate,
Quote: "I compiled the project and got a duplicated #constant error."

Did you do a search to identify if there is a duplicate? Also, do you use the #include command?
Quote: "When I look at the source code dump"

Which source code dump are you looking at (file name)? To me there are two. One that Indigo makes and sends to the compiler and the second would be one of the files that the compiler actually makes. I want to make sure we are referring to the same file.

Regards,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 4th Dec 2011 11:29
Quote: "Which source code dump are you looking at (file name)?"


"FullSourceDump.dba" The one in the TEMP folder of the DBPRO installation path. I did not know about the one Indigo creates, so I will have to wait for the error to happen again to look at it. What is the file path for the one that Indigo makes?

Quote: "Did you do a search to identify if there is a duplicate? Also, do you use the #include command?"


Yeah I searched. The entire content of the files I mentioned where added twice in FullSourceDump.dba. The first line of the duplicated code was the #constant declaration, the first error detected was based on a declaration already declared.

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 4th Dec 2011 20:55
Ok, I was working on my project and it happened again a few minutes ago; here is a copy and paste of the duplicated part of the FullSourceDump.dba file:


SF Character Text.dba is the only source file in there twice at the moment. I do not know where the source file Indigo creates is. SF Character Text.dba is an open source file in the IDE, but it was not focused. The DBPRO file looks like this:



Only one entry of SF Character Text in there, and in the project file list in Indigo.

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 4th Dec 2011 23:28 Edited at: 4th Dec 2011 23:29
I just caught this duplication bug too.

I loaded my DBPro, removed 3 .DBA files, then re-added the same 3 files. Edited one of the #CONSTANTS within one of the 3 files, then compiled.

Seems to think I have two of the same functions, but I don't.

EDIT: And I can confirm the problem goes away after closing Indigo, opening Indigo then reloading my project.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 5th Dec 2011 00:24 Edited at: 5th Dec 2011 03:36
Chris Tate,

I noticed a couple of things from the examples. I see that the order of printing is also wrong. Did you happen to change the order or add/remove includes before trying to compile?

[edit]Look for "_Temp.dbsource" in "C:\Users\owner\AppData\Local\Temp\Indigo". It won't last long.[/edit]

BFM,

Thank you for the report. It helps confirm that there is definitely an issue in Indigo. Helpfully combining the information from both will lead to a root cause.

All the best,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 5th Dec 2011 13:34
Quote: "I see that the order of printing is also wrong. Did you happen to change the order or add/remove includes before trying to compile?"


I changed the order to how it is in the DBPRO file when the files where first created. The last thing I did was create a few new constants in the SF Text file.

I will try to copy the Indigo source file when it happens again. It happens every 20-30 compiles.

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 5th Dec 2011 19:01
Update, I got it to happen but could not get to the Indigo file in time. It seems to repeat the same source code: SF Character Text:


I have noticed an error that I have made in my own code; the name of the constant T_PROTAGONIST_1 is not a good one; this may cause the compiler to change occurances of T_PROTAGONIST_1_SNAME, but this did not happen because T_PROTAGONIST_1 was compiled after T_PROTAGONIST_1_SNAME. I will still change it to T_PROTAGONIST_1_FULLNAME to see if it is related to the problem.

The last error message was "Failed to 'UnfoldFileDataConstants'". The last action was to hit save after creating and coding two new files. The compile order of the two new files where changed manually. Again, reloading the project, without having to close Indigo, prevents to the issue temporarily; I can compile and run the program with or without the change of constant names.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 6th Dec 2011 01:31
Grasmann,

I'm not able to actually reproduce what you describe. I would suggest using [tab] rather than [enter] when selected from auto-complete though. I found that using [enter] would just give me a new line.


Chris Tate,

I will focus on the functions used to re-order includes. It most like is not clearing (or moving) data correctly. And this was next step anyway. It's only thing left that I can think of.

All the best,

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 11th Dec 2011 23:08
v1.3.1 b3 has been posted.

Corrected issues with the Cut/Copy/Paste buttons on the toolbar not working. As well as some other bug fixes. To include the issue that Chris Tate brought up about changing the include order and having duplicated code source when compiling. Come to find out it would only do it for me if I had the source open as well. Should be fixed now.

Ingido Site

All the best,
Craig

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 12th Dec 2011 01:03
Yipee!

I will download it in a day or so.

I never noticed the copy and paste button issues; I use the keyboard for most tasks.

Thanks Craig.

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 12th Dec 2011 04:48
So far almost so good. I've found the application crashes when the user right clicks and selects "Insert Keystate".

But yeah, things are working so far. So much delicious functionality, I'm tempted to donate twice!

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
MadBit
Valued Member
9
Years of Service
User Offline
Joined: 25th Jun 2009
Location: Germany
Posted: 12th Dec 2011 14:02
Thank you for this great IDE. But can you insert a function to rescan the keywords? This makes it easier to write plugins. The one without constantly deleting the keyword list by hand.

With Computers you can solve Problems that you have never befor.
Share your knowledge. It's a way to achieve immortality. (Tenzin Gyatso)
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 12th Dec 2011 22:12 Edited at: 13th Dec 2011 01:42
BFM,

I could not duplicate the error by right clicking and selecting 'Insert Keystate'. Could you send me the error message that you are receiving? [edit]I think I found it. An old '.config' file. The Debug and Release versions had different ones. So as I'm testing with the Debug version no issues. Then I thought, "BFM isn't running the Debug version. He's got the Release version." So I fired that up and got the error. I dropped in the '.config' from Debug. And the error stopped. Once I get MadBit's request in, I'll upload the whole lot.[/edit]

MadBit,

That should be easy enough. Expect to see it in the next beta.

All the best,

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 14th Dec 2011 22:53
Another bug Balid,

Take this simple, useful code;



Now I find that when I try to modify anything my code, such as changing Value2# to Value3# I get an unhandled exception;



The error is easily dismissed, but is very repetitive making life tough.

In my options file, I have the "Auto Complete Parenthesis" turned off too, although turning it on doesn't resolve this error.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 15th Dec 2011 16:56 Edited at: 15th Dec 2011 19:50
BFM,

Sorry but I am unable to duplicate the error with the information provided. Lets talk this through in regular email.

[edit]You must have 'Auto Suggest After' turned on. The error should be resolved now.[/edit]

[edit2]Uploaded v1.3.1 b4. Implemented MadBits suggestion and two defect fixes as reported by BFM. [/edit2]

Indigo Site

All the best,

Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 16th Dec 2011 08:48
Looking good mate. Definitely giving this a good work out over the Christmas break.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
MadBit
Valued Member
9
Years of Service
User Offline
Joined: 25th Jun 2009
Location: Germany
Posted: 17th Dec 2011 15:02
Thank you.

With Computers you can solve Problems that you have never befor.
Share your knowledge. It's a way to achieve immortality. (Tenzin Gyatso)
Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 30th Dec 2011 23:28
Happy new year Balid! Cheers for all of your efforts with your Indigo editor, you've both been fantastic!

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 31st Dec 2011 04:55
BFM,

Thank you. Hope you and yours have a safe and Happy New Year.

All the best,

BandP College Man
10
Years of Service
User Offline
Joined: 3rd Jul 2008
Location: Dorset (U.K.)
Posted: 3rd Jan 2012 19:14
This is not strictly a fault but I have always been a programmer that likes to put many comments in my code. I have noticed that if I have beautify turned on to produce uppercase keywords then they are also 'beautified' in comments as well. This means that words like 'and', 'to', and many other innocuous words used in comments are transformed to upper-case. Can comment lines be left out of the 'beautify' process?
BandP College Man
10
Years of Service
User Offline
Joined: 3rd Jul 2008
Location: Dorset (U.K.)
Posted: 3rd Jan 2012 19:23
I should have qualified my previous statement to say that it seems to occur only between Remstart and Remend comment blocks.
BandP College Man
10
Years of Service
User Offline
Joined: 3rd Jul 2008
Location: Dorset (U.K.)
Posted: 3rd Jan 2012 19:33
Something else as well!
I recently installed V1.3.1 Beta 4.
I open it up; save project file; save (blank) source file and then I get an error (see attached Image). Clicking continue allows me to carry on. I don't understand what's going on.

Attachments

Login to view attachments
Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 3rd Jan 2012 23:09
The IDE is working wonderfully.

Just a minor glitch so far; when a compiler error occurs, the IDE opens a new instance of the source file with the error line, but the file is already open. So for instance; if I make a mistake in a source file 1, after the compiler error; two instances of source file one are visible in the document tab, and you end up being taken to one of them. I am not sure why this happens.

Balid
15
Years of Service
User Offline
Joined: 21st Nov 2003
Location: MI, USA
Posted: 3rd Jan 2012 23:31
BandP College Man,

Thank you for the report. Those should be easy to address.


Chris Tate,

Interesting. I'll have to do some testing. Could you post a screenshot?

All the best,

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 4th Jan 2012 00:16
I just had a compiler error, but this time the problem did not occur. I will post a screenshot the next time it happens.

Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 4th Jan 2012 00:52 Edited at: 4th Jan 2012 00:56
Just a side note; the Replace tool replaces all occurances of text in all documents; even if 'Current Document' is selected.

Edit: also on the following line; when I searched for 'offset#', it only found and highlighted the first offset word, when next was pressed, it did not highlight the second occurance. Not sure if this is what was intended.



Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 4th Jan 2012 20:05
Here is a screenshot of the compiler error. The problem occurs after adding a new file to the project, saving it, then causing a compiler error; two instances of the source file end up open.



Grasmann
10
Years of Service
User Offline
Joined: 1st Sep 2008
Location:
Posted: 5th Jan 2012 07:09 Edited at: 5th Jan 2012 07:10
I know this error. It occures if you add a new source file and work on it. If you add the source file it isn´t listed in the list of source files. You can easily fix this by reopening the project.

Just hit CTRL+S and reopen the project from the list of recent projects under "File".

Not really the best solution but it works this way XD.

I had it myself many times but didn´t really bother to report it here, because it can be fixed so easily.

Login to post a reply

Server time is: 2019-02-16 04:07:12
Your offset time is: 2019-02-16 04:07:12