Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / Wrong parts of the car is moving...

Author
Message
Ghost Games
12
Years of Service
User Offline
Joined: 1st Aug 2007
Location:
Posted: 17th Dec 2010 06:19
Hi all

i had opened the Beach buggy from the DB Phy demo, made a custom car in 3ds max with the same parts as the one from DB Phy, named the parts the same and centret the pivit point at all objects. exportet it out as a .x file.

so i used the original code from the demo project, just replacing the model to see if it works. it can load the model, but when a try to move it. it the wrong body parts the are moving.

anyone has a clue what im proberly doing wrong??



thx.
LBFN
12
Years of Service
User Offline
Joined: 7th Apr 2007
Location: USA
Posted: 20th Dec 2010 14:37
Hi Ghost Games,

I see a couple of things. I would suspect that the limbs for the wheels are not numbered correctly. Determine what the actual limb numbers of the wheels are, and re-assign them.

Secondly, you are assigning two wheels to limb 5. The wheels must all be different limbs. From the demo:


You can see where the limbs are numbered 5, 7, 3 and 9, whereas your code has them numbered 5, 9, 5 and 7.

Hope this helps.

Login to post a reply

Server time is: 2019-09-15 15:15:54
Your offset time is: 2019-09-15 15:15:54