Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DLL Talk / DKShop and DKAVM plugins - a new version compatible with u7.7?

Author
Message
Duffer
16
Years of Service
User Offline
Joined: 9th Feb 2003
Location: chair
Posted: 9th Apr 2011 12:23 Edited at: 9th Apr 2011 13:27
It's a long-shot but I am going to try and email DmitryK and ask if he might create a version of his plugin which is compatible with DBPro u7.7.

When you install any of the release canditate versions of u7.7 and try and use pick limb demos from DKShop/DKAVM you get an error something like:- [with the project "Pick Limb - Limb Properties in the DKShop demos] "Runtime Error 7804. Matrix4 is Illegal at Line x" and it crashes - unlike earlier occasions when it just couldnt see the limbs...

I attach copy of the version(s) of the DKShop/DKAVM plugin compatible with [versions compatible with DBPro u5.9 through to...] DBPro u7.6 [which also includes all the dkavm/dkshop demos...] and also set out a useful link now below:-

http://forum.thegamecreators.com/?m=forum_view&t=175969&b=18

fingers crossed...

a long time dabbler with DBC and DBPro with no actual talent but lots of enthusiasm...

Attachments

Login to view attachments
Duffer
16
Years of Service
User Offline
Joined: 9th Feb 2003
Location: chair
Posted: 9th Apr 2011 12:28
and here is the link to the latest release candidates of u7.7:-

http://forum.thegamecreators.com/?m=forum_view&t=180294&b=1&p=0#m2178262

a long time dabbler with DBC and DBPro with no actual talent but lots of enthusiasm...
Duffer
16
Years of Service
User Offline
Joined: 9th Feb 2003
Location: chair
Posted: 9th Apr 2011 12:31
and here is the link to a more lengthy discussion re the error with DKShop and DKAVM and DBPro U7.7:-

http://forum.thegamecreators.com/?m=forum_view&t=180499&b=15

Quote from IamM on the subject:- "7.7 contained library changes, including to the 3D Maths commands which was quite a number of changes to enhance validation and add performance."

as I say I will email DmitryK (if he is still about) and see if he can release a version compatible with u7.7...

a long time dabbler with DBC and DBPro with no actual talent but lots of enthusiasm...
Duffer
16
Years of Service
User Offline
Joined: 9th Feb 2003
Location: chair
Posted: 18th Apr 2011 21:09
By way of update, I'd emailed DmitryK and his has emailed back(!). He is going to have a go at making his great plugins u7.7 compatible but it may take him some time. Nevertheless, great news (potentially).

a long time dabbler with DBC and DBPro with no actual talent but lots of enthusiasm...
Burning Feet Man
11
Years of Service
User Offline
Joined: 4th Jan 2008
Location: Sydney, Australia
Posted: 22nd May 2011 14:00
Fingers crossed. I've only just discovered the DKShop/DKAVM plugins and am most interested to review them.

Help build an online DarkBASIC Professional help archive.
DarkBasic Help Wikia
miso
9
Years of Service
User Offline
Joined: 16th Jun 2010
Location: Budapest, Hungary, 127.0.0.1
Posted: 24th Jul 2011 01:20
I'm using it too, so glad that DmitryK didn't abandon this useful plugin.

No place like 127.0.0.1 .
Duffer
16
Years of Service
User Offline
Joined: 9th Feb 2003
Location: chair
Posted: 24th Jul 2011 01:26
I'm waiting still to hear from DmitryK - plugin not compatible with latest versions of DBPro...

a long time dabbler with DBC and DBPro with no actual talent but lots of enthusiasm...

Login to post a reply

Server time is: 2019-10-17 03:26:46
Your offset time is: 2019-10-17 03:26:46