Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / Mixed graphics cards and PhysX

Author
Message
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 29th Sep 2011 17:07
Hi,

I've just plugged in my old Geforce 8600GT to add a second monitor to my system which already ran an ATI 4850. I would also like to take advantage of the onboard PhysX on the 8600, but I can't seem to get it working in hardware mode. Does anyone have any idea how to get it to work? I've heard of it being done before.

Nick
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 30th Sep 2011 18:48
Have you download the Nvidia physX drivers, if you have, have you open the Nvidia control planel and turned the physX chip on.

Dark Physics makes any hot drink go cold.
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 1st Oct 2011 13:20
It's installed and I've tested my PhysX based game with it, but it can't detect a PPU so runs in software mode only.

I've looked everwhere for the control panel. I remember it from when I used the 8600 as my main card, but I can't find it. As far as I can tell it should be under the 3D Settings catagory in the NVIDIA CP, but it's not there. Am I looking in the right place?

(Correction my ATI card is a 4800 not 4850! not that it makes any difference to this problem!)
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 1st Oct 2011 18:09 Edited at: 1st Oct 2011 18:10
should look something like this
[img]http://forum.thegamecreators.com/xt/xt_apollo_pic.php?i=2265367
[/img]
this is using windows 7 but should be the same if using xp.

Dark Physics makes any hot drink go cold.

Attachments

Login to view attachments
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 1st Oct 2011 18:11 Edited at: 1st Oct 2011 18:12
should look something like this



this is using windows 7 but should be the same if using xp.

Dark Physics makes any hot drink go cold.
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 2nd Oct 2011 12:07 Edited at: 2nd Oct 2011 12:08
I'm using WIndows 7 ultimate 64, and for some reason I only have the 2 top options in 3D settings. I'm not sure what I can do about that...

Thanks HowDo for your replies

www.illuminatedfx.com
For web design and custom GUI and 3D model design services.
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 2nd Oct 2011 13:23
I think I had this problem, did you let windows 7 install the drivers for your card or did you go and get them from nvidia, best to go and get the drivers as windows 7 does not always get it right.

Dark Physics makes any hot drink go cold.
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 2nd Oct 2011 13:40
At first I let it install the drivers, but then it immediately said that there was an update so I downloaded and installed the update. I can't remember if I looked at the CP before I updated it, but I have a feeling that's why I updated it. I'll see about uninstalling the card, then letting Windows install it again.

www.illuminatedfx.com
For web design and custom GUI and 3D model design services.
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 2nd Oct 2011 14:50 Edited at: 2nd Oct 2011 14:57
the latest physx drivers should be 9.10.0513, i think windows tries to put 9.10.0514 which does not work as it should.

Dark Physics makes any hot drink go cold.
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 3rd Oct 2011 14:18 Edited at: 3rd Oct 2011 14:18
I tried reinstalling the card with no success. As 514 version of PhysX is what it installed, but I do so happen to have 513 already downloaded, but it won't let me install it, even before 514 was installed. Do you think installing the card in my secondary x4 PCI-E slot might be stopping the PhysX working?

www.illuminatedfx.com
For web design and custom GUI and 3D model design services.
HowDo
16
Years of Service
User Offline
Joined: 28th Nov 2002
Location: United Kingdom
Posted: 3rd Oct 2011 15:11
getting 514 off the system so that you can install 513 takes some doing and I wish I could remember how I did it.

I think I did a big reinstall of windows 7 so that you basic loose everything, but I dont think you will want to go that far.

I think there is away in the windows install system which shows what update have been downloaded and install, I think you find the one to do with the driver or graphic card and tell it to uninstall them.

if you get it to unistall 514, then try the 513 version and it should hopfully work.

I know thats not very clear, but it might help a bit.

Dark Physics makes any hot drink go cold.
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 3rd Oct 2011 16:30
Hmm...

I first went into the CP and uninstalled Physics 514, tried to insteall 513. That didn't work so uninstalled all NVidia stuff. Let Windows install the card (which doesn't include PhysX. Tried manually installing 513...didn't work. Told it to install latest drivers which insluded 514. At this point I got dizzy and passed out

You're right...I don't really want to reinstall Windows. My system would take about a week to get going again!

www.illuminatedfx.com
For web design and custom GUI and 3D model design services.
dbpro2011
7
Years of Service
User Offline
Joined: 16th Oct 2011
Location:
Posted: 17th Oct 2011 00:58
after the optimization program, the program accelerated by 8-12%!

Attachments

Login to view attachments
NickH
11
Years of Service
User Offline
Joined: 19th May 2008
Location: Nova Prospekt, North Yorks, UK
Posted: 18th Oct 2011 12:50 Edited at: 18th Oct 2011 13:10
@dbpro, I don't think that'd make Mirrors Edge work in software mode at an acceptable frame rate. I need it to work in hardware mode. That's what this thread is about

www.illuminatedfx.com
For web design and graphic design services
mikeven
7
Years of Service
User Offline
Joined: 31st Dec 2011
Location:
Posted: 31st Dec 2011 20:45
Hi NickH

With this free tool "TechPowerUp - GPU-Z 0.5.7" you can check if Nvidia Physx Hardware acceleration is enabled on your system.

If Nvidia Physx hardware acceleration is enabled, then I suggest you to try "water.exe" or "water.dbpro" (the version with the logo "Physx by NVIDIA" - see attachment -, not the older one) that you can find in this folder : "Program Files (x86)\The Game Creators\Dark Basic Professional Online\Projects\Dark Physics\Competition 2008\Water".
(it was included with "Dark Physicx - DB Pro Update - 1.05 (24th May 2010).

if this instruction works : "phy start 1,0,1" in your project, then your Physx hardware acceleration is enabled in your Nvidia Control Panel and furthermore it is identified by DB PRO.

Attachments

Login to view attachments

Login to post a reply

Server time is: 2019-08-22 06:08:15
Your offset time is: 2019-08-22 06:08:15