Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Program Announcements / SPARK 3D Particle Engine wrapper 1.2 for DBPro

Author
Message
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 21st Nov 2011 03:39 Edited at: 14th May 2013 14:40
VERSION 1.2.4 Released !!!!!!!!!!!!


Latest version : 1.2.4 (21.04.2013)
Download available as an attachment in this post !

Some Demo videos :

Demo Video (created with older version of the plugin)

Subtractive Blending 1 (black particles)
Subtractive Blending 2 (black particles)
Subtractive Blending 3 (Coloured particles)
Advanced Explosion




Version 1.2.4 changelog :




Version 1.2.3 changelog :


Version 1.2.2 changelog :


Version 1.2.1 changelog :


Version 1.2 changelog :



About SPARK:




CLICK HERE TO DOWLOAD THE GDK VERSION !!

NOTE : If you using SPARK wrapper in your GDK game , you need to run the exe in XP SP2 compatibility mode ! (this applies only to win7 64 bit users !)


Known Bugs :

Spaces are not allowed in the texture name /path when saving a system with SP SAVE SYSTEM command
The Line trail renderer's scale is wrong.


COMING SOON : Particle Pack ! More than 15 Game ready particle effects for developers who don't want to waste time "coding" particles systems.The pack contains : rain , explosions , bullet hits , smoke , fire
Simply Load the system you need with one command and thats all ! No programming needed !!

Thanks for everyone , especially for IanM who helped me with the render sequence !

And one more thing... The wrapper is completely free ! However if you find it useful >> PLEASE DONATE << because i BADLY need a new HDD and a Graphics card ... Thanks in advance...

CLICK HERE TO MAKE A DONATION


[href=forum.thegamecreators.com/?m=forum_view&t=191567&b=5]Spark Particle engine[/href]
[href=forum.thegamecreators.com/?m=forum_view&t=199163&b=5]Transform gizmo plugin[/href]

Attachments

Login to view attachments
Stab in the Dark software
Valued Member
16
Years of Service
User Offline
Joined: 12th Dec 2002
Playing: Badges, I don't need no stinkin badges
Posted: 21st Nov 2011 15:08
HotLine,

Great work, we can really appreciate the amount of work that goes into creating software.
We will definitely use this in our projects and on that note we have made a donation.

[img][/img]


WindowsXP SP3,Vista,Windows 7 SP1, DBpro v7.7RC7
Stab In The Dark Editor
The coffee is lovely dark and deep,and I have code to write before I sleep.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 21st Nov 2011 15:41
Quote: "HotLine,

Great work, we can really appreciate the amount of work that goes into creating software.
We will definitely use this in our projects and on that note we have made a donation."


Thank you !
By the way i tried the S.I.T.D.E and it was awesome ! Great work !

Jeff Miller
14
Years of Service
User Offline
Joined: 22nd Mar 2005
Location: New Jersey, USA
Posted: 23rd Nov 2011 13:39
Great documentation and well-commented demos.
One minor documentation issue: command "sp add emitter attacher modifier" seems to be missing from the .ini file in the Keywords folder.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 23rd Nov 2011 17:44 Edited at: 23rd Nov 2011 17:45
Quote: "Great documentation and well-commented demos.
One minor documentation issue: command "sp add emitter attacher modifier" seems to be missing from the .ini file in the Keywords folder. "


Sorry for that I fix this ASAP

Daniel wright 2311
User Banned
Posted: 27th Nov 2011 07:19
Some of your examples dont work right or look right,like when I try your 02_PointSpriteDemo, all i get is a bunch of balls falling every where,but in the demos file I get sparks. Even in the frist example,the basic demo,when I run it from dark basic pro all I get are planes textured with a fire texture moving upward with no effect at all. But when I run the demo version I get a perfect effect.

All of the files are in the correct folders so I guess its my pc.

my signature keeps being erased by a mod So this is my new signature.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 27th Nov 2011 12:08
Quote: "Some of your examples dont work right or look right,like when I try your 02_PointSpriteDemo, all i get is a bunch of balls falling every where,but in the demos file I get sparks. Even in the frist example,the basic demo,when I run it from dark basic pro all I get are planes textured with a fire texture moving upward with no effect at all. But when I run the demo version I get a perfect effect.

All of the files are in the correct folders so I guess its my pc."


Well youre the first who have had this problem so it might be your PC... No idea what should cause this... what graphic card you using ?

Iceman
16
Years of Service
User Offline
Joined: 10th Jan 2003
Location:
Posted: 27th Nov 2011 13:33
Hotline.. brilliantly done m8. A real time saver this. Looking forward to the Particle Pack.
Chris Tate
DBPro Master
10
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 27th Nov 2011 15:47
Very impressive. It is well documented and organized.

It is not only the best looking particle system I've tested so far, it is also the largest, feature wise. It gives you more control and allows you to save your settings in memory or to file.

Do not overlook this guys.

Being able to add systems, groups and emitters is far more ideal than having to deal with one level of detail. You can spot the difference straight away.

[Note that the video title has been named with 'Baasic' rather than Basic]

Daniel wright 2311
User Banned
Posted: 27th Nov 2011 18:09
Quote: "what graphic card you using "


Its not my graphics card as the other exampes and demos work,if the demos work from your demos folder it cant be my graphics card,it has to be the examples code.

my signature keeps being erased by a mod So this is my new signature.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 27th Nov 2011 20:36 Edited at: 27th Nov 2011 20:38
Quote: "Hotline.. brilliantly done m8. A real time saver this. Looking forward to the Particle Pack."


Thanks ! I'm busy with my other project , but it will be ready soon !

Quote: "
Very impressive. It is well documented and organized.

It is not only the best looking particle system I've tested so far, it is also the largest, feature wise. It gives you more control and allows you to save your settings in memory or to file.

Do not overlook this guys.

Being able to add systems, groups and emitters is far more ideal than having to deal with one level of detail. You can spot the difference straight away.

[Note that the video title has been named with 'Baasic' rather than Basic]"


Thanks ! Regarding to the title , i was in a hurry and uploaded with wrong title , and i can't chang it... sorry about that


Quote: "Its not my graphics card as the other exampes and demos work,if the demos work from your demos folder it cant be my graphics card,it has to be the examples code."


Good point ...

Daniel wright 2311
User Banned
Posted: 27th Nov 2011 21:12 Edited at: 27th Nov 2011 21:26
here is your basic demo code, look it over and see if there might be any mistakes please.

i love this and realy need it and i thank you for making it.

if its not the code then it has to be the .dll you provided or mabey you left out a .dll file somehow? becouse your demos work just fine and this tells me 2 things.

its the code, or i am missing a .dll

EDIT:RAIN DOES NOT RENDER EITHER,ITS JUST A BUNCH OF BLACK LINES ALL SCRAMBLED.








my signature keeps being erased by a mod So this is my new signature.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 27th Nov 2011 22:18
Quote: "here is your basic demo code, look it over and see if there might be any mistakes please.

i love this and realy need it and i thank you for making it.

if its not the code then it has to be the .dll you provided or mabey you left out a .dll file somehow? becouse your demos work just fine and this tells me 2 things.

its the code, or i am missing a .dll

EDIT:RAIN DOES NOT RENDER EITHER,ITS JUST A BUNCH OF BLACK LINES ALL SCRAMBLED."


1st Ensure you downloaded the latest version of spark wrapper (see my first post attachment)

2nd Remove the SP UPDATE from your code since the rendering is done in dbpro's SYNC command , so SP UPDATE is now obsolete !
(i can't understand how did you even compile this code... as the SP UPDATE command does not exist in the latest version )

3rd Make sure you using the demos that comes with the latest version !

Please let me know if it helped
Regards

Daniel wright 2311
User Banned
Posted: 27th Nov 2011 23:16
Ok, I did everything you asked my good friend and I still get the same problems,I downloaded your updated download in the first post, I replaced everything on all of my dlls, I then replaced the projects files and I still get messed up rain,and messed up plains for the first project. There are other also that are messing up,here is the new code for the first project just to make shure I am using the correct code.


first project


rain


my signature keeps being erased by a mod So this is my new signature.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 28th Nov 2011 06:52
Ok ! I have and idea ! please compile the demo 1 , ( make sure when you run the exe the particles are messed up ) then upload here , so i can test it and see if your compiled exe causes the same issue on my machine...

Daniel wright 2311
User Banned
Posted: 28th Nov 2011 07:26 Edited at: 28th Nov 2011 07:28
ok, here it is my friend, in the download.

my signature keeps being erased by a mod So this is my new signature.

Attachments

Login to view attachments
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 28th Nov 2011 08:49
Well , never saw an issue like this before... It seems that particle color's alpha is reverted ?? particles born with alpha = 0 and die with alpha=255 , but in the code is ok ! The rgb color is constant either ... The texture is messed up , like the atlas dimension interpolator has no effect in your code ... Also i see you set fullscreen on , ensure you call SP INIT after SET DISPLAY MODE

Not sure 100% but probably this issue is caused by DBPro and/or operating System... (when i started your exe i get a security warning message ? i never get warning messages when run DBPro exe's compiled by another users)

What is your operating system ?
Which version of DBpro you are using ?
Which Editor ?

I really want to help you , but i'm affraid this isn't a bug in the wrapper , i hope other people will compile the demos so we can see is there a similar issue in other users code too ?

Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 28th Nov 2011 12:58
The new 1.2.1 version is available !!! See the first post for details

PS > Wow ... just wow !! This new subtractive blend mode is awesome ! If anyone searched a solution for black smoke effect , well then this is definitely for you !

Stab in the Dark software
Valued Member
16
Years of Service
User Offline
Joined: 12th Dec 2002
Playing: Badges, I don't need no stinkin badges
Posted: 28th Nov 2011 17:14
HotLine,

I ran Daniel Wright’s compiled demo. I don’t see any particles at all.
The only way I can duplicate the results of the way Daniel Wright’s compiled demo runs on my pc is to not call SP INIT after SET DISPLAY MODE.

I have compiled all your demos and have had no problems.
While setting up in one of our projects I did find one minor bug.
If there are spaces in the name of a file in the directory where the textures are it can not find them. Also the parameters for SP LOAD SYSTEM are incorrect in the .ini file.

So far I tested on; Windows XP, DBPro 7.7 RC7 and of course Stab In The Dark Editor. I will test on our Vista and Windows 7

Thanks for the update.

[img][/img]


WindowsXP SP3,Vista,Windows 7 SP1, DBpro v7.7RC7
Stab In The Dark Editor
The coffee is lovely dark and deep,and I have code to write before I sleep.
Daniel wright 2311
User Banned
Posted: 28th Nov 2011 17:20
Quote: "What is your operating system ?"


I use vista

Quote: "Which version of DBpro you are using ?"


the newest one,Im not shure of the number,lol.


Quote: " Which Editor ? "


Bolth of the ones that come with dark basic pro,the newest one and the old one just to test it becouse I thought it might be the editor.

Well this puts on a whole new meaning of dark basic pro to me,I have a half decent pc,and when I finish any game then I will know half the people out there will not see the effects properly,Now that I know its not your code or dlls It is dark basic pro on some computers and this well,sucks.

Its a funny thing, Any game I buy off the internet plays just fine on my pc,But fpsc and or dark basic pro, and my pc is just a regular laptop runing window vista.

My pc does run every effect for Benge's Animated Sprite Pack,But I thought yours where well, better.

my signature keeps being erased by a mod So this is my new signature.
Daniel wright 2311
User Banned
Posted: 28th Nov 2011 17:24
Quote: "I ran Daniel Wright’s compiled demo. I don’t see any particles at all."


It needs to be in the folder where the media is so it can load the texture. Just drop it in the same folder your regular main program is,just over write it with mine.

my signature keeps being erased by a mod So this is my new signature.
Stab in the Dark software
Valued Member
16
Years of Service
User Offline
Joined: 12th Dec 2002
Playing: Badges, I don't need no stinkin badges
Posted: 28th Nov 2011 18:37 Edited at: 28th Nov 2011 18:38
Daniel Wright

I tested again with exe in folder with media. I know see the Particles as you described. Since your not sure what version of DBPro your using try updating to DBPro to version 7.7 RC7. Here is the link.


http://forum.thegamecreators.com/?m=forum_view&b=1&t=180294&p=0

[img][/img]


WindowsXP SP3,Vista,Windows 7 SP1, DBpro v7.7RC7
Stab In The Dark Editor
The coffee is lovely dark and deep,and I have code to write before I sleep.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 28th Nov 2011 21:31 Edited at: 28th Nov 2011 22:21
Quote: "HotLine,

I ran Daniel Wright’s compiled demo. I don’t see any particles at all.
The only way I can duplicate the results of the way Daniel Wright’s compiled demo runs on my pc is to not call SP INIT after SET DISPLAY MODE.

I have compiled all your demos and have had no problems.
While setting up in one of our projects I did find one minor bug.
If there are spaces in the name of a file in the directory where the textures are it can not find them. Also the parameters for SP LOAD SYSTEM are incorrect in the .ini file.

So far I tested on; Windows XP, DBPro 7.7 RC7 and of course Stab In The Dark Editor. I will test on our Vista and Windows 7

Thanks for the update."


Thanks for testing the engine !! greatly appreciated ! Well i tested with S.I.T.D.E too and the compiled demos run fine.Also just tested on one of my friends PC with Win7 64bit and everything worked fine... no issues at all. Regarding to the path names it seems it's an internal issue...will fix it in the next release , and the SP LOAD SYSTEM documentation too , till then i will add it to the "known bugs" section...

Quote: "I use vista"

Not sure but maybe this causes the issue... unfortunately i can't test on vista , i'm using XP Sp2 and all my friends using XP or Win7 so i can't test it on vista , sorry about that ...

EDIT : i'm 99% sure Vista causes the issue just type in "vista" in the search box and you will see how many users have various issues runing DBPro on vista... Try run in compatibility mode for Xp or win98... maybe it helps...

Also it's recommended to read this tread

Please read all the posts in the thread carefully maybe you find something useful to correct the issue!

EDIT2 : Just read some of the posts in the thread well runing DBpro with some plugins seems more complicated than i thought at first...

Daniel wright 2311
User Banned
Posted: 28th Nov 2011 22:41
Quote: "try updating to DBPro to version 7.7 RC7. Here is the link."


thanks, i did, it did not work


Quote: "run in compatibility mode for Xp or win98... "


thanks. I tryed that with no luck,thanks for trying.

my signature keeps being erased by a mod So this is my new signature.
Stab in the Dark software
Valued Member
16
Years of Service
User Offline
Joined: 12th Dec 2002
Playing: Badges, I don't need no stinkin badges
Posted: 29th Nov 2011 01:16
I have tested on our Vista notebook. It is running Vista Home Premium Service Pack 2.
All the examples compile correctly using DBPro version 7.7rc7


[img][/img]


WindowsXP SP3,Vista,Windows 7 SP1, DBpro v7.7RC7
Stab In The Dark Editor
The coffee is lovely dark and deep,and I have code to write before I sleep.
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 29th Nov 2011 01:39
Quote: "I have tested on our Vista notebook. It is running Vista Home Premium Service Pack 2.
All the examples compile correctly using DBPro version 7.7rc7"


it seems that the wrapper is Ok then...
BTW i can't express how much you help me with these tests... when i finished the engine i have no time to test it correctly so most of the commands are untested , but should work though...
Thanks !

Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 30th Nov 2011 05:03
Hi everyone ! I just made a new really cool and professional explosion with the wprapper !!! The demo is attached to the post.
NOTE : make sure you turn down your speakers because theres an explosion sound in the demo ... i dont want to you guys have a heart attack

and a demo video (unfortunately the quality is really really bad... so its recommended to download the exe) use up down keys to move and mouse to rotate the camera... have fun with it

Attachments

Login to view attachments
gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 9th Dec 2011 09:00
@Hotline

hi

I just found this post

I was wondering if you could add one option ?

liquids

not the splash part that you did in "03_RainDemo"
but more like water Pouring out of pipe and building up
so it makes a large puddle and with that the option to have it any color
and to control the thickness so it can flow fast or slow

with what you got now it should only be a few more steeps
to achieve or in my case like building a full size house
with the tiniest rocks

to move side ways - is to move forward
Since a Strait line gets thin fast
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 9th Dec 2011 15:03
Quote: "@Hotline

hi

I just found this post

I was wondering if you could add one option ?

liquids

not the splash part that you did in "03_RainDemo"
but more like water Pouring out of pipe and building up
so it makes a large puddle and with that the option to have it any color
and to control the thickness so it can flow fast or slow

with what you got now it should only be a few more steeps
to achieve or in my case like building a full size house
with the tiniest rocks"



Hi ! I'm not quite sure what exacly you looking for but i will upload an example of a "fountain" effect which probably does the same thing .The problem is that i'm really busy with some other projects recently so i can't promise i will upload it today or tomorrow but will upload it ASAP !!!!

Simulating fluids it's not complicated using SPARK. All you have to do is to make a group with a spheric (or straight) emitter ( because this way you can specify the direction of the particles) and add gravity modifier to the group with negative force on the Y axis . Because you will simulate 20000+ particles , it's recommended to use a point sprite renderer , which is more optimized for these kind of things. The color can be easily set with one of the color interpolators.

Regards

gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 10th Dec 2011 10:21
@Hotline

I understand

it dose give me some ware to start

thanks

to move side ways - is to move forward
Since a Strait line gets thin fast
gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 11th Dec 2011 16:59
I was trying out all the demos
and found typo in #3 "RainDemo"

I've correct that and tweaked to that
the user has a range from 0 to 100

it was just one number off

to move side ways - is to move forward
Since a Strait line gets thin fast

Attachments

Login to view attachments
GeeBee
10
Years of Service
User Offline
Joined: 26th Aug 2008
Location:
Posted: 12th Dec 2011 08:35
Hotline

The negative blending update works fine for 'black', but I don't seem to be able to produce shades of grey (eg any RGB combination of r=g=b or close variations thereof).

Any reason why this would be the case? Or am I demonstrating my duffer abilities again...

GeeBee

Habits can get you into trouble sometimes (unless you are a nun....)
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 12th Dec 2011 21:29 Edited at: 13th Dec 2011 07:31
Quote: "The negative blending update works fine for 'black', but I don't seem to be able to produce shades of grey (eg any RGB combination of r=g=b or close variations thereof).

Any reason why this would be the case? Or am I demonstrating my duffer abilities again..."


Actually thats normal... You can get grey color but it won't be easy

The subtract blending (like it says) subtracts the quad color from background color.So lets say you have a bacground pixel with rgb 100,100,100 and particles with rgb 32,32,32
that means rgb(100,100,100) - rgb(32,32,32) = 68 which is ok , but if you render more than 10 particles on top of each other (like in demo21) the result color will always end up with black (rgb(0,0,0)) color , because :

rendering quad1 with color will cause
background - quad1 = rgb(68,68,68) <- this is the new bgrnd color
background - quad2 = rgb(36,36,36) <- this is the new bgrnd color

which is far too dark but if you render just one more :

background - quad3 = rgb(0,0,0) <- this is the new bgrnd color

you will end up with black color.And you rendered ONLY 3 particles on top of each other ! Just imagine what happens if you render 10 !

To solve this you can try :
-render smaller amount of particles (change the #flow parameter in the emitter to a lower value like 3 or 4)
- use very low values in the interpolator like
SP ADD RGBA INTERPOLATOR group , 0x050505ff , 0x05050500
-set the backdrop to brighter color
-Tweak these parameters until you are satisfied with the result

PS: Same thing happens when you use additive blending , except you will have white color rgb(255,255,255)

i will try to change some render states in the next update to get more control over the color

Regards

GeeBee
10
Years of Service
User Offline
Joined: 26th Aug 2008
Location:
Posted: 13th Dec 2011 13:27
Hotline

Thank you - nicely explained. This has helped slightly now that I can picture what is happening as I tweak the various parameters.

In my case, the background might vary from blue sky / white cloud / Green terrain as the particle effect represents artillery bursts and/or destroyed vehicles.

when I try the other modifications you suggest, I find the overall result is not as pleasing.

However, I certainly have more than I did before you released this plugin, so I'm still a happy punter!!

GeeBee

Habits can get you into trouble sometimes (unless you are a nun....)
Clonkex
Forum Vice President
9
Years of Service
User Offline
Joined: 20th May 2010
Location: Northern Tablelands, NSW, Australia
Posted: 14th Dec 2011 02:37
Downloading now.

Looks good, will probably use this in my new Mist Engine that I am developing (along with my Bullet Wrapper, for all of you who think I have deserted it).

Clonkex

gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 14th Dec 2011 05:52
the demo that has the rockets blowing up

07_GlueDemo

I want to have the fire trail longer

I thought I had it with

sp set system speed trailProto

but the last peace dose not change any thing

to move side ways - is to move forward
Since a Strait line gets thin fast
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 14th Dec 2011 09:48
Quote: "the demo that has the rockets blowing up

07_GlueDemo

I want to have the fire trail longer

I thought I had it with

sp set system speed trailProto

but the last peace dose not change any thing"


Hi ! The SET SYSTEM SPEED only sets the Update speed of a system... its similar like SYNC RATE in DBPro... if you want to have particles with longer lifetime just set the groups lifetime to higher value.



NOTE : In this case the partilces will live longer in this group, so the group will probably exceed his capacity , so you might change the capacity too.If your group exceeds his capacity , the group will emit particles intermittently ! Because the group will wait until at least one particle dies , so there will be again a "free particle slot" in the group's buffer.

To get rid of this you shall change :



Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 14th Dec 2011 10:01 Edited at: 14th Dec 2011 10:01
Quote: "Downloading now.

Looks good, will probably use this in my new Mist Engine that I am developing (along with my Bullet Wrapper, for all of you who think I have deserted it).

Clonkex"


Thanks ! I already using SPARK in my game ! What i really like in this engine is the Reference counting ! This ensures automatic destruction of a system if it becomes inactive ,And it also ensures 100% memory leak free desctuction ! No additional code needed for checking inactive systems so you can focus more on game development instead of writing hundreds lines of pointless code. Normally this feature can be turned off and you can delete particle systems manually if you wish !
Regards !

GeeBee
10
Years of Service
User Offline
Joined: 26th Aug 2008
Location:
Posted: 20th Dec 2011 20:54
Hotline

If I have saved a particle system, and then reloaded it into a program, is possible to modify the parameters - eg gravity, in order to represent varying wind strengths? (I can see the parameters listed in the saved output html file.)

Or do I need to create the particle system in the main program code in order to have the parameters available for subsequent manipulation?

GeeBee

Habits can get you into trouble sometimes (unless you are a nun....)
Clonkex
Forum Vice President
9
Years of Service
User Offline
Joined: 20th May 2010
Location: Northern Tablelands, NSW, Australia
Posted: 21st Dec 2011 09:24
After testing....this is brilliant!

I love it! It's the most powerful, flexible and feature-rich particle system I have ever seen! Thankyou, thankyou! This will definitely go into my Mist Engine!

Clonkex

Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 21st Dec 2011 11:03
Quote: "If I have saved a particle system, and then reloaded it into a program, is possible to modify the parameters - eg gravity, in order to represent varying wind strengths? (I can see the parameters listed in the saved output html file.)

Or do I need to create the particle system in the main program code in order to have the parameters available for subsequent manipulation?

GeeBee"


Absolutely ! See the load demo , or you can do it in a very simple way. When you create your Emitters , renderers , modifiers ...etc
and add a unique name for them with SP SET NAME and anytime you need a handle to any spark element just call SP GET ID BY NAME and the returned handle will be the handle to the element (renderer modifier , emitter etc)



In case you working with instances (lots of systems of same type) you can follow the load demo to see how to get the correct handle to the elements.And there's also a command : SP GET TYPE which returns the type of an element (DBP_SPHERICEMITTER or DBP_GRAVITYMODIFIER , DBP_SYSTEM etc for details see the help) Just call the command on any of your element and it will return the type of the element ! If you still have problems , maybe i will have time to write a small tutorial...


Quote: "After testing....this is brilliant!

I love it! It's the most powerful, flexible and feature-rich particle system I have ever seen! Thankyou, thankyou! This will definitely go into my Mist Engine!

Clonkex"


Thanks Clonkex !

GeeBee
10
Years of Service
User Offline
Joined: 26th Aug 2008
Location:
Posted: 4th Jan 2012 20:33
Hotline - sorry, but I'm stuck.

I can achieve parameter manipulation (a modifier) on a single system instance only (the first one) using the 'Get ID by name' as you suggested. I want to apply individual parameters across the various copies (multiple instances).

I can't see how to apply a different set of parameters to any specific system copy, as the 'Set Modifier Commands' don't have the hierarchy eg "SP Set Gravity System A, Group B, Modifier C, x,y,z" that I would have thought necessary.

What have I missed?

Habits can get you into trouble sometimes (unless you are a nun....)
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 5th Jan 2012 15:00
Hi ! Yes you are right ! Thats because the SP GET ID BY NAME searches the whole scene and returns the id of the first element found... but if have lots of instanced systems... then it wont work properly .. the first found is returned other instances are ignored... sorry it's my fault ! i will upload a new version tonight where a systemID is allowed as a parameter in SP GET ID BY NAME

so from now on you can specify which System to search :



Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 8th Jan 2012 17:12
New version available (first post)... Now working on a musroom cloud modifier...

gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 8th Jan 2012 18:48
@Hotline

thanks ;o)

one other one I thought about
is tornado or hurricane

that should cover over possibility

fyi Hotlne I made my Donation ;o)
please keep up the good work

to move side ways - is to move forward
Since a Strait line gets thin fast
gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 8th Jan 2012 19:04
@Hotline

umm I've been on your website

I could not find examples in 1.23

SPARK Fountain demo - the spell check for fire fox says --> "Foutain" spelled wrong - see missing the "n"

SPARK Galaxy demo
SPARK Flakes demo

any possibility of them showing up soon please ?

to move side ways - is to move forward
Since a Strait line gets thin fast
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 8th Jan 2012 22:06
Quote: "umm I've been on your website

I could not find examples in 1.23

SPARK Fountain demo - the spell check for fire fox says --> "Foutain" spelled wrong - see missing the "n"

SPARK Galaxy demo
SPARK Flakes demo

any possibility of them showing up soon please ?"


Hi thanks for the donation !! Highly appreciated !
Well i do not have a website for Spark wrapper... I thing you were on the Official SPARK website.. (http://spark.developpez.com)
Thats not my site , and the demos on the official site are made with SPARK1 engine . My wrapper uses SPARK2 engine (which isn't released yet officially but it is way more feature rich and stable than SPARK1)

Regarding the examples , i can make similar demos (like flakes and fountain) if you wish , but i don't think i can port exacly the same as those in SPARK1 because SPARK2 has completely different structure...

Quote: "I could not find examples in 1.23 "


Are you sure ? Did you downloaded from my first post ?
Just downloaded it and everything seems ok to me...

And finally for the tornado and galaxy effect : Just started implementing new zones and modifiers to my wrapper which are necessary for those effects . Will be ready soon.

Regards ! And thanks for using SPARK2 Wrapper !!!! I hope you find it useful !

gwheycs62egydws
9
Years of Service
User Offline
Joined: 17th Aug 2009
Location: The World
Posted: 8th Jan 2012 22:21
I did not know about there being two similar but different engine's

the Sparks 2 engine is the only one that matters to me as c++ is beyond
my skill level at this point

I would think there would be some differences between the two engine's
but ever soo slightly

I did the update and noticed some of the dba's were smaller in size when I was
replacing them but of the examples provided all worked

I would appreciate having those examples created
I know it's a bit of work to create such

umm what I should have said I could not find the 3 example's
that I thought were missing ;oP

every thing showed up fine , sorry about that mistake on my part

creating particles even with dbp can only take you so far

Spark 3d Particle Engine Wrapper closes a lot more doors
and expands DBP options , and have a much smaller file size to load up
speeds things up greatly

to move side ways - is to move forward
Since a Strait line gets thin fast
tschwarz
14
Years of Service
User Offline
Joined: 13th Feb 2005
Location: 127.0.0.1
Posted: 9th Jan 2012 21:32
I remember you saying you might write a particle editor a while back. Is that still a possabilty?

Shall we play a game?” - Joshua
Hotline
10
Years of Service
User Offline
Joined: 22nd Aug 2008
Location:
Posted: 9th Jan 2012 22:29
Quote: "I remember you saying you might write a particle editor a while back. Is that still a possabilty?"


Yes... But first i want to finish the engine... to have a
"finished" engine i need to implement 1 zone and 2 modifiers .

Regards

Login to post a reply

Server time is: 2019-06-15 22:33:53
Your offset time is: 2019-06-15 22:33:53