Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / I'm having problems with Evolved shaders

Author
Message
Hawkblood
10
Years of Service
User Offline
Joined: 5th Dec 2009
Location:
Posted: 26th Feb 2012 19:55
A few of the downloads work fine with the example executable, but when I compile the project, I get a black screen with lights on the "Soft Shadows" and a blank green screen with the "Post Bloom".
I think I've narrowed it down to something with the effect. For instance, if I rem out the assignment
Quote: "dbSetObjectEffect(1,1);"
in the Soft Shadows example, the lights cull properly as if the object is there, but when I use the
Quote: "dbSetObjectEffect(1,1);"
, the lights leave a trail (because the backdrop is off) and they don't cull......


Does anyone know what is going on?

The fastest code is the code never written.
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 26th Feb 2012 20:00
I always had problems to, I think some recent updates broke the commands.
Hawkblood
10
Years of Service
User Offline
Joined: 5th Dec 2009
Location:
Posted: 26th Feb 2012 20:49
Crap! I wanted to use those effects in my next game. I wonder if there is a workaround.....

The fastest code is the code never written.
Morcilla
17
Years of Service
User Offline
Joined: 1st Dec 2002
Location: Spain
Posted: 3rd Mar 2012 19:37
I'll be glad to help.
Please post the whole test project so we can give it a try.

All shaders that I've tested run fine and there's nothing broken regarding shaders in DGDK, although Evolved ones use to be kind of tricky.

Charles
15
Years of Service
User Offline
Joined: 11th Jul 2004
Location: Phoenix, AZ USA
Posted: 21st Apr 2012 18:42
I've been having problems with shaders, as well. I found out that the "ps_1_1" macro for the pixel shader is no longer supported. When I changed it to "ps_2_0" for the pixel shader, the FX file worked just fine on both Dark BASIC as well as DaekGDK. See if that works.
Hawkblood
10
Years of Service
User Offline
Joined: 5th Dec 2009
Location:
Posted: 24th Apr 2012 00:37
DUDE! That was it. I had to change all the shaders for "ps_2_0".
I noticed some z-fighting, so I also adjusted the "StencilShadow.fx" from 0.1 to 0.5

You'll see it in the .fx

I must admit at first I was skeptical because Decepticons are the enemy.

The fastest code is the code never written.
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 24th Apr 2012 16:18
Holy crap! Thanks Charles, I just got soft shadows to work
Charles
15
Years of Service
User Offline
Joined: 11th Jul 2004
Location: Phoenix, AZ USA
Posted: 27th Apr 2012 08:12
Aww... Shucks, guys. Glad I was able to help.

Login to post a reply

Server time is: 2020-02-20 07:57:47
Your offset time is: 2020-02-20 07:57:47