Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / ddraw.lib not found?

Author
Message
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 00:55
Hi everyone


I'm not sure how to fix this. Apparently ddraw.lib is missing from my computer. Here's the error:



TheComet

Hawkblood
10
Years of Service
User Offline
Joined: 5th Dec 2009
Location:
Posted: 24th Apr 2012 00:59
Is this a new problem for you?

ddraw.lib is a part of DX. If you are missing it, you could just download it from Microsoft.

The fastest code is the code never written.
WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 01:01
2 ways: either re-install DirectX SDK or search on your HD if there's another copy of the lib file hidden somewhere.

I'd personally go for the SDK re-install...

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 24th Apr 2012 02:25
The new SDK dropped support for DirectDraw, so you can only use the SDK from August 07 unless you modify the DGDK source.

What is your DXSDK version?
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 07:32
I followed all of the installation steps and installed the DirectX 9.0c AUG 2007 SDK. I noticed that when installing DGDK it told me it didn't recognise the required DX version. Maybe that's the problem?

TheComet

WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 13:37
You have to install the Aug 2007 SDK first before installing Dark GDK. So long as the steps are followed (even down to the run VS2008C++ once before after installing it), it should install fine.

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 14:30
The thing is I did install the DX SDK before I installed GDK. But for some reason GDK didn't recognise I had it installed.

TheComet

Hassan
10
Years of Service
User Offline
Joined: 4th May 2009
Location: <script> alert(1); </script>
Posted: 24th Apr 2012 15:12
did you run visual C++ at least once before installing DX?

WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 15:31
As Hassan says, if Visual Studio C++ hasn't been run for the first time before installing anything else, the environment variables don't get set up and the DX installation will not attach itself to any SDK's...

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 16:19
Yep, I wrote a small "hello world" program in VC++ and compiled it successfully. Then I uninstalled DX, re-installed it, and finally I re-installed DGDK. Unfortunately, I still get the same error.

TheComet

WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 16:34
And you're using the Visual Studio wizard to set the project up for you?

Weird... (That's a similar problem I keep having with Code Blocks but you can't use DGDK with Code Blocks)...

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 16:53
Quote: "And you're using the Visual Studio wizard to set the project up for you?"


Yes.

Quote: "Weird... (That's a similar problem I keep having with Code Blocks but you can't use DGDK with Code Blocks)..."


I'm pretty sure you can use GDK with Code Blocks. There's no reason why it shouldn't work, you just need to set the build options correctly. I've played around with it too and have managed to get it to compile successfully. The linker reports just one conflicting library, but when I search for it on my computer, it seams it doesn't exist.

TheComet

WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 17:49
Attached are the x86 and x64 ddraw.lib files from my sdk install. Might be worth a try to see if placing them in the correct folder (screen shot in archive too).

Good luck man... I just hope you don't have to go through the rigmarole of un-installing everything and starting again...

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!

Attachments

Login to view attachments
TheComet
12
Years of Service
User Offline
Joined: 18th Oct 2007
Location: I`m under ur bridge eating ur goatz.
Posted: 24th Apr 2012 17:56
Thanks a lot for attaching them.

That's another thing... How on earth do I change the compiler and linker settings? In Code Blocks you have "Build Options", but I have the fealing VS 2008 doesn't want me to change things like that.

TheComet

WLGfx
12
Years of Service
User Offline
Joined: 1st Nov 2007
Location: NW United Kingdom
Posted: 24th Apr 2012 18:19
They're in Project Properties. What I usually do is set the 'lib' paths and in my code I add instead: #pragma comment (lib, "libname.lib")

You can also alter the optimization settings too...

Mental arithmetic? Me? (That's for computers) I can't subtract a fart from a plate of beans!
Warning! May contain Nuts!

Login to post a reply

Server time is: 2020-02-26 07:39:16
Your offset time is: 2020-02-26 07:39:16