Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Error compiling CYGDRIVE

Author
Message
payopepe
12
Years of Service
User Offline
Joined: 10th Aug 2008
Location: Spain
Posted: 8th May 2012 18:00
I followed the steps of the tutorial, Building a Tier 1 Android App in Windows, but I get an error.

What am I doing wrong?

Thank you very much!

Attachments

Login to view attachments
The Zoq2
11
Years of Service
User Offline
Joined: 4th Nov 2009
Location: Linköping, Sweden
Posted: 9th May 2012 11:37
Try copying the whole IDE/apps folder, not just the interprenter folders.
Marl
9
Years of Service
User Offline
Joined: 19th Nov 2011
Location: Bradford, UK
Posted: 9th May 2012 17:32 Edited at: 9th May 2012 17:35
If you look at the log.txt file in the interpreter_android folder, it will give you a more specific reason.

Most likely something like

In my case (above) and for every install so far it was permissions.

Even though, by now, I expect it and set the rights in advance, somehow it gets messed up.

The above was the same for all users for this particular file.

Resetting the permission from the AppGameKit or IDE folder and propagating to the sub folders usually sorts it.

Attachments

Login to view attachments
victordavion
9
Years of Service
User Offline
Joined: 3rd Jan 2012
Location:
Posted: 10th May 2012 00:53 Edited at: 10th May 2012 02:04
I'm upgrading my Tier 2 project from 1065 to 1072 and copied over the *.a libs from the new template folder into my project's jni folder.

During linking, it's reporting tons of undefined references. Just for clarification and summary, can someone give me a quick step by step for upgrading an old project for Android ?

Update: The new template project also fails to compile for me. I'm getting undefined references for stuff in the STL libs, too... I wonder what I did.

Edit: I'm gonna dump my log.txt here.

Attachments

Login to view attachments
victordavion
9
Years of Service
User Offline
Joined: 3rd Jan 2012
Location:
Posted: 10th May 2012 04:17
I reinstalled from scratch. I went to compile the template_android project and got the attached log.txt. If you take a quick look, something is causing something to access a non-existent directory "C:/TGCSHARED/*" and if you look further down ( just do a search ) for android-ndk-r6b. What could be forcing this? I'm using NDK r8.

I used to use r6b with 1065, but got those library issues with STL and changed to r8 just for kicks.

I did a search in all the files ( using Sublime Text ) and I can't find anything that references that directory except some Meego.pro file that isn't related.

Attachments

Login to view attachments
Tv Xxx
13
Years of Service
User Offline
Joined: 23rd Sep 2007
Location: Behind You!
Posted: 11th May 2012 01:10
I get the exact same errors as above
http://pastebin.ca/2147068

I have tried using ndk r6b aswell was r8 with the same errors output.

Your signature has been erased by a mod - It was way to awsome!
Ancient Lady
Valued Member
16
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 13th May 2012 20:34
When you do an update, you need to copy the entire IDE directory so that the sources are also updated.

And you need to clean your project before you rebuild it (I renamed my android-ndk directory, substitute the right path for your computer):


Cheers,
Ancient Lady

Login to post a reply

Server time is: 2021-01-24 00:51:45
Your offset time is: 2021-01-24 00:51:45