Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / dbLoadObject problems

Author
Message
Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 9th Jun 2012 22:55
Sorry I have searched before posting but I couldn't find a solution to this.

When I call dbLoadObject in the following way it fails



To check if the object loads I added the following



but the program never ends. My first thoughts were that either it wasn't seeing the right directory or that the object was corrupt.

I have a test further on to check we are actually in the media folder so I know it is not this.

I wrote a quick test in DBPro and the object loaded fine, so now I am stuck as to what the problem might be. Any help please?

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 10th Jun 2012 01:49
Try using dbSetDir ( "media/" ); instead of SetCurrentDirectory ( "media" );
Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 10th Jun 2012 02:20
Quote: "Try using dbSetDir ( "media/" ); instead of SetCurrentDirectory ( "media" ); "


Thanks for the suggestion, made no difference though.

I am using dbDir ( ); when I hit the spacebar and it shows it is in the media folder.

I am confused???

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 10th Jun 2012 15:12
OK, I have narrowed it down to calling dbLoadObject from a function. If I call the command outside of the function it works but inside the function it doesn't load anything and there is no error report that anything went wrong.

Is this a known bug or am I doing something really stoopid???

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 10th Jun 2012 18:58
What version of DarkGDK are you using?
Mistrel
Retired Moderator
13
Years of Service
User Offline
Joined: 9th Nov 2005
Location:
Posted: 10th Jun 2012 19:10
It's some version of DarkGDK 1.0 if he's using dbObjectExist(). This command is renamed to dbIsObject() in DarkGDK 2.0.

Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 10th Jun 2012 19:52
DarkGDK 2.0 is a paid product though isn't it? I thought they were 2 separate things?

Sorry if I'm being dumb.

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mistrel
Retired Moderator
13
Years of Service
User Offline
Joined: 9th Nov 2005
Location:
Posted: 11th Jun 2012 02:26
DarkGDK 2.0 is free to use while it's in beta.

Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 11th Jun 2012 05:52
That's very generous but I can't seem to generate a login for some reason???

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mistrel
Retired Moderator
13
Years of Service
User Offline
Joined: 9th Nov 2005
Location:
Posted: 11th Jun 2012 12:35
If you get an error, it would be helpful if you told me what it is.

Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 11th Jun 2012 13:51
Quote: "If you get an error, it would be helpful if you told me what it is."


When I register my email and name I see a message that says...

Quote: "Your account has been created successfully.

Instructions for activating your account have been sent to the e-mail address you provided. Please follow the steps there to continue"


but nothing is ever received, I tried both my email addresses but no luck.

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mistrel
Retired Moderator
13
Years of Service
User Offline
Joined: 9th Nov 2005
Location:
Posted: 11th Jun 2012 14:55
Your e-mail service is reporting that my SMTP server is being blocked for spam. I've reported the issue to my hosting provider and they said they are working to correct the issue.

I do not send spam. This is an issue because the SMTP (outgoing e-mail) server is shared between customers.

I'll let you know when I have more information.

Olby
16
Years of Service
User Offline
Joined: 21st Aug 2003
Location:
Posted: 11th Jun 2012 15:01 Edited at: 11th Jun 2012 15:01
Mistrel, looks like you having trouble with finding the right host. I suggest www.hostgator.com. Never had any issues with them running both my personal and business web page (which authenticates users upon login in my proprietary software so 99.9% uptime is a must).


Intel Core2Duo 2.2GHZ, 2GB, GeForce 8600M GT 1280MB, Windows Vista Ultimate SP2, PureBasic 4.61 + DarkGDK 2.0
Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 12th Jun 2012 14:50
I'm guessing that the server is in the process of migrating because it doesn't load the website. Once it has settled I will try again from my gmail account.

Thanks for your help.

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Marabas
8
Years of Service
User Offline
Joined: 12th Dec 2010
Location:
Posted: 12th Jun 2012 21:44
WOW, I am seriously impressed by GDK 2.0 and will be buying it as soon as it is complete. I've only looked through the demos and started to read through the C++ docs but this must have taken an incredible amount of work.

Kudos to you, that was well worth the effort...

Signature removed by moderator. Please do not give out the meaning of life in an open forum.
Mistrel
Retired Moderator
13
Years of Service
User Offline
Joined: 9th Nov 2005
Location:
Posted: 13th Jun 2012 02:39
I'm glad to see the website finally working for you. I'm sorry for the trouble you've had trying to get your account up and running.

Please feel free to ask any questions you may have here on the forum.

Login to post a reply

Server time is: 2019-09-17 05:22:08
Your offset time is: 2019-09-17 05:22:08