Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / do you have to use 2.3.1 android sdk or can you use the latest version

Author
Message
leo877
11
Years of Service
User Offline
Joined: 6th Mar 2008
Location: san antonio, tx
Posted: 30th Jul 2012 05:26
I would like know if i can use the latest version of the android sdk instead of using 2.3.1(api9). can i use use a higher api.


victordavion
7
Years of Service
User Offline
Joined: 3rd Jan 2012
Location:
Posted: 4th Aug 2012 19:10 Edited at: 4th Aug 2012 19:11
Yes. I have successfully built AppGameKit projects on all SDKs above 2.3 ( just out of curiosity ).

The reason for this is because you're using Android NDK for the app, not the SDK, so as long as the API supports the NDK ( anything above 2.3 and you aren't using any newer features) then it'll work. The Target Build and Min SDK is really only there for the SDK developers and NDK developers that use newly introduced features.

The difference can be explained here: [href]null[/href]

Basically, using a higher target API allows you to use new features, where having a lower min SDK allows the same app to still run on older devices ( although you need to make sure your app checks which API it is running on so it knows when to use a backup feature when the new feature isn't available ).
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 5th Aug 2012 00:09
I've run AppGameKit generated apps on Android 3.2 and Android 4.1 devices and not seen an issue so far.

Cheers,
Ancient Lady
AGK Community Tester
leo877
11
Years of Service
User Offline
Joined: 6th Mar 2008
Location: san antonio, tx
Posted: 5th Aug 2012 05:44
@ victor

thanks for reponding and that article, i read it but don't know what going on sinse i not a tech guy.

@ ancient lady

i can make app in 2.3.1 and comply,install on my tablet that runs 4.0.4..

The question i was asking is for example say if i use a newer api(16) android 4.1.... would app that comply with 4.1 would it work with android device thats lower like 3.1.

i was gonna try and download another android folder that only has the newest format and not download api(9). but my problem is the only android devices i have is my tablet, so i can not test an older version.

If i was to make my gamme in android 4.1, some one who download it with an older version wouldnt be able to play it, is that right.

Thanks for respond @victordavion and @ancient lady


Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 5th Aug 2012 18:32
Quote: "If i was to make my gamme in android 4.1, some one who download it with an older version wouldnt be able to play it, is that right."


I don't know, but probably not. My concern is that the AppGameKit libraries were built for supporting Android 2.3 and up. They might not link/work right with newer libraries for Android. This is why the Android setup says to use the obsolete android sdk set when setting it up in Eclipse.

Cheers,
Ancient Lady
AGK Community Tester
Digital Awakening
AGK Developer
16
Years of Service
User Offline
Joined: 27th Aug 2002
Location: Sweden
Posted: 5th Aug 2012 20:25 Edited at: 5th Aug 2012 23:33
Currently Android 2.3 is used by 60% of the devices in use. This is the latest info, came out earlier this week I think. 4.0 is used by 16% and 4.1 < 1%.

leo877
11
Years of Service
User Offline
Joined: 6th Mar 2008
Location: san antonio, tx
Posted: 5th Aug 2012 20:40
@ ancient lady and digital awaking

thanks for the respond and information.

i just wondring if using 2.3.1 are you missing out on the newer opotion in newer android version.


Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 5th Aug 2012 21:49 Edited at: 6th Aug 2012 16:15
EDIT: Disregard this one. (I mean my post, this one, not this thread).

Cheers,
Ancient Lady
AGK Community Tester
Digital Awakening
AGK Developer
16
Years of Service
User Offline
Joined: 27th Aug 2002
Location: Sweden
Posted: 5th Aug 2012 23:37
I remembered wrong. Jellybean is < 1%.

And here's a link. The current one ended Aug 01. You can also see screen sizes in use.

Login to post a reply

Server time is: 2019-08-22 06:47:12
Your offset time is: 2019-08-22 06:47:12