Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Android Tier 2 Template

Author
Message
TheTeenDevs
6
Years of Service
User Offline
Joined: 19th Aug 2012
Location:
Posted: 8th Dec 2012 21:38
Ok..... I think I get it.. Right now I have the template from the my products download section, Cygwin, and the NDK in the Android folder. I need the whole IDE directory, and I replace the template from the wiki into the template folder in c/Android. My project is the template right? That's in c/Android/AGK/IDE/templates/template_android_v1076........The wiki is really nice. I joined it the other day! It has a lot of good info in it!

Thanks for all of the help Ancient Lady!

EDIT:
It compiled properly now in Cygwin! If you want your name in the credits of my game or anything let me know!!!!!!!!!! Thank you soooooo much for your time and effort!!!!!!!!!
Theteendevs
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 8th Dec 2012 22:06
I'm just glad to help.

Happy Programming!

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
TheTeenDevs
6
Years of Service
User Offline
Joined: 19th Aug 2012
Location:
Posted: 10th Dec 2012 02:53 Edited at: 10th Dec 2012 02:54
Does anyone else have these two warnings on eclipse:

The import android.provider.MediaStore is never used at line 10, Java Problem at path /androidtemplate/src/com/thegamecreators/agk_player
and
the value of field AGKHelper.myActivity is not used, AGKHelper.java at /AndroidTemplate/src/com/thegamecreators/agk player at line 80 java problem.

It seems to compile fine... I'm using the wiki template v1076......Will this be a problem in the future, All I have is Hello World in my program.
PaulTR
6
Years of Service
User Offline
Joined: 25th Oct 2012
Location: Fresno, CA
Posted: 10th Dec 2012 04:21
I have warnings on mine, too. Doesn't cause any problems with a filled out game. You should be OK.
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 10th Dec 2012 15:50
As PaulTR says, the warnings are pretty standard and have no effect on the final product.

The core AppGameKit stuff has things that are there because they are needed, but not necessarily used by all apps.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
TheTeenDevs
6
Years of Service
User Offline
Joined: 19th Aug 2012
Location:
Posted: 11th Dec 2012 23:28 Edited at: 25th Dec 2012 01:46
Ok, Thanks Ancient Lady! . I'm having issues with setdisplayaspect.......I'll try to avoid it......
gsdblack
7
Years of Service
User Offline
Joined: 6th Dec 2011
Location:
Posted: 5th Jan 2013 18:24
To use the android template I still have to follow the android guide for setting up tier 2 right? Then I copy over the template to my android dir? I setup the android/eclipse environment way back in feb '12. I've been working with VS so I forgot how all this works

Login to post a reply

Server time is: 2019-05-24 05:00:24
Your offset time is: 2019-05-24 05:00:24