Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Trouble running Android apps

Author
Message
Steve the cabbie
6
Years of Service
User Offline
Joined: 3rd Sep 2012
Location:
Posted: 3rd Sep 2012 19:51
Hi I am new to AGK.

I have followed the Android tutorial on here and I have got AppGameKit player and Snakesnacker to work ok on my android phone but any other programme I write just comes up as AppGameKit player on my phone. Does anyone know what I am doing wrong?

Thanks
The Zoq2
9
Years of Service
User Offline
Joined: 4th Nov 2009
Location: Linköping, Sweden
Posted: 3rd Sep 2012 23:15
One thing that could be your problem is that as of 1.7.4 your media has to be put in a media folder inside assets. This is sort of an undocumented change that is vital to get your app working.
Steve the cabbie
6
Years of Service
User Offline
Joined: 3rd Sep 2012
Location:
Posted: 4th Sep 2012 15:07
I have tried this it don't seem to make much difference
Steve the cabbie
6
Years of Service
User Offline
Joined: 3rd Sep 2012
Location:
Posted: 4th Sep 2012 15:10
I have tried this but it don't seem to make much difference
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 17th Sep 2012 18:09 Edited at: 17th Sep 2012 18:10
Did you edit the interpreter.cpp file to uncomment the correct line?

And then did you do a build clean and build?

Did you rename your byte code file from <yourproj>.byc to exactly bytecode.byc (case is important) and is it in the <yourandroidprojdir>/assets/media directory?

Cheers,
Ancient Lady
AGK Community Tester

Login to post a reply

Server time is: 2019-06-16 19:43:13
Your offset time is: 2019-06-16 19:43:13