Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / IsCapturingImage / ShowImageCaptureScreen Crash on Android 2.3.7 // return 0

Author
Message
Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 12th Sep 2012 14:59 Edited at: 13th Sep 2012 16:43
Hi everybody.

I'm working with camera, but it seems that the GetCameraExists return 0 on my smartphone but work fine on my PC.

ShowImageCaptureScreen( ) crash and the app quit but, work fine on my PC too.


How to allow AppGameKit access to the camera ?


The smartphone run on Android 2.3.7 (Sony Xperia, Samsung Galaxy S)

The AppGameKit Player is: Android AppGameKit Player (beta)
On the "no-beta" player, I have the same problem.

And my AppGameKit version is : v1076 (6th Jun 2012)


There is my Code :



Thanks for the halp.

Arbrakan.

Edit :

I get the error: Unknown Instruction 890 on the AppGameKit Player.

Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 12th Sep 2012 23:40
Someone have the same error ?, It came from my Android, the agk player or my code ?

Can some one test this 2 commands for me on android ?

ShowImageCaptureScreen

GetCameraExists


Thanks

Arbrakan

Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 13th Sep 2012 16:21
This code give me 0 on Android


And this one give me 1 for the camera.


Why ?!

Rich Dersheimer
AGK Developer
9
Years of Service
User Offline
Joined: 1st Jul 2009
Location: Inside the box
Posted: 19th Sep 2012 18:23
Arbrakan, I too am having a lot of trouble getting the camera to work on my Android phone, but if doing that accelerometer call first causes GetCameraExists() to work, then I'll try that. Good catch!

Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 22nd Sep 2012 23:00 Edited at: 23rd Sep 2012 00:56
Thanks for the reply.

For me, The GetAccelerometerExists() get the GetCameraExists() return 1 without this it return 0. But my camera don't work. My App crash when I call ShowImageCaptureScreen( ).

Arbrakan

(And Sorry for multi-post..)

Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 23rd Sep 2012 01:23
I recently tested some of the camera examples on my Android devices, using the player, and none returned successfully from takeing a picture.

I plan to do some more testing and report an official bug. Unless I can figure out what is wrong.

Cheers,
Ancient Lady
AGK Community Tester
Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 23rd Sep 2012 22:24
Thanks to take time for it, Ancient Lady. It is very appreciated !

Arbrakan

Arbrakan
8
Years of Service
User Offline
Joined: 10th Oct 2010
Location: Geneva
Posted: 19th Nov 2012 20:43 Edited at: 22nd Nov 2012 18:33
ShowImageCaptureScreen Work fine on the Beta4 Thanks !

Login to post a reply

Server time is: 2019-05-23 10:44:49
Your offset time is: 2019-05-23 10:44:49