Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / CopyImage() doesn't work on Galaxy Note

Author
Message
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 11:41
A simple application of CopyImag (see code below) works on windows but fail on Android Galaxy Note Device...

On the android Device, the sprite if black white...



Cry "Havoc!" and let slip the dogs of war
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 13:07
It doesn't work on a Xoom 2 Media Edition with Android 3.2.2...

I got the same blank sprite.

Cry "Havoc!" and let slip the dogs of war
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 14:29
I tried this simple code.
It works on windows and display nothing on an android device...



Cry "Havoc!" and let slip the dogs of war
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 21st Dec 2012 15:44
What version of AppGameKit are you using (v1076 or v1085)?

Are you running the app on your devices with a Player or are you compiling and installing an apk?

If you are using a Player, what version is it and where did you get it?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 16:11
I'm using v1076 with the Google Play AppGameKit player current version.
I tried the Beta version AppGameKit player but the result was the same.

Cry "Havoc!" and let slip the dogs of war
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 21st Dec 2012 16:30
The Google Play AppGameKit Player has not been updated since about v1065.

And the beta player posted on the 'My Products' page also doesn't work right and won't work at all with v1076.

You can get a clean, working v1076 Player here.

And, if you start using the v1085 AppGameKit IDE, MikeMax posted a good v1085 Player here.

I am willing to bet that many of your problems disappear when you use the correct version of the Player.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 17:17
Quote: "You can get a clean, working v1076 Player here."


Thanks!
I can already see than a freezing problem has disapeared!
I will try copyImage() asap!
Thanks again!

Cry "Havoc!" and let slip the dogs of war
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 21st Dec 2012 17:21
CopyImage() is the slowest way to do what you want. It is memory intensive and not the best choice for Android devices.

I would recommend that you stick with viewOffset.

But, of course, do whatever you want, it is your app and all programming choices are up to you.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
LeGugusse
12
Years of Service
User Offline
Joined: 15th Feb 2007
Location: Paris - France
Posted: 21st Dec 2012 19:43
You are right.
That's the way I will take.
Thanks.

Cry "Havoc!" and let slip the dogs of war

Login to post a reply

Server time is: 2019-08-26 08:53:40
Your offset time is: 2019-08-26 08:53:40