Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / DarkNet for Visual Studio c++ 2012

Author
Message
Parry
AGK Developer
9
Years of Service
User Offline
Joined: 16th Dec 2009
Location: Swampstone
Posted: 11th Jan 2013 15:23 Edited at: 11th Jan 2013 15:24
Anyone tried to use DarkNet with Visual Studio 2012?

I tried using the 2010 files with 2012

Qqite
9
Years of Service
User Offline
Joined: 28th Feb 2010
Location: Florida, U.S.
Posted: 11th Jan 2013 15:39 Edited at: 11th Jan 2013 15:40
Check his Program Announcement page. He just released the new version that supports 2012 natively.

http://forum.thegamecreators.com/?m=forum_view&t=135855&b=5&msg=2417036#m2417036

I, personally, have not checked TGC to update it yet so I'm not sure if they have updated it yet. But it will.

Ventures of the worlds around us are limited only by our imagination.
MrValentine
AGK Backer
8
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 11th Jan 2013 20:41
server.obj <--

But yeah, I am waiting on TGC to update their version...

Michael P
13
Years of Service
User Offline
Joined: 6th Mar 2006
Location: London (UK)
Posted: 15th Jan 2013 19:56
The update has now been released by TGC - let me know if you have any issues, it should work as normal with VS 2012.

MrValentine
AGK Backer
8
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 16th Jan 2013 08:59
I had a lot of errors, but I will not be using this for some months to come [VS2012]

Parry
AGK Developer
9
Years of Service
User Offline
Joined: 16th Dec 2009
Location: Swampstone
Posted: 19th Jan 2013 10:49 Edited at: 19th Jan 2013 10:50
I didn't have any problems using the 2012 version. VS2012 done a flawless transfer back from VS2008. I'm using the version for DarkGDK 1.0 though, I haven't tried yet to build a DarkGDK 2.0 version.

Par
Have Fun!
8
Years of Service
User Offline
Joined: 16th Dec 2010
Location:
Posted: 16th Apr 2013 00:37
@Parry: Can you run your DarkGDK 1.0 projects using Visual Studio 2012 without having VS2008 on your computer? If you uninstall VS2008, you will probably find that your DarkGDK projects will no longer run.

I'm trying to upgrade our classroom projects to VS2012 without forcing everyone to install both VS2010 AND VS2012.

Does anyone have any ideas to get DarkGDK to work with VS2012 without having a prior version of VS installed?

Live your dreams.
Michael P
13
Years of Service
User Offline
Joined: 6th Mar 2006
Location: London (UK)
Posted: 17th Apr 2013 01:16 Edited at: 17th Apr 2013 01:16
You would probably have to build DGDK sources with VS2012.

FYI the configuration flag which specifies which compiler is used is project properties -> configuration properties -> platform toolset.

Login to post a reply

Server time is: 2019-09-18 13:06:56
Your offset time is: 2019-09-18 13:06:56