Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark Physics & Dark A.I. & Dark Dynamix / HELP - Dark AI demos crashing after hitting the ESC key !

Author
Message
Juggernaut
7
Years of Service
User Offline
Joined: 12th Mar 2012
Location:
Posted: 19th Jan 2013 16:44
Whenever I hit ESC key to close a Dark AI demo project running under Windows 7 64 bit, I get the Dark Basic Pro has stopped working error
dialogue box.

Quote: "
Problem signature:
Problem Event Name: APPCRASH
Application Name: Sound Demo.exe
Application Version: 1.0.0.0
Application Timestamp: 4d460aea
Fault Module Name: DarkAI.dll_unloaded
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 44f58ac4
Exception Code: c0000005
Exception Offset: 003aa718
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

"


I have tried running the compiled exe using run as Administrator.
Juggernaut
7
Years of Service
User Offline
Joined: 12th Mar 2012
Location:
Posted: 19th Jan 2013 18:17
I have isolated the scenario when the crash is occurring. If I enable the following debug controls while the demo is running -

[1] Show Entity Paths
[2] Show Obstacle Bounds
[3] Show Entity View Arcs And Hearing
[4] Show Sounds

and then hit the ESC key to close the running application, the
above mentioned ( first post ) application crash occurs.

Does anybody know how to fix this ?
MrValentine
AGK Backer
9
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 19th Jan 2013 18:18
Try this...

Change the setup from EXE to INSTALLER in the Project Settings tab... run the exe... go into the folder and notice the exe no longer has a shield on it... also copy the images into the folder...

run and press ESC...

Good day to you

I avoid using MEDIA and EXE these days...though I completely avoid MEDIA entirely!

MrValentine
AGK Backer
9
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 19th Jan 2013 18:20 Edited at: 19th Jan 2013 18:26
You can also try ALONE

EDIT

Sorry about the double post...

Did a retest and can confirm the issue exists on 32-bit Win7 Too...

I am yet to test on my 64-bit Win 7/8 Rig...

Juggernaut
7
Years of Service
User Offline
Joined: 12th Mar 2012
Location:
Posted: 19th Jan 2013 18:25
ok. Mr. Valentine I will try those settings out.
MrValentine
AGK Backer
9
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 20th Jan 2013 15:35
Yup, I get the same results from the Demos on Windows 8 Pro x64...

I think we should try creating a modified program aside from the demo code examples and see if the issue is no longer present... I will try this sometime in the coming days...

Juggernaut
7
Years of Service
User Offline
Joined: 12th Mar 2012
Location:
Posted: 21st Jan 2013 20:06
So Dark AI fails to work on Windows 8 ?
MrValentine
AGK Backer
9
Years of Service
User Offline
Joined: 5th Dec 2010
Playing: FFVII
Posted: 21st Jan 2013 20:27
works, just the same exit issue, but again it could just be the Demo apps, as I have not come across the issue mentioned in other applications...

As I said, test it in your own application first... I will do this soon...

Login to post a reply

Server time is: 2019-12-10 15:29:15
Your offset time is: 2019-12-10 15:29:15