Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Windows / Jittery sprite movement scrolling sprite with uv offset

Author
Message
Naphier
9
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 26th Jan 2013 06:30 Edited at: 26th Jan 2013 06:47
I'm using AppGameKit 1088b on Windows 7 and coming across an annoyance / potential game issue.
I've set up a simple test for a scrolling sprite background and it is a bit jittery in Win7. The movement is smooth for a few seconds then jittery, then repeats.
This doesn't occur on my Nexus 7 (android 4.1) or my HTC Incredible 2 (android 2.3). Just my Windows machine which is pretty high end.
Is it some sort of rounding issue?
Could others test this on their Windows 7 machines and tell me if they have the same results? Project files attached.

Thanks!!



EDIT: Some further notes / testing. I think that it is the new Catalyst drivers... I can't load the ATI Control Center app to change settings... seems to be a constant issue with ATI.
When I run the app fullscreen it definitely looks like a vsync issue. When I run it in a maximized window there's no issues, in the normal size window it is jittery, but doesn't look like vsync issues, though it could be... I'd still appreciate some others testing it if possible.
Now I notice if I have Adobe Reader minimized the windowed version is fine..but fullscreen still has vsync issues.
Thanks again!

Attachments

Login to view attachments
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 26th Jan 2013 17:00
I just tested your app on my Windows 7 and it was perfectly smooth.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Naphier
9
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 26th Jan 2013 22:41
Good to know! Thanks!
Could you tell me what gpu you have and if possible what driver version?

Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 27th Jan 2013 17:12
I have an NVIDIA GeForce GTS 450, driver version 9.18.13.697 dated 2-Oct-2012.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Naphier
9
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 27th Jan 2013 22:08
Thanks, Lady. I'm becoming more and more convinced that the issue is with ATI Catalyst... sure wish they could get it right!

Hockeykid
DBPro Tool Maker
12
Years of Service
User Offline
Joined: 26th Sep 2007
Location:
Posted: 29th Jan 2013 03:44
I tried the example, and I see the little jitters too.

Windows 7 64 bit
Nvidia GTX 460 drivers 9.18.13.697 2-Oct-2012



Sean

Naphier
9
Years of Service
User Offline
Joined: 2nd Oct 2010
Location: St Petersburg, Florida
Posted: 29th Jan 2013 04:09
Darn then it is not ATI catalyst.
I had a lot of issues like this with DBPro and ultimately abandoned it because I was concerned that a commercial product would have the issues. Guess I'll be tied to slow moving games with AppGameKit too...

Thanks, Sean.

Login to post a reply

Server time is: 2019-12-08 00:06:07
Your offset time is: 2019-12-08 00:06:07