Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Android SDK why 2.3.1 and not 4.2.2 ?

Author
Message
AutOmatIc
9
Years of Service
User Offline
Joined: 17th Sep 2009
Location:
Posted: 30th Mar 2013 04:14
When installing the android SDK, all of the posts I have read so far tell you to make sure that you install the "obsolete" 2.3.1 (API9) *puzzled

Now, is it ok to install all of the API packages up to 4.2.2? As I understand it, when you are developing and releasing apps that you would want to release it with compatability for as many versions of the device as you can...or will this present major problems later on?

If you only use 2.3.1 to develop with, will people with phones running Jelly Bean (4.2) have issues running the app?

-remember that you are unique, just like everyone else-
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 30th Mar 2013 16:25
Quote: "If you only use 2.3.1 to develop with, will people with phones running Jelly Bean (4.2) have issues running the app?"

I know there is no problem with 4.1.

And I don't think there is any issue with installing the more recent API packages.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
AutOmatIc
9
Years of Service
User Offline
Joined: 17th Sep 2009
Location:
Posted: 30th Mar 2013 20:39
OK cool thanks so much for the reply, I just wanted to make sure it wouldn't cause issues if I installed the other packages. Although let me tell you...it took me almost an entire day to do so :/ so be warned LOL

Cheers,
Auto

-remember that you are unique, just like everyone else-
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 31st Mar 2013 05:46
Been there and done that (and sometimes more than once) to get things working.

Good luck.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Digital Awakening
AGK Developer
16
Years of Service
User Offline
Joined: 27th Aug 2002
Location: Sweden
Posted: 3rd Apr 2013 02:03
But will a 2.3 device be able to run the app if you use the 4.2 package? 2.3 is still used on over 40% of all Android devices.


Demo 3 is out now!

Login to post a reply

Server time is: 2019-08-21 22:07:05
Your offset time is: 2019-08-21 22:07:05