Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / 1076 Template when run on Android device

Author
Message
MojoWaffles
6
Years of Service
User Offline
Joined: 2nd May 2013
Location:
Posted: 21st May 2013 09:19
I followed all the instructions on the guide to set up Tier 2 for Android with only a few minor differences: Used Eclipse 4.2.2 (The guide states it must be 3.5 or higher), the NDK is r8e (Guide states it must be at least 6) and the JDK is 1.7.0_21. I only installed API Level 9 with all the Tools and the C/C++ developer tools. Everything including Cygwin, AppGameKit, the SDK and Eclipse are installed in the same C:\android folder. I also don't have spaces in path names.

My phone is an HTC One SV running 4.1.2 (Jelly Bean).

I compiled in Cygwin and got this in the log


The template imported fine and there were no errors in Eclipse "Unfortunately, AppGameKit Player has stopped." message everytime I run it. I am running a 64-bit PC with Windows 7.

I'd like to think I missed something but I've already completed the process three times and get the same results. If anyone knows what's wrong or has had a similar experience and fixed it please help. Thanks!
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 21st May 2013 16:33
First, what version of AppGameKit are you using?

And where did you get the template from?

Did you run the project in Eclipse as an 'Android Application'? That is what creates the apk that is installable on your device.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
MojoWaffles
6
Years of Service
User Offline
Joined: 2nd May 2013
Location:
Posted: 21st May 2013 17:51
AGK is 1076. The template is the one in AGK\IDE\templates\template_android when I installed AGK. Yes I'm running the project as an 'Android Application'.
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 21st May 2013 20:37
That is not a good template to use. None of the ones provided with v1076 were up to date or working.

Get a good template from this page and look at the instructions on that page.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
MojoWaffles
6
Years of Service
User Offline
Joined: 2nd May 2013
Location:
Posted: 21st May 2013 21:07
Got the 1076 template off that page and it worked! Thank you!

If I understand correctly, the 1088 templates can't be used if I have AppGameKit 1076 right?
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 22nd May 2013 04:12
Quote: "the 1088 templates can't be used if I have AppGameKit 1076 right?"

That is correct.

But AppGameKit is currently up to v10811 in the beta and soon to come out with v10812.

The templates with v10811 basically worked, which is why they are not posted on the wiki page I sent you to.

Unless you need something specific in v108+, stick with v1076 until some issues are worked out. The main one being that Apple will reject any apps (as of 1-May-2013) that use the UDID. And the Twitter portion of the social stuff in v1085+ uses it. This is not controllable by TGC.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2019-10-14 14:09:33
Your offset time is: 2019-10-14 14:09:33