Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Unknown Instruction 649

Author
Message
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 27th May 2013 05:18
Hey there:

Is anyone getting this error? I updated my android AppGameKit Player to the 10000008 build May 21 2013 version, and evertytime I try to preview the game I'm working on, the player exits with the Last Error label, reading "Unknown Instruction 649".

I already made an apk file using the very same code and it works fine; I works perfectly on Windows, and it worked fine with the AppGameKit PLayer released in April.

I'm using the player on a Samsung Galaxy Ace, the game is programmed using Tier 1.

Is anyone experiencing the same behaviour? Can someone suggest a solution?

Thanks

Sans peur
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 27th May 2013 16:23
What version of AppGameKit IDE are you using?

If, by some chance, your AppGameKit IDE is v1076, then it is not compatible with the v10812 Player.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 27th May 2013 19:40
Thanks for your quick reply Ancient Lady,

I started this proyect using v106 and then upgraded to v107. They both work fine, and as I mentioned, I could preview my game using the Android Player released in April, was it v106 o v107.

So, if the problem is the player, is there a way to downgrade the Android player?

Greetings from Mexico

Sans peur
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 27th May 2013 20:42
Thanks for your quick reply Ancient Lady:

I'm using AppGameKit IDE v1065. I'm upgrading to v1076. My game runs and compiles with no erros with either IDE version, and it ran perfectly with the Android player released in April, regardless of it being transfered from the v1065 or v1076 IDE.

So, if the problem is the player, is there a way to downgrade my player to the April release?

Thank you

Classics games, modern wonders
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 28th May 2013 07:01
Oh sorry, I didn't see that my message had to be approved before being shown, that's why I ask the same thing twice

Classics games, modern wonders
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 28th May 2013 16:27
I have a working v1076 player that you can download from this page.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 28th May 2013 17:51
Thanks Ancient Lady,

I'll be doing some tests today. I was curious about what you said. Yesterday I tried the demos included with AppGameKit and they seem to work fine even with the AppGameKit Player May release. I thought something could be wrong with my code, I use several global variables and bidimensional arrays, so I commented my code to the point of just having the variable declaration section and the main loop working. I transfered the app to the AppGameKit PLayer and I could see my main window appear [before posting this issue to the forum I couldn't see anything], yet, the program crashes and the Last Error reports that I'm using an invalid reference for a virtual button I have no virtual buttons hahaha, I believe I have a commented test for a virtual button but that's it.

Anyways, I'll try installing the player you were so kind to share with me and see what happens.

Thanks a lot again

Classics games, modern wonders
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 28th May 2013 19:07
Good luck.

The v1076 IDE and the v10812 Player are NOT compatible. There were some fixes made that caused the loss of backward compatibility.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 29th May 2013 04:28
Thanks a lot Ancient Lady Using the v1076 player my app works again.

The thing is, why doesn't TGC mention the incompatibily issues before releasing a new version?

Anyways, I guess I won't update the player anymore until v108x becomes stable.

Have a nice day

Classics games, modern wonders
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 29th May 2013 16:19
They did mention it in at least one post and it has been mentioned again.

And it is mentioned in the AGK.txt file distributed with each release.

v10812 is fairly stable. They appear to have handled most or all of the bugs.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
Alebrije
6
Years of Service
User Offline
Joined: 27th May 2013
Location: Toluca
Posted: 29th May 2013 19:56
Hey there Ancient Lady,

I dind't see the post about the incompatibility between players, that's my mistake.

About v10812, do you know when it will be the official version?

Greetings

Classics games, modern wonders
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 30th May 2013 16:22
About v10812, do you know when it will be the official version?[quote]
I don't work for TGC, so I don't have a clue.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2019-08-17 14:43:52
Your offset time is: 2019-08-17 14:43:52