Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Dark GDK / Adding extentions to dark gdk (dark ai, dark physics)

Author
Message
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 22nd Jun 2013 02:24
hello, i am using Visual C++ 2008 express edition with dark gdk for games. I recently brought the Dark Game Studio Bonanza where dark lights, dark ai and dark physics were included. For days i have been trying to make the extentions work the gdk but i keep on getting errors. I have managed to get dark lights to work but not the others. I cannot compile any of the samples of physics and AI.

With Dark Physics I am getting:



with Dark AI I am getting:



Can anyone help!?!
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 22nd Jun 2013 15:07
Okay, i got Dark AI to work by mkaeing it ignore some libraries: LIBCMTD, libcpmtd. this was done by going properties//Configuration Properties//Linker//Input//Ignore Specific Library.

but dark physics i still cant get to work. i have tried to compile the samples where it successfully debugs but then opens up a web browser to download the phyx drivers but the page does not exist any more. where can i download these drivers. i thought i already downloaded them as i have ageia physX drivers v2.5.0. where can i get the correct physx drivers? secondly, when i right clicked on the project and then clicked build with the samples it then comes up with this errror again:





and now when ever i debug it i cannot run it at all. please help!
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 23rd Jun 2013 02:07
That error is telling you that the DarkPhysics libary file (*.lib) was created with an older compiler than the one you are using.

What compiler are you using?
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 23rd Jun 2013 02:26
I dont know, how can i find out?
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 23rd Jun 2013 08:37
What version of Visual Studio are you using? (i.e 2008, 2010, 2012)
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 23rd Jun 2013 10:40 Edited at: 25th Jun 2013 08:37
2008 express

ive attached an image of the vs c++ 2008 files on my computer, is any of these making dark physics not work?

Attachments

Login to view attachments
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 25th Jun 2013 19:39
okay, i have now got dark physics working but i had to uninstall/remove the updates. when i run the examples (and any other projects using dark physics) it opens up the web browser to install physx. I would install it but the web address does not exist anymore. where can i install physx. I thought i already had it but maybe i got the wrong one. ive installed one from Runtime Drivers which was supplied by TGC and the phyx devolpment version. do you need a nvidia graphics card for dark physics to work?
Mr Bigglesworth
11
Years of Service
User Offline
Joined: 4th Mar 2008
Location:
Posted: 26th Jun 2013 02:39
You don't need a nvidia card, amd/ati works fine. Try getting these drivers: http://www.nvidia.com/object/physx-9.12.1031-driver.html
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 26th Jun 2013 16:31 Edited at: 26th Jun 2013 16:55
Thanks, I have a new error while tring to run the compiled demos (slime & water):

Unable to set up SDK in dbPhysX

and with the others:

Invalid PhysX Runtime - check drivers are installed - http://www.ageia.com/physx/drivers.html

i have tried the web address and it no longer exists

what can i do to fix these problems?
samqweqwe
6
Years of Service
User Offline
Joined: 7th Apr 2013
Location:
Posted: 27th Jun 2013 19:00
from debuging the c++ samples i do not think that they are compiling correctly, for example, i debuged the falling objects project and the results was that the objects were bouncing off the platform. From reading the comments it seems that it is not meant to happen.

I tried to compile the dark basic samples but all come up with the error of:




c++:

the vehicle sample come up with this error:



and in all other projects, no media is being loaded but basic object are (eg spheres and boxes)

and in the water demo when debuging, nothing is shown in the window. this problem may have occured because it is not loading any media

any ideas on how to fix this?

Login to post a reply

Server time is: 2019-09-21 11:53:19
Your offset time is: 2019-09-21 11:53:19