Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / error: undefined reference to 'AGK::agk::GetInternetState()' - Tier 2

Author
Message
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 24th Jul 2013 23:18
When I try to build my project for Android, i get the
following error in the link process:

error: undefined reference to 'AGK::agk::GetInternetState()'

For Windows the projects compiles fine. I'am using version 108.
Can someone tell me what am i doing wrong?

Tnx
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 25th Jul 2013 16:18
Do you actually have the code as 'AGK::agk::GetInternetState()'?

Or is the compiler adding the 'AGK::'?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 25th Jul 2013 19:27
My code looks like this:



i think that the ndk compiler is adding the AGK:: ,
because for Windows it compiles fine...
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 26th Jul 2013 02:06
What version of AppGameKit are you working with?

Did you upgrade recently and just copy new stuff over old stuff in your Android setup?

Do you do your ndk compiles in Cygwin or using the batch file?

If yes to the previous two, very possibly some libraries did not get updated properly.

Based on your answers, I may have more questions, or suggestions.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 26th Jul 2013 09:10
I'am using version 108.

I've setup the project from scratch, taking the template_android folder that comes with the AppGameKit setup.

I compile directly in Cygwin with the 'ndk-build' command.

If I remove the mentioned 2 lines of code the project compiles fine for Android and for Windows.
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 26th Jul 2013 16:24
Which flavor of v108? We are not up to v10816 (and it will go higher).

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 7th Aug 2013 17:07
Sorry for my late response, but i was on holiday...

I'am using version 108.16
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 8th Aug 2013 21:47
It looks like your libraries in your Android setup might not be the correct versions. I am not at a computer that I can check paths and such on right now (and won't be until the 18th).

I am assuming that you made an Android directory within which you have the AppGameKit IDE directory with the bits needed door Android building and that is the environment that you are compiling in.

I seem to remember that my initial v10816 android_template setup didn't have the libraries for linking and that I had to copy them from the interpreter_android set. I just can't remember off hand the right paths to check.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 9th Aug 2013 11:04
My directory setup looks like this:

D:\
| Android
|+NDK (folder containing NDK)
|+SDK (folder containing SDK)
|+IDE (Complete AppGameKit IDE folder)
|+templates
|+template_android

hope it helps you...
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 11th Aug 2013 08:18
I don't have access to a computer to check. But I seem to remember that my template_android directory, for the past few v108 releases has been in IDE/apps.

I don't think the templates have been in a separate templates directory since v1076. It looks like you are not using the correct ones. The libraries in the Android templates are not in a separate directory. If you are using v1076 templates, they do not have the correct libraries.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
m0rph3us
6
Years of Service
User Offline
Joined: 24th Jul 2013
Location:
Posted: 19th Aug 2013 10:39
I've moved my stuff in to

IDE/apps/template_android_lite

and compiling works fine.

Thank you for your help.
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 19th Aug 2013 19:17
I am always glad to help.

It's just trickier when I am traveling.

We just got back from Alaska yesterday.

Happy Programming!

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2019-08-25 17:09:30
Your offset time is: 2019-08-25 17:09:30