Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Bug Reports / Copy Vector4 vs New Vector4

Author
Message
Chris Tate
8
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 26th Aug 2013 13:12
This is the issue posted on the Matrix1 board; but it could be caused by the standard Copy Vector4 command.

Copy Vector4 will not work when a vector4 result was created by the New Vector4 command:

This did not work:

+ Code Snippet

This did:

+ Code Snippet

Green Gandalf
12
Years of Service
User Offline
Joined: 3rd Jan 2005
Location: Cornwall UK
Posted: 26th Aug 2013 23:33
Both snippets work fine for me.

I'm using U77RC7 and Matrix1 seems to have 19/5/12 as the most recent change.



Powered by Free Banners
Chris Tate
8
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 26th Aug 2013 23:55 Edited at: 26th Aug 2013 23:57
Thanks for the info, I am limited to U76. I have to use that version so that Dark Dynamix can work.

WickedX
8
Years of Service
User Offline
Joined: 8th Feb 2009
Location: A Mile High
Posted: 29th Aug 2013 19:29
Chris,

The way you’ve coded the second snippet, it only appears to work. Check your variables, both “a” and “b” equal 1. The problem is the copy vector4 function does not work. U77RC7 has seemed to fix the problem.

+ Code Snippet
Chris Tate
8
Years of Service
User Offline
Joined: 29th Aug 2008
Location: London, England
Posted: 1st Sep 2013 01:07
OK thanks; so once again it is my version with the broken command.

I quickly assumed Make Vector() returns the vector ID because I do not like using it.

It is one of those standard commands I avoid using that are not consistent with the DB tradition of creating a resource without having to return a result; like MAKE IMAGE or MAKE OBJECT, unless the ID is machine-supplied rather than self-specified as is the case with the Matrix1 NEW VECTOR commands.

Login to post a reply

Server time is: 2017-04-30 08:09:20
Your offset time is: 2017-04-30 08:09:20