Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / virtual button not showing on tablet device

Author
Message
mindsclay
7
Years of Service
User Offline
Joined: 1st May 2012
Location: Rocklin, CA, USA
Posted: 8th Sep 2013 18:30
The virtual button shows on screen in the PC display but does not show in the device display. I am performing a compile,run,broadcast. I can see the button only on the computer, not on my Nook. I can however see text on both.

Any prescedence to this?

AGK build 107

www.mindsclay.com
lucifermagus.mindsclay.com (not working with Firefox)
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 8th Sep 2013 18:56
I have not experienced this issue with other Android devices.

Which version of 107? The current 107 release is 1076.

Do you have the same problem if you use just the broadcast button (instead of run and broadcast)?

Do you know what version of Android your Nook is using?

Can you show the code you are using and having trouble with?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
mindsclay
7
Years of Service
User Offline
Joined: 1st May 2012
Location: Rocklin, CA, USA
Posted: 8th Sep 2013 22:06 Edited at: 8th Sep 2013 22:21
Pretty sure it is not the code unless there is more code needed (and not shown in the tutorial).

AGK: version 1076
Nook: Android 3.0 Ice Cream Sandwich



www.mindsclay.com
lucifermagus.mindsclay.com (not working with Firefox)
mindsclay
7
Years of Service
User Offline
Joined: 1st May 2012
Location: Rocklin, CA, USA
Posted: 8th Sep 2013 22:42
@ Ancient Lady: How does one get the "badges" posted? I am a silver backer and would like to have the icon shown.

www.mindsclay.com
lucifermagus.mindsclay.com (not working with Firefox)
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 9th Sep 2013 01:23
For your backer badge, follow the instructions in this thread.

Your code looks fine and it works for me (in v1076) via broadcasting to my Android devices.

However, if you are using the Player from the Android Player store, then it is the wrong version for v1076.

Because of some significant fixes, v1076 is not compatible with v108+.

Since you are a backer, you are entitled (I believe) to use the current v108 betas. If it appears in your TGC 'My Products' page, you might want to download and install that version of AGK. Just remember to uninstall v1076 first (saving any of your own work somewhere else so it doesn't get lost).

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
mindsclay
7
Years of Service
User Offline
Joined: 1st May 2012
Location: Rocklin, CA, USA
Posted: 10th Sep 2013 02:56
Thanks again!

The newer player was the issue. I downloaded the AppGameKit 108 beta and my code is now working okay.

www.mindsclay.com
lucifermagus.mindsclay.com (not working with Firefox)
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 10th Sep 2013 05:03
Excellent!

Happy Programming!

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2019-12-06 23:26:13
Your offset time is: 2019-12-06 23:26:13