Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / eclipse setup....outdated?

Author
Message
SoftMotion3D
AGK Developer
14
Years of Service
User Offline
Joined: 24th Aug 2005
Location: Calgary,Alberta
Posted: 11th Oct 2013 15:25
Im assuming the setup sticky on top is outdated.

I followed all those steps and got the facebook without errors now but still have them on the agk player.

I think I need to copy more then just the agk interpreter for android as I remember getting blackberry to work I also needed to link other folders from the agk installation folders.

please see image below...this is where im at.

any help would be appreciated!

I would just use the tgc webpage one however QmidiStudio is ~150 mb too large.

Attachments

Login to view attachments
Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 11th Oct 2013 19:09
Did you do the steps in the Readme.txt file in the interpreter_android directory?

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
SoftMotion3D
AGK Developer
14
Years of Service
User Offline
Joined: 24th Aug 2005
Location: Calgary,Alberta
Posted: 12th Oct 2013 00:49
yup...doesn't say much...says you don't need to build the player.... but you do if you want a standalone.

ill try the other one...the prebuilt one it mentions.

I followed all the steps written in the sticky

SoftMotion3D
AGK Developer
14
Years of Service
User Offline
Joined: 24th Aug 2005
Location: Calgary,Alberta
Posted: 12th Oct 2013 03:22
this time around im even having worse troubles...

going to try to get it working without the face book dependencies

SoftMotion3D
AGK Developer
14
Years of Service
User Offline
Joined: 24th Aug 2005
Location: Calgary,Alberta
Posted: 12th Oct 2013 04:18
ok whew! I got the prebuilt lite working...

what are the limitations of the lite one vs not?

is it just the inclusion of the facebook sdk?

Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 12th Oct 2013 06:51
I just rechecked the Readme.txt files. The one in the interpreter_android looks like it should be the one in the interpreter_android_prebuilt and vice-a-versa.

But the main difference between the lite and non-light is Facebook, push support, in-app purchasing and, I think, Ads. (I am not sure about that last)

So, if you don't any of those, the light version should work.

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master
SoftMotion3D
AGK Developer
14
Years of Service
User Offline
Joined: 24th Aug 2005
Location: Calgary,Alberta
Posted: 13th Oct 2013 05:37
fyi...

ads are supported in the lite build.

I just created a Chopper Rescue apk using the lite build and the adverts seem to be working

Ancient Lady
Valued Member
15
Years of Service
User Offline
Joined: 17th Mar 2004
Location: Anchorage, Alaska, USA
Posted: 13th Oct 2013 06:09
Good. I'm glad you got it working.

Happy Programming!

Cheers,
Ancient Lady
AGK Community Tester and AppGameKit Master

Login to post a reply

Server time is: 2019-10-16 20:07:43
Your offset time is: 2019-10-16 20:07:43