Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Models and Media / I made a tree with treemagik,how do i get it to fpsc

Author
Message
mguy1122
6
Years of Service
User Offline
Joined: 5th Mar 2013
Location:
Posted: 8th Jan 2014 23:16
I exported my tree from treemagik and it's given me two .X files and two image files(.png,.jpg). As it is now it won't work in fpsc. Can anyone explain to me how to make this fpsc ready? I've tried making an .fpe file for this but you can only assign one texture to an entity. (Picture below)

Attachments

Login to view attachments
starmind 001
11
Years of Service
User Offline
Joined: 23rd Sep 2007
Location:
Posted: 10th Jan 2014 17:49 Edited at: 10th Jan 2014 17:50
to assign more than one texture to an entity just leave the line open like so...



Then make sure that the textures are in the same file as the fpe and .x file.

If part of the entity is textured and not the other, then you will need to locate the right texture or combine textures.

When you combine the textures you will need to make sure the model is unwrapped accordingly.

Good luck. If you cannot get it to work post the model and textures or send me an email. We'll get it for you.

mguy1122
6
Years of Service
User Offline
Joined: 5th Mar 2013
Location:
Posted: 10th Jan 2014 21:47
I read on here before to leave the texture section blank so I tried that and my model is showing up pure black. I change the textures to .dds files to see if that would help but it didn't. Im borrowing an fpe file from another tree and changing what .x file it uses and the texture line. Maybe that's the problem. I included the tree,fpe file and textures I'm working with below. If you could help me get it working that would be awesome. Thank you for the reply

Attachments

Login to view attachments
starmind 001
11
Years of Service
User Offline
Joined: 23rd Sep 2007
Location:
Posted: 11th Jan 2014 01:13
Here you go. I combined the textures and uvmapped it to match.

As far as what was wrong with your model, the only thing I saw was fpsc was looking for two materials on two different meshes. Fpsc is a little picky for me in this area too.

Enjoy!

Attachments

Login to view attachments
mguy1122
6
Years of Service
User Offline
Joined: 5th Mar 2013
Location:
Posted: 11th Jan 2014 02:03
Thank you very much! I just started making my own models so I'm not very good at it yet. I've been staying in the safe zone with squares so I wasn't quite sure how to uvmap a tree. Thanks again!
mguy1122
6
Years of Service
User Offline
Joined: 5th Mar 2013
Location:
Posted: 11th Jan 2014 18:28
I tried to recreate what you did with my tree on my own to make sure I knew what I was doing. I don't think I'm quite there yet. I converted my .x file to a .obj file and opened it in uvmapper and the map I got was much more complicated than the .dds you sent me lead me to believe. From what I gathered it looked as if you took the branch texture and placed the trunk texture in the upper right corner. How did you get that layout in uvmapper?thanks

Login to post a reply

Server time is: 2019-08-19 15:35:27
Your offset time is: 2019-08-19 15:35:27