Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / Help! problem install IPA on IOS

Author
Message
payopepe
8
Years of Service
User Offline
Joined: 10th Aug 2008
Location: Spain
Posted: 27th Jun 2015 13:07
Hello,

I use the version: 2.0.14b AppGameKit (Mac)

And I can not install any IPA in my testers.

The APP is always "installing" permanently.

I've tried several "provisioning profiles", and various apps, as well as the AppGameKit Player.



Thanks!

Attachments

Login to view attachments
payopepe
8
Years of Service
User Offline
Joined: 10th Aug 2008
Location: Spain
Posted: 27th Jun 2015 14:58
This I have already solved. The problem was directly used "update" rather than the version "2.0.11"

APPs now appear signed and I could create the AppGameKit Player.

But now is not how to install the update "2.0.14b" without damaging the original installation. Because when I use the "update", everything returns to fail and can not sign the apps.

Thank You.
MucMac
1
Years of Service
User Offline
Joined: 13th Sep 2015
Location: Munich, Germany
Posted: 13th Sep 2015 15:42
How did you solve this? I have the same issue, using latest 2.0.14b.

Cannot install the player for testing my app.... please help a newbie

--
Mac
WestLaBill
1
Years of Service
User Offline
Joined: 19th Sep 2015
Location: Malibu, CA
Posted: 19th Sep 2015 11:32 Edited at: 19th Sep 2015 18:05
PS
This mac install is from the Steam network.
WestLaBill
1
Years of Service
User Offline
Joined: 19th Sep 2015
Location: Malibu, CA
Posted: 19th Sep 2015 11:33
Hi Everyone,

So far I've spent days trying to get a hello world app to run on two iphones without success.

I've followed the instructions to get my developer ID profile: iOSTeam_Provisioning_Profile_.mobileprovision

added it to the export feature in AGK2 2.0.14b. Using the Itunes sync feature where I double clicked on the .ipa file generated from the export feature the IP5 says unable to install the app. The IP 4S (IOS 7.1.2) just says installing when I click on the app name and does that indefinitely.

I've even gone as far as using one of the web based app testing services on the IP5 with IOS 6.0 (Jail broken) and it also said it failed to install.

Could someone make an up-to-date video tutorial on the steps to get a hello world app to run on an iphone 5?

I've had no problem writing Xcode apps and testing development versions on my Iphone 5 and 4S. Though I bought AGK2 to write code more easily which it is, though it's appearing way more complicated getting even a hello world app to run on either of these phones.

Thanks much,

Bill
WestLaBill
1
Years of Service
User Offline
Joined: 19th Sep 2015
Location: Malibu, CA
Posted: 24th Sep 2015 03:05
Hi Everyone,

I'm happier than a clam to report that I got AGK2 apps running directly on my Iphone 4S (IOS 7.0.2) via Itunes software.

My had made the mistake of using the Developer profile provisioning on the Apple Developer site.

We need to use the Distribution profile AND only with the ADHOC option selected.
This wasn't intuitive for me because I thought the distribution option was only for apps we intended to distribute through the app store or Itunes.

Finding the UUID ID for the phone was also tricky. I plugged the phone in to the Mac, Ran Itunes, clicked on the phone icon and then had to click on the Serial number which turned it into the 40 digit UUID number. Then you copy the UUID number. Go back to the Apple Developer site and under the Devices section on the left click Iphones>+ (upper right portion of the screen) Type an identifiable name for the device and Paste the UUID number in the UUID box>Continue at the bottom of the screen.

Then I selected File>Export Project>IOS App
entered my splash screens, the correct provisioning protocol. I outputted the .ipa file into a directory that was writable (that also took a long time for me to figure out).

Make sure you've added the devices you've previously added the UUID numbers into in your provisioning profile.

I don't have any screen capturing software on my Mac or I would have made a video guide as I did this.

Hope this helps,

Bill

Login to post a reply

Server time is: 2017-04-24 16:03:12
Your offset time is: 2017-04-24 16:03:12