Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / AGK2 generated IPA rejected by Apple. Please HELP!

Author
Message
Zappo
12
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 10th Sep 2015 02:53
I am hoping someone might have some experience or advice on why my app has been denied by Apple.

I'm using AppGameKit 2 v2.0.14b tier 1 and the IPA export function. It builds the IPA fine and it works perfectly on my iPod Touch 4. I submitted it to iTunes Connect and after a few days got a 'rejected'. The reason given is "We were unable to review your app, as it crashed on launch".

It has never crashed for me and the crash logs they have provided have 'xxx' where it should identify the hardware it was tested on. The exception type is EXC_BAD_ACCESS with a subtype of KERN_INVALID_ADDRESS. I've tried importing the log into the Xcode Device logs window and it displays it but doesn't seem to do the "symbolication" where it is supposed to convert memory addresses to more useful function info. Apple's provided links offer no help.

Does anyone have a clue what I can do about this? I have seen mention of just submitting it again and it often gets accepted but I am worried about the limitation on how many times you can submit an app before they prevent you doing it again.

I have just had a quick try at using the 'interpreter_ios_lite' Xcode project and dropping all my media and bytecode into the media folder but it fails to build. I would much rather use the IPA export routine if possible. In the past I have converted everything to tier 2 when I needed the extra speed but I would rather not with this project. The Android exported APK works great and is already available on Google Play and the Amazon store.


Chart data provided with kind permission from ELSPA
Zappo
12
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 10th Sep 2015 05:57
I think I may have sorted this and it is partly my fault for having more than one version of AppGameKit 2 available. After doing some checks it looks like the working distributable IPA was built using v2.0.11 and a subtly broken IPA was built using v2.0.14b. The AppGameKit version is the only difference between the two.

For now I have gone completely back to v2.0.11 as the newer version doesn't seem to create working IPA files from the 'File/Export' menu. I have resubmitted the app using iTunes Connect so it's now a waiting game again.


Chart data provided with kind permission from ELSPA
JohnnyMeek
4
Years of Service
User Offline
Joined: 23rd Apr 2013
Location: Slovenia
Posted: 10th Sep 2015 15:47
I have published a lot of apps with 2.0.14b from the menu export option, without any rejections from apple.
WestLaBill
1
Years of Service
User Offline
Joined: 19th Sep 2015
Location: Malibu, CA
Posted: 20th Sep 2015 00:20
Hi Zappo,

Where can I find the 2.0.11 version of the software because I'm having the same issue with the 2.0.14b?

If it wasn't such a superior language to Xcode, I wouldn't be sooo eager to get this working.. I'll seriously be at least 20 times faster coding with this than Xcode.

I've downloaded the 2.0.14B from Steam and my IP 5 says my Hello world app failed to install. My IP 4S puts the app on the device but just starts eternally says installing after I tap it to run. I have Xcode apps I've developed that I've put directly on both these phones via my developer provisioning profiles.

I've tried every potential solution I could find on these forums since 2012 since last Wednesday.

I have not yet tried uninstalling and reinstalling it yet but I'm going to try that now.

Jonny Meek, is there any chance you could create a demonstration video of putting a hello world app on a phone?

The code runs locally on the Mac. Here it is in case there's something in the code that may be producing the issue. I've also tried making it just show the FPS previously.

+ Code Snippet

Thanks much,
Bill
Zappo
12
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 20th Sep 2015 05:17
Hi WestLaBill - It's nice to know I'm not alone in my Apple troubles.

Quote: "Where can I find the 2.0.11 version of the software because I'm having the same issue with the 2.0.14b?"


I purchased AppGameKit 2 directly from TGC so I get access to the current and previous version via the 'My Products' area. If you purchased yours through Steam I'm not sure how/if you can get it I'm afraid.

Quote: "My IP 4S puts the app on the device but just starts eternally says installing after I tap it to run."


I'm not sure if this will help but I have had this before. It was down to my test device ID not being in my list of devices on the Apple developer site, or not being ticked when the development or adhoc provisioning profile was generated. It can also do this if you build a release version to submit to the iTunes store and try to install that on your test device.

There doesn't seem to be much consistency with the Apple building and submitting to be honest so I am no longer convinced that a problem lies with AppGameKit 2.0.14b. I built the IPA again using 2.0.11 and my 'adhoc provisioning profile' to try on my test devices and it worked perfectly (as it always has). Then I built it immediately afterwards using the 'release provisioning profile' and submitted it to Apple. They have refused it again saying it crashes on startup.

I have renamed the two IPA files to '.zip', extracted them and looked inside the packages. The two builds appear identical - same files and same file sizes. The only difference is the provisioning profile I used. I am at a loss and Apple are supposed to be phoning me in the next day or two, although I am not sure why as I have put all the info in my feedback to them.

My frustration with Apple is at an all-time high with the cryptic hoops they make you jump through, their boilerplate responses that don't apply to the situation and don't answer my questions, and their outdated links which point to pages offering no help at all. Add to that the delay of about 7 days for them to test any new build and tell me it doesn't start up. I have it running in my hand right now on an iPad and an iPod Touch! Rant over


Chart data provided with kind permission from ELSPA
WestLaBill
1
Years of Service
User Offline
Joined: 19th Sep 2015
Location: Malibu, CA
Posted: 22nd Sep 2015 10:54
Thanks for your detailed reply.

As you suggested, I just created an additional developer profile and confirmed that I had checked both devices to be used.

I also tried to compiling various version of the agkinterpreter.xcodeproj but it keeps failing as the code is looking for many links that aren't there.

I tried the Tools>IOS>export AppGameKit Player and installing it via double clicking on the player.ipa and then syncing it with my IP 4S but that produces the same Installing forever issue on the device.

All the best,

Bill
Zappo
12
Years of Service
User Offline
Joined: 27th Oct 2004
Location: In the post
Posted: 22nd Sep 2015 18:05
Does double clicking the IPA file open up Xcode? I think it does on mine and I have never been able to push it out to my devices from Xcode.

To install it, try doing it through the iTunes application on your Mac. If you go to the 'Apps' section you can drag your IPA file over to the right hand area of that window. Dragging it to correct place on there can be hit and miss so drag it around until a box appears for you to drop it. Once it is in there you can click on your plugged in device and on its 'apps' section and hopefully you will see the new app and an 'install' button.

I also use an Adhoc profile rather than a Developer profile too. Those are the only things I can think of which are different to yours.


Chart data provided with kind permission from ELSPA

Login to post a reply

Server time is: 2017-04-24 16:05:19
Your offset time is: 2017-04-24 16:05:19