Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Geek Culture / Help with samba

Author
Message
Phaelax
DBPro Master
15
Years of Service
User Offline
Joined: 16th Apr 2003
Location: Metropia
Posted: 11th Dec 2015 07:01
I've recently set up a Cent OS 6.7 server to play with. It's been a long time since I've played with linux, so assume I'm a newbie. I installed samba using yum. Aside from changing the workgroup in the smb.conf file, I haven't done anything else. By default, there's already one share setup. (eventually I'll be sharing my web files folder as I have Apache running)
Default share:


I'm using Putty to access the server via SSH, so I know my connections are fine. But I can't access my share. I verified that the smb service is running. When I try to access it with Win7: \\10.0.1.3\homes it just says network error windows cannot access \\10.0.1.3\

\"I like offending people, because I think people who get offended should be offended.\" - Linus Torvalds
Van B
Moderator
16
Years of Service
User Offline
Joined: 8th Oct 2002
Location: Sunnyvale
Posted: 11th Dec 2015 12:13
I had a couple of issues like this, setting up wifi access to some documents (production specifications and instructions) on Android tablets. I ended up just forcing an admin account to get around the user access restrictions. Maybe worth trying an account with admin privileges and see if that lets you access it... then perhaps even setup an account just for that access and apply it to any device or PC when accessing the server. User permissions and trust relationships can be a minefield, I was lucky in that the data being accessed is disposable, it can be re-uploaded if it gets corrupted or interfered with, so having an admin account privilege sidestepped the issues with minimal risk.
Phaelax
DBPro Master
15
Years of Service
User Offline
Joined: 16th Apr 2003
Location: Metropia
Posted: 11th Dec 2015 19:09 Edited at: 11th Dec 2015 19:18
But I can't even connect to the share to login with anything. Normally when I connect to a network share, I would be prompted to enter credentials.


\"I like offending people, because I think people who get offended should be offended.\" - Linus Torvalds

Attachments

Login to view attachments
budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 11th Dec 2015 21:07
homes is a user-specific macro, there should be no "\homes" directory. For each smbuser you have, they will have their own home directory. So if you create smbuser Foo and have [homes] setup, you would have \\10.0.1.3\Foo network directory. Try creating a different share like [test] and see if you can connect to that.
"Giraffe is soft, Gorilla is hard." - Phaelax
Phaelax
DBPro Master
15
Years of Service
User Offline
Joined: 16th Apr 2003
Location: Metropia
Posted: 12th Dec 2015 20:44 Edited at: 12th Dec 2015 21:24
A friend suggested I take a look at the firewall. I disabled iptables to give it a try and now I can connect to the server. I made a share to an apache folder to where I can upload web files. I can connect but not login. It just won't accept my credentials.



I added the users to samba with smbpasswd, something I didn't realize I had to do. I can get a directory listing of shares at the server's IP but still can't access them. It says I don't have permission.

\"I like offending people, because I think people who get offended should be offended.\" - Linus Torvalds
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 12th Dec 2015 23:51
Check user read/write permissions?
Phaelax
DBPro Master
15
Years of Service
User Offline
Joined: 16th Apr 2003
Location: Metropia
Posted: 13th Dec 2015 01:23
Can you elaborate?

\"I like offending people, because I think people who get offended should be offended.\" - Linus Torvalds
budokaiman
FPSC Tool Maker
9
Years of Service
User Offline
Joined: 24th Jun 2009
Playing: Hard to get
Posted: 13th Dec 2015 12:01 Edited at: 13th Dec 2015 12:04
What is your apache configuration? Apache and samba use different authentication, so if you have an smbuser who can connect through samba's authentication, you will also have to setup users and passwords (either through ldap, basic or digest authentication) for apache to use.

As for the permissions, run "ls -l" command and make sure that all users who can connect have permissions (folder permissions should be "drwxrwxrwx" to give all users permission to the folder after authentication).
"Giraffe is soft, Gorilla is hard." - Phaelax

Login to post a reply

Server time is: 2018-11-17 23:10:36
Your offset time is: 2018-11-17 23:10:36