Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

iOS and MacOS / Beta Toolchain. This app has been built using beta toolchains

Author
Message
crumpet
1
Years of Service
User Offline
Joined: 17th Jun 2016
Location:
Posted: 17th Jun 2016 07:16
im getting the following error when trying to submit the app through the Application Loader:

+ Code Snippet
I have the latest version of xcode Version 7.3.1, and my OSX isn't beta either

Any ideas what the problem might be?!
crumpet
1
Years of Service
User Offline
Joined: 17th Jun 2016
Location:
Posted: 17th Jun 2016 21:52
Is it possible that the agk exporter is compiling with an older toolchain? i'm seeing BuildMachineOSBuild 15C65 inside the app info.plist, and it doesnt match with any of the release versions of OSX.

i tried to do a workaround and change the build number on my mac but it doesn't change when exporting the app with AGK.

see: https://georgegarside.com/blog/ios/submit-apps-built-beta-xcode/
crumpet
1
Years of Service
User Offline
Joined: 17th Jun 2016
Location:
Posted: 18th Jun 2016 01:33
found a solution posted in this thread by Paul Johnston https://forum.thegamecreators.com/thread/217220

Quote: "If you right click AGK2.app and browse to "Contents/Resources/share/geany/ios/source", right click on "AGK 2 Player.app" and replace Info.plist with the attached version, and then export, does it work?"


its not nesscary to replace the entire info list , it will also work by editing the BuildMachineOsBuild entry in the list to 15F34 . thank god for pauls solution because I thought I was done for.

Login to post a reply

Server time is: 2017-07-26 03:44:12
Your offset time is: 2017-07-26 03:44:12