Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / Some programs do not execute after compiling

Author
Message
CSL
10
Years of Service
User Offline
Joined: 22nd Mar 2009
Location: USA
Posted: 18th Sep 2016 21:52 Edited at: 18th Sep 2016 21:55
I have DBPro v 1.077 with Matrix1 and D3D plugins on two Win 10 computers at home.
For the sake of explanation, I have two programs A and B on both PC1 and PC2.

Program A compiles and runs on PC1. Program A uses both Matrix1 and D3D commands.
Program A compiles but does NOT run on PC2. It does NOT run in debug mode.

Program B compiles but does NOT run on PC1. Program B has no commands from any plugin. It runs in Debug Mode.
Program B compiles and runs on PC2.

I have deleted and re-created the project files for both programs on both computers.
I have re-built keywords.
My DBPro application folder security is completely open (Full control for All Users) on both computers.

My only conclusion so far has to do with the DBPro versions where the programs were originally written. I thought that by re-creating the project files I would solve any corruption, but that didn't solve my problem.
I've searched the forum for similar problems but the solutions have not worked for me. I'm stumped here and really need some help.
CSL
Ortu
DBPro Master
11
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 20th Sep 2016 00:07
Are you getting any specific error messages?

On the ones that don't run, does it crash? Give an error? Do nothing?


A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
Mage
12
Years of Service
User Offline
Joined: 3rd Feb 2007
Location: Canada
Posted: 20th Sep 2016 05:06 Edited at: 20th Sep 2016 05:08
On the subject of inconsistent behavior:

I'll also add for reference that I recently discovered any/all DBP programs will not register keyboard and mouse input/movement (except escape key to end program) when an Xbox One controller is plugged into one of my computers (the other is fine).
Working fine before Windows 10 upgrade but after, and with full DX9 installed even previously compiled programs won't register the inputs.
CSL
10
Years of Service
User Offline
Joined: 22nd Mar 2009
Location: USA
Posted: 20th Sep 2016 18:27 Edited at: 20th Sep 2016 18:29
Quote: "Are you getting any specific error messages?
On the ones that don't run, does it crash? Give an error? Do nothing?"


F4 - Compile only - no errors
F5 - Compile and run - Compiles, no errors, and shows the executing... text but no output and no executable created. As I mentioned above, one of the programs only runs in debug mode (F6) on one of the computers.
F8 - Nothing happens, with or without an EXE file. I have older EXE files from when the programs used to work years ago, some of these don't work anymore, depending on which computer I use. No rhyme or reason if you ask me.

I'm quite sure this has to do with the DBPro version in Github. I used to have the CD version, which installed in PRogram Files X86, Dark Basic Professional Folder. Then I purchased the online version around 2009 as part of a special bundle. Then recently I downloaded the free Github version without the license key requirement. I'm sure there's a mixup of online, disc and github files that's screwing things up but I haven't found the correct combination of files to make everything work on both of my computers.

I have systematically uninstalled everything and reinstalling only the disc version, then the updates up to 7.62 and RC7 then installing the plugins. I have also tried copying the entire folder structure from one computer to another. I have tried installing the online version, then copying the certificates folder to skip the registration process that no longer works. It's very frustrating.
CSL

Login to post a reply

Server time is: 2019-08-21 01:24:31
Your offset time is: 2019-08-21 01:24:31