Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / What is causing this?

Author
Message
LiamBradbury
8
Years of Service
User Offline
Joined: 28th Apr 2011
Location: Manchester, UK
Posted: 11th Oct 2016 02:41
For some reason when I have an object behind this tree object, it doesn't show up. I can't figure out why! My player object can walk behind fine and it looks ok but any other object is hidden.

Here's a quick video of the problem:
www.liambradburymusic.com - professional music for your games.
Ortu
DBPro Master
11
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 11th Oct 2016 03:44
Looks like a transparency mode issue on the tree leaves


A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
LiamBradbury
8
Years of Service
User Offline
Joined: 28th Apr 2011
Location: Manchester, UK
Posted: 11th Oct 2016 05:12
How would I fix that? I've tried culling and setting transparency on / off but doesn't work. Is it because the tree is a cloned object?
www.liambradburymusic.com - professional music for your games.
Ortu
DBPro Master
11
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 11th Oct 2016 05:47
I haven't used the commands in a while, but when you use set object transparency, I believe one of the parameters is a mode flag, these affect how transparent areas are handled. I remember the modes went up through at least 6. One of these modes will likely fix this issue. There should be details in the help page for this command


A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
LiamBradbury
8
Years of Service
User Offline
Joined: 28th Apr 2011
Location: Manchester, UK
Posted: 11th Oct 2016 06:15
Thanks I'll have a look tomorrow.
www.liambradburymusic.com - professional music for your games.
evilsourcil
2
Years of Service
User Offline
Joined: 10th Oct 2016
Location:
Posted: 11th Oct 2016 11:20
Hello
I think you can solve your problem by changing the object load order, the tree <=> character
For to view the sheet engine marks the zbuffer even on the edge of the leaves where it is semi-transparent. After that the engine tries to display the character and this one is not displayed because of zbuffer.
Bye
LiamBradbury
8
Years of Service
User Offline
Joined: 28th Apr 2011
Location: Manchester, UK
Posted: 11th Oct 2016 22:24
I used 'set object transparency treeobject,2' and it's working fine now. Thanks everyone
www.liambradburymusic.com - professional music for your games.

Login to post a reply

Server time is: 2019-05-25 19:53:54
Your offset time is: 2019-05-25 19:53:54