Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Author
Message
klarkit
7
Years of Service
User Offline
Joined: 27th Feb 2010
Location:
Posted: 2nd Mar 2017 20:47 Edited at: 2nd Mar 2017 20:48
IDE says it cannot understand the if statement in this function.
I'm following an older tutorial from 2010 if that helps any.
+ Code Snippet

any help is greatly appreciated.
Thanks
Bored of the Rings
12
Years of Service
User Offline
Joined: 25th Feb 2005
Location: Middle Earth
Posted: 3rd Mar 2017 16:33 Edited at: 3rd Mar 2017 16:35
seems to compile ok on my DBPro version which is the open source
Professional Programmer, languages: SAS, C++, SQL, PL-SQL, DBPro, Purebasic, JavaScript, others
klarkit
7
Years of Service
User Offline
Joined: 27th Feb 2010
Location:
Posted: 3rd Mar 2017 17:39 Edited at: 3rd Mar 2017 17:45
Okay I'll try that one as I am using the 9EX version.
edit: no luck. Very strange. Using either open source or 9EX I get same error.
Here is full code
+ Code Snippet
Rudolpho
11
Years of Service
User Offline
Joined: 28th Dec 2005
Location: Sweden
Posted: 3rd Mar 2017 21:19
Compiles fine for me.
Could you share your DBPro Installation\TEMP\FullSourceDump.dba file after building, as well as the error message you're getting?
klarkit
7
Years of Service
User Offline
Joined: 27th Feb 2010
Location:
Posted: 3rd Mar 2017 21:39 Edited at: 3rd Mar 2017 21:42
I believe the issue is the advanced terrain package is not working for me.
Is it included with the open source DBPro or do I need to install it?
I tried installing it but it gives me a reg error. RegDBGetKeyValueEx is the error.
Derek Darkly
6
Years of Service
User Offline
Joined: 22nd Sep 2011
Location: Whats Our Vector, Victor?
Posted: 4th Mar 2017 18:54 Edited at: 4th Mar 2017 18:56
I once requested a fresh Advanced Terrain .dll file

(I can't recall if it solved my problem.)
Send your parents to noisy sprite demo hell... enter the D-Zone
klarkit
7
Years of Service
User Offline
Joined: 27th Feb 2010
Location:
Posted: 4th Mar 2017 20:40
Great that solved that issue. Now to fix my matrix Utility issues.
Again thanks.
Bored of the Rings
12
Years of Service
User Offline
Joined: 25th Feb 2005
Location: Middle Earth
Posted: 5th Mar 2017 06:25
sorry, I meant I'm using the open source , but 9EX upgrade.
Professional Programmer, languages: SAS, C++, SQL, PL-SQL, DBPro, Purebasic, JavaScript, others
Derek Darkly
6
Years of Service
User Offline
Joined: 22nd Sep 2011
Location: Whats Our Vector, Victor?
Posted: 5th Mar 2017 14:23
You should find M1Utils as well as BlitzTerrain and a few other goodies that I linked/uploaded here:

https://forum.thegamecreators.com/thread/218439
Send your parents to noisy sprite demo hell... enter the D-Zone
klarkit
7
Years of Service
User Offline
Joined: 27th Feb 2010
Location:
Posted: 5th Mar 2017 20:34
Thanks for the link. I already have the utilities they are just giving me some command unrecognized errors on move object.
I do appreciate all the help.

Login to post a reply

Server time is: 2017-10-20 17:17:30
Your offset time is: 2017-10-20 17:17:30