Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Product Chat / watercurrent/waterflow actions don't work

Author
Message
KingMassen
1
Years of Service
User Offline
Joined: 23rd Dec 2016
Location:
Posted: 25th Jul 2017 22:16
Hi there

I was trying to test out these two actions: "watercurrent=x" ,"waterflow=x"

According to the syntax list, "watercurrent" is used to set THE DIRECTION of water flow ,while "waterflow" is used to set the MAGNITUDE OF THE FORCE of the water flow ,correct?

Now both of them actually don't work .... like I can't see water moving in the set direction and when the player jumps into the water or any dynamic entity is put in it, it doesn't move at all ,just keeps floating then starts to sink ....

I tested that in 'test level' inside the level editor ,not in a built game ,maybe that's the reason? ....
ncmako
6
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 26th Jul 2017 23:23
KingMassen Just tested these commands with BI mod and everything still works fine even using just a test build.
What does your script look like? Mine is very basic...

I used one I already had done. I made a simple trench one segment wide and only about 4-5 long. Threw in some barrels and they flowed to the other end
I had player go underwater and he would also be pulled to one end. I don't see anything wrong.
best
My games never have bugs. They just develop random features..
Lots and lots of random features...
KingMassen
1
Years of Service
User Offline
Joined: 23rd Dec 2016
Location:
Posted: 27th Jul 2017 20:00
Hmmmm ... it worked

But seriously ,it didn't work before ... I was planning to put something in my game such that the player has to turn off a pump engine or something to turn off water movement to be able to proceed ...

Maybe it didn't work because the whole room was full with water? Don't know ....

Login to post a reply

Server time is: 2018-11-17 23:43:57
Your offset time is: 2018-11-17 23:43:57