Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPS Creator X10 / Invisible Weapon bug

Author
Message
Darkness1993
1
Years of Service
User Offline
Joined: 11th May 2016
Location:
Posted: 29th Jul 2017 18:17 Edited at: 29th Jul 2017 18:26
Hey guys,

so I'm having this very weird problem. I'm using a custom axe weapon (https://forum.thegamecreators.com/thread/82518) and for quick testing have the player spawn point start with the axe. When I go into Test Game on my main computer the axe doesn't show or even register as a usable weapon (it just shows the correct crosshair image which is a small white dot, yet when I try to break the wall nothing happens). Here's the weird thing.. when I build the game and test on my main computer (Windows 7) the axe is still invisible HOWEVER when I test the built game on my laptop (also Windows 7) the axe is visible and usable. Before you ask what my specs are etc. I'll also say that I've had the axe working fine in the past on my main computer (https://youtu.be/d8Qrgt33z3w) though can't remember if I fiddled with the files again, but that shouldn't matter because as I said it shows up fine on my laptop. I also tested on my sister's computer (Windows 10) and the axe is invisible..

Any ideas?

One last thing I'll add is that if I press "0" on the keyboard to holster the axe, it actually appears and plays the holster animation. I can then press "1" to get it back out and all's fine, but when my mates are play-testing it I don't want them to have to do the same tedious thing every time they pick up the axe!

Thanks,
Darkness1993
Darkness1993
1
Years of Service
User Offline
Joined: 11th May 2016
Location:
Posted: 31st Jul 2017 14:19
It's all good now! I updated my graphics drivers and the problem magically rectified itself. Must've been some strange bug with the previous version.. anyway leaving this info here to help others

Login to post a reply

Server time is: 2017-08-19 02:50:17
Your offset time is: 2017-08-19 02:50:17