Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Newcomers AppGameKit Corner / AGK remembers the last size and does not revert back to SetVirtualResolution

Author
Message
Golelorn
3
Years of Service
User Offline
Joined: 20th Nov 2016
Location:
Posted: 12th Sep 2017 01:35
I have only had this happen twice. The first time - I restarted and it fixed it. This time I can't fix it. It is not defaulting to the setvirtualresolution when I hit Run. Its goes back to the last screen size when I exited the last Run. Unfortunately, most of the time that is minimized. So there is no screen.

I am assuming I accidentally hit a hotkey that turned this option on. Any help?
Cybermind
Valued Member
17
Years of Service
User Offline
Joined: 28th Nov 2002
Location: Denmark
Posted: 12th Sep 2017 12:21
You can use SetWindowSize( X , Y , fullscreen toggle) at the beginning of your code, this will give the window a default size on start
13/0
Golelorn
3
Years of Service
User Offline
Joined: 20th Nov 2016
Location:
Posted: 18th Sep 2017 01:31
I have to do that, so thank you.

But it still doesn't explain why this suddenly started to happen after 8 months of use. I think I accidentally hit a shortcut key to turn some weird setting on that makes AppGameKit remember the last window size. Why doesn't it recognize the virtual resolution?
PartTimeCoder
AGK Tool Maker
5
Years of Service
User Offline
Joined: 9th Mar 2015
Location: Suffolk UK
Posted: 18th Sep 2017 18:42
I actually consider that a feature and a very handy one, its useful when debugging and needing access to the IDE for skipping breakpoints and viewing debug data, not have to resize and move the window every time I debug the app, its easy to reset everything after.

Login to post a reply

Server time is: 2020-04-05 20:45:27
Your offset time is: 2020-04-05 20:45:27