Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / Is the activation server down?

Author
Message
Quantum Fusion
10
Years of Service
User Offline
Joined: 1st Aug 2008
Location: The Great White North
Posted: 17th Dec 2017 06:02 Edited at: 17th Dec 2017 06:03
After nearly a decade I've decided to reinstall my copy of DBPro.

But I keep getting the "Unable to get response from server. A firewall may be blocking this application."

I've disabled the Windows firewall, the router firewall, added exceptions to the Windows firewall for all of the DB exes, turned off the anti-virus software, and running it as Administrator. But it still gives me that message.

I've installed it on Windows 10 (64 bit).

Any help would be appreciated.
Bored of the Rings
13
Years of Service
Recently Online
Joined: 25th Feb 2005
Location: Middle Earth
Posted: 17th Dec 2017 06:30 Edited at: 17th Dec 2017 06:31
the activation server no longer functions since DBPro went open source (Github). Also, see first post on this forum (DBPro 9Ex).
Professional Programmer, languages: SAS, C++, SQL, PL-SQL, DBPro, Purebasic, JavaScript, others
zero32
2
Years of Service
User Offline
Joined: 28th Jul 2016
Location:
Posted: 17th Dec 2017 06:55 Edited at: 17th Dec 2017 06:55
https://forum.thegamecreators.com/thread/219455 <- some short guides: how to install open source version + how to activate already installed Dark Basic Pro using the open source license files + my dbpro folder (U7.6, works on windows xp)

https://forum.thegamecreators.com/thread/220966 <- Ortu's framework and build utilities.
Ortu wrote: "DBPro Folder:

In here you will find a full, usable install of vanilla/official DBPro U77 ready to go. So many people come through here with trouble trying to get the open source version working or to get their old installation reinstalled or moved to a new machine. It includes many of the popular free community plugins. It does not include any of the paid plugins.

It also has a second copy of this version with Rudolpho's 9Ex installed over it."
"It is only slightly easier than changing all sugar in a cake into stevia after it has already been baked" -Bisqwit
Quantum Fusion
10
Years of Service
User Offline
Joined: 1st Aug 2008
Location: The Great White North
Posted: 17th Dec 2017 20:33
Many thanks!
zootan
8
Years of Service
User Offline
Joined: 12th Apr 2010
Location:
Posted: 1st Feb 2018 20:28
i have the full package any ideas how to get paid plugins to work?
Nomad Soul
11
Years of Service
User Offline
Joined: 9th Jan 2007
Location: United Kingdom
Posted: 3rd Feb 2018 19:29
I have a problem.

When I download the free DBPro open source from GitHub
https://github.com/TheGameCreators/Dark-Basic-Pro

If I go to the Install folder then open Launch.exe and check about DBPro information it says v1.071.

I followed the instructions on the thread below but whenever I try updating to U77 RC7 the installer fails saying 'update aborted. could not detect Dark Basic Pro installation'.
https://forum.thegamecreators.com/thread/219455

Does anyone know why the update installer is failing or how I can fix this to get v1.077?
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 3rd Feb 2018 19:47
A full portable copy of U77 r7 is included in the package i posted here:

https://forum.thegamecreators.com/thread/220966
http://games.joshkirklin.com/sulium

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
Nomad Soul
11
Years of Service
User Offline
Joined: 9th Jan 2007
Location: United Kingdom
Posted: 3rd Feb 2018 21:34
Thanks Ortu

Just 1 thing. After I associate the IDE with the DBPro compiler in Dark Basic Professional Online, it says DBPro version is 1.054 on the about information but I am expecting 1.077.

Is everything definitely updated for U77 r7?
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 3rd Feb 2018 22:21
99% positive...

You should see a file in the Dark Basic Professional Online directory: upgrade7_7.txt as well as a folder 'VersionHistory' including upgrade5.txt through upgrade7_6.txt
http://games.joshkirklin.com/sulium

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
Nomad Soul
11
Years of Service
User Offline
Joined: 9th Jan 2007
Location: United Kingdom
Posted: 3rd Feb 2018 22:28
Yeah I can see those.

It seems to be the dbp_config.dll in the Editor folder which updates the DBPro version number. I copied one from an older installation I had updated across and it now says DBPro v1.077

Not sure how important this dll is or what it actually does though
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 3rd Feb 2018 22:47
Interesting... I've tried to test if the changes in the U77 patch notes are present and they do not seem to be.

It looks like this may indeed be version U54, my guess is that dbpro must have gotten re-installed at some point but not all of the upgrades were re-applied.

Sorry about that!
http://games.joshkirklin.com/sulium

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
Nomad Soul
11
Years of Service
User Offline
Joined: 9th Jan 2007
Location: United Kingdom
Posted: 3rd Feb 2018 23:05
Ok no problem,

Please can you post once the package has been updated for U77 again. I would be very grateful.
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 4th Feb 2018 01:04 Edited at: 4th Feb 2018 01:06
I do have the upgrade installer, so I will give it a try.

However, if it has to contact activation servers, these are down and that will fail, also if it tries to read an install location from the registry that will also fail as this is portable (not installed), I could maybe hack in the needed registry keys if someone has an old install for reference as to what keys get registered and where. Unfortunately, the pc that had my original install finally gave up and died in December and that drive has been wiped.

We'll see how it goes.

Ill keep versions 5.4 and 7.7 as separate packages if I can get it to work, more options are always good and I think u77 did break compatibility with some plugins
http://games.joshkirklin.com/sulium

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.
Ortu
DBPro Master
10
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 4th Feb 2018 04:28 Edited at: 4th Feb 2018 05:43
ok success!

I'll get the github repo updated shortly



Thanks man, I really thought I'd been using U77 all this time. It's good to get this cleared up, and now we've got both versions 5.4 and 7.7 portable installs.

Edit--

Well hell, I don't know. I did a full new install of 5.4 on a clean machine, copied over the activation cert from the portable, ran the U77 upgrade, and now the IDE shows the correct version... but otherwise it does seem to be the same as the previous version included in the portable I posted. the documented changes in the 7_7 log for adding 'perffreq' and 'set sprite resize' parameters still do not show up in the keywords or help docs ( I don't know if these ever did really...)

The compiler date and size is the same on both the posted version and this new install + upgrade.

So this leads me to believe that the posted version is indeed U77 as I had thought initially.

Edit Again --

Ok, yes. the posted version is U77.

The command set sprite resize 1, 1.0, 1.0 compiles without issue even though the help files are not updated to reflect these new parameters. the last 2 parameters were added in the U77 update, previously it only had one 'mode' parameter. This should not compile if the version was not at U77

I will go ahead and post an update with the current dbp_config.dll so that the correct version is displayed.
http://games.joshkirklin.com/sulium

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.

Attachments

Login to view attachments

Login to post a reply

Server time is: 2018-11-20 13:42:20
Your offset time is: 2018-11-20 13:42:20