Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Chat / Bug from 24/5/2018 version - Fullscreen mode.

Author
Message
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 25th May 2018 14:00
Hi - the app I'm developing runs in fullscreen mode and began working strangely as of yesterday with the new version. The first couple of frames take about 3 seconds to display each.

By some experimentation, I see this only affects full screen mode - I cut everything down to this to prove it.




This version runs fine in windowed mode. But if you change to SetWindowSize( 1024, 768, 1 ), you get the same as in my APP, the first two frames take an age...
Xaron
4
Years of Service
User Offline
Joined: 3rd May 2014
Location: Germany
Posted: 25th May 2018 14:39
Runs without issues on my Windows 7 machine.
PSY
Valued Member
1
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 25th May 2018 15:55 Edited at: 25th May 2018 15:57
Runs smoothly under both 32 and 64 bit on my Windows 10 machine.

Sounds at first glance like a energy-saving related issue, but since it didn't show up until the latest update, I guess that can be ruled out.

Did you compile under 64 bit prior to the latest update? Because every update resets the interpreter to 32 bit default...


PSY LABS Games
Coders don't die, they just gosub without return
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 25th May 2018 23:39
I'm running under Windows 10 too.

I confess I'm not sure how to compile under 32 or 64 bit - I have always just compiled things...
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 26th May 2018 00:10
Hmm - my Windows 10 updated on that day too...

This is enough to see the problem on my computer.

c0d3r9
User Offline
Joined: 2nd Oct 2017
Location:
Posted: 26th May 2018 00:34
Runs smooth in windowed and fullscreen mode compiled with 32bit and 64bit.
PSY
Valued Member
1
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 26th May 2018 08:26 Edited at: 26th May 2018 08:27
Quote: "I confess I'm not sure how to compile under 32 or 64 bit - I have always just compiled things..."


No prob, here's the thread with the info on that:
https://forum.thegamecreators.com/thread/221939


PSY LABS Games
Coders don't die, they just gosub without return
Santman
6
Years of Service
User Offline
Joined: 15th Sep 2011
Location: Inverness
Posted: 26th May 2018 19:28
Have an Nvidia card with GeForce experience? Whenever you run an app the GeForce overlay kicks in then the frame rate dies while it come on and goes off. Always done this for me.
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 27th May 2018 21:27
Since I last posted, I have checked 32 and 64 bit mode, updated my graphics card driver - and no, I don't have the NVidia card with GeForce. No luck.

AGK is the only application that is suffering from the problem - about 3 seconds each for the first 2 frames. I have kind of fixed this in my App by doing a couple of sync() commands first thing - but it still means I have a 6 second delay every time I run!

Does anyone know if it is possible for me to revert my AppGameKit back to previous version? Or is that only Beta versions on Steam where I remember you can do this?
DavidAGK
4
Years of Service
User Offline
Joined: 1st Jan 2014
Location:
Posted: 27th May 2018 21:52
I’ve had exactly this type of scenario. Wait a few days before doing anything drastic. Windows 10 does all sort of cleanup after updates. A few reboots and a few days and you might find the problem just goes away!!! That’s what happened with me, after someone on this forum gave me the exact same advice.
Using Tier 1 AppGameKit V2
Started coding with AMOS (Thanks Francois Lionet)
PSY
Valued Member
1
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 28th May 2018 17:21 Edited at: 28th May 2018 17:22
This might be worth a try:


1. Go to your Windows settings
2. Click on Gaming
3. Disable Game Bar and Game DVR

Game DVR is known to be buggy since the Creator's Update on some machines


Also run the Windows internal Disk clean-up tool


PSY LABS Games
Coders don't die, they just gosub without return
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 29th May 2018 17:23
Thanks guys - tried these but still no joy...
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 6th Jun 2018 19:08
Found one more clue - it's not just when the app starts, it also happens when you alt tab away, and then alt tab back. i.e. it is whenever the fullscreen AppGameKit window gets focus.

Any ideas?
Hudd
10
Years of Service
User Offline
Joined: 23rd Aug 2007
Location:
Posted: 9th Jun 2018 10:48
Eventually I have found the problem - no fix though, I think definitely there is something wrong with AGK.

If I have my monitor set to 3840 x 2160, which is the recommended size, I get the bug. If I lower the resolution to any other value, even 3200 x 1800, it works fine!

Login to post a reply

Server time is: 2018-06-22 23:43:29
Your offset time is: 2018-06-22 23:43:29