Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / [SOLVED] Bug in "AUTOMATIC CAMERA COLLISION" ? 4 arguments are not allowed.

Author
Message
blackdrake
2
Years of Service
User Offline
Joined: 21st Aug 2015
Location:
Posted: 26th May 2018 09:46
Hello,

I think I have found a bug in the function "automatic camera collission". I am using the current GitHib version I have checked out yesterday (Compiler reports to be 1.071)

The help offers two possible syntax possibilities:



In the help, there is also an example stating the usage:



I have an old game which works with this code. But in the newer version of DarkBASIC Pro, it does not work. The compilation won't succeed, because it says "Syntax error".
I found out that the compiler does not accept the syntax with 4 arguments. Only 3 arguments are possible.

If this was an intentional change, then my question is how I can mange to allow the camera to be pushed around by other objects?

Thank you for your help!

The author of this post has marked a post as an answer.

Go to answer

Derek Darkly
6
Years of Service
User Offline
Joined: 22nd Sep 2011
Location: Whats Our Vector, Victor?
Posted: 26th May 2018 20:36

I'm using compiler version 1.075 and this works:



Send your parents to noisy sprite demo hell... enter the D-Zone
blackdrake
2
Years of Service
User Offline
Joined: 21st Aug 2015
Location:
Posted: 27th May 2018 12:38
Thank you for your message. With your code, I also receive the error message:

Quote: "Parameter for 'AUTOMATIC CAMERA COLLISION' do not match 'Camera Number, Radius, Response' at line 1."


How did you get the version 1.075 ?

I downloaded the GitHub version ( https://github.com/TheGameCreators/Dark-Basic-Pro/archive/Initial-Files.zip ) two days ago.
When I click at "Help --> About Dark Basic Pro", I see a message box stating version 1.071 .
Is there a new Beta/RC-Build I am missing?
Derek Darkly
6
Years of Service
User Offline
Joined: 22nd Sep 2011
Location: Whats Our Vector, Victor?
Posted: 27th May 2018 18:05
This post has been marked by the post author as the answer.

I think there are a few good download links available. (Keeping in mind you may want to scan any files you download for viruses of course.)
I found one workable link here.

I think that is the right installer for 1.075, although the installer I have is 237MB instead of 231.
If that one doesn't work, I'll upload mine to Zippyshare for ya.
Send your parents to noisy sprite demo hell... enter the D-Zone
blackdrake
2
Years of Service
User Offline
Joined: 21st Aug 2015
Location:
Posted: 30th May 2018 16:40
Thank you for your answer.

With this version (which reports to be 1.075), everything works. Also, several other bugs of the GitHub version (like broken collissions and output EXE files without icons) are fixed. I kinda think that the GitHub version is some kind of older version??
I'm a bit confused about this, and I wonder how I can be sure that I got the latest version. Is there an official link to the latest version?
WickedX
9
Years of Service
User Offline
Joined: 8th Feb 2009
Location: A Mile High
Posted: 31st May 2018 01:55 Edited at: 31st May 2018 01:57
I think 7.62 is the current official version. Most here use U77 Public Release Candidate.

Login to post a reply

Server time is: 2018-08-19 18:59:06
Your offset time is: 2018-08-19 18:59:06