Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Chat / Issue with AGK tier 2: template_android_google

Author
Message
spasski
AGK Backer
5
Years of Service
User Offline
Joined: 2nd Jan 2013
Location: Amsterdam
Posted: 5th Jun 2018 08:45 Edited at: 5th Jun 2018 08:46
Hi,

I can't get the android tier 2 template to run on my device. I followed the steps from this guide https://www.appgamekit.com/documentation/guides/25_android.htm. I get to the point that Android Studio compiles the APK without errors but when I try to run it on my old device (api 17) or on a newer virtual device (api 26) it crashes at startup: AKT Template has stopped

This is what the logcat is saying:



So it looks like the issue is with the libandroid_player.so file. I did ran the jniCompile.bat succesfully by the way. The log shows 2 warnings:



Anyone ran into this too?
Anyone know a way to solve it?
spasski
AGK Backer
5
Years of Service
User Offline
Joined: 2nd Jan 2013
Location: Amsterdam
Posted: 5th Jun 2018 08:54
Ok, found something on the forum I will check. Need to update the android NDK: https://forum.thegamecreators.com/thread/222088
spasski
AGK Backer
5
Years of Service
User Offline
Joined: 2nd Jan 2013
Location: Amsterdam
Posted: 5th Jun 2018 10:07
Ok, issue is gone and the app runs smoothly now

I needed to change/rerun the jniCompile.bat file pointing to the latest android ndk: android-ndk-r17.

Login to post a reply

Server time is: 2018-06-22 23:40:16
Your offset time is: 2018-06-22 23:40:16