Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / Need tester to check if Google Play Games login works

Author
Message
PSY
Valued Member
2
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 6th Jun 2018 18:26 Edited at: 6th Jun 2018 18:29
Hey guys,

A game I coded some time ago wouldn't connect to Google Game Center anymore.
It used a pretty old API and Android version, so I updated it to Minimum Android Version 8.0 ( API 26 )

Spaze Haze https://play.google.com/store/apps/details?id=com.psylabs.spacehaze

I still have a Galaxy S4, which runs Android 5.01, so I can't test it myself Oo

Can anyone please download and install the game, and see if it connects to Google Game Center?
It should display your Game Center name if it works correctly.


Thanks alot,
PSY


PSY LABS Games
Coders don't die, they just gosub without return
smallg
Valued Member
12
Years of Service
User Offline
Joined: 8th Dec 2005
Location: steam
Posted: 6th Jun 2018 18:42
you don't need to set the minimum to 8.0, it's only the target - AppGameKit will handle that automatically in the next update.
life's one big game
spec= 4ghz, 16gb ram, AMD R9 2700 gpu
PSY
Valued Member
2
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 6th Jun 2018 19:09 Edited at: 6th Jun 2018 19:56
I don't understand what you mean.

When I uploaded the app to Google Play Console, Google said the API levels were sufficient now ( Export options 8.0 API 26 ).
But I can't downgrade the version in Google Play Console anymore, which sucks
Once you uploaded a version which requires Android version X, you can't upload an older version later on.

I can download an old version on my Galaxy S4, but I'm still getting the Unable to sign in to Google Play Games Message.

How do I solve this?

(edit) Just found this thread:
https://forum.thegamecreators.com/thread/222231


So the version I had in the store didn't work anymore because the SDKs it was compiled with were outdated, or for some other unknown reason.
The new version I uploaded today could work, but I can't test it, because I set the Minimum to 8.0 when exporting, and I only have a Galaxy S4 to test.
I could compile and export a new version with Minimum set to 4.x, but Google Play Console won't accept it. ( See attachment )
I just found out about the RequestPermission command, which I didn't build in the new version.


So probably nothing will work.
What do I do now? Wait for the next AppGameKit update, compile a new version which uses SDK 26, upload it and buy a new phone ( need that anyway )?

That Google Game Center crap starts to annoy me.
They build the most advanced AIs and can't get their Game Center implementation straight Oo


PSY LABS Games
Coders don't die, they just gosub without return

Login to post a reply

Server time is: 2018-10-19 03:19:26
Your offset time is: 2018-10-19 03:19:26