Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

DarkBASIC Professional Discussion / Dark basic pro still the best

User Offline
Joined: 2nd May 2018
Posted: 23rd Dec 2018 19:28
Dark basic pro is still the best coading software out there, graphics are decided on you, so dont blame that.

Its the easiest language to code in, so I think it is still the best and should have never been abandoned.
Years of Service
User Offline
Joined: 11th Dec 2012
Posted: 24th Dec 2018 03:38
Many programers call this language "c++ on steroids" but in fact DBPro is actualy a step above c++ so I`m with you.
Years of Service
User Offline
Joined: 22nd Aug 2008
Posted: 24th Dec 2018 09:31
Quote: "DBPro is actualy a step above c++"

You do know that DBP is written in c++ ? ...
[]Spark Particle engine[/href]
[]Transform gizmo plugin[/href]
Derek Darkly
Years of Service
User Offline
Joined: 22nd Sep 2011
Location: Whats Our Vector, Victor?
Posted: 1st Jan 2019 22:08

Doesn't everything boil down to assembly code? "Best" is a personal interpretation at best.
I haven't bought AppGameKit yet, but it seems like new-age DBP for those who actually want to sell a game.
And cheers to those who have!
Send your parents to noisy sprite demo hell... enter the D-Zone
Years of Service
User Offline
Joined: 24th Feb 2005
Location: nm usa
Posted: 16th Jan 2019 07:06
i will always love dbpro. been playing atound with agk lately after years of trying to ignore it but dbpro is no longer supported and mobile rapid dev is the future for indie. i must say though agk annoys me with all the usless extra keystrokes. get this get that extra usless words everywhere in almost every command. darkbasic had a few of these but agk is horrible. type a million lines of agk commands in your life and half the keystrokes are extra and pointless. it needs to be streamlined like "screen width()" instead of " getmaxdevicewidth()" harder to read and two usless words " get max." i get trying to make it easy to read but there comes a point where it greatly slows down production.
A child's dream never dies.

DBPro Master
Years of Service
User Offline
Joined: 21st Nov 2007
Location: Austin, TX
Posted: 16th Jan 2019 23:22
There's definitely some things that it handles oddly, part of that is because it tries to normalize things across a large variety of platforms and devices. Width height is one of those.

Aside from device dimensions the are also virtual dimensions, retina/ scaling dimensions, usable screen space dimensions which exclude control space headers and footers and so on...

What I am really enjoying right now is AgkSharp which is the agk libraries for c#

A single player RPG featuring a branching, player driven storyline of meaningful choices and multiple endings alongside challenging active combat and intelligent AI.

Login to post a reply

Server time is: 2019-01-23 08:59:13
Your offset time is: 2019-01-23 08:59:13