Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

FPSC Classic Models and Media / VWEAP's problem

Author
Message
syh
1
Years of Service
User Offline
Joined: 16th Aug 2017
Location:
Posted: 31st Jan 2019 12:51
I had already assign the texture to the VWEAP model,but why the VWEAP model is still grey in game?
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 31st Jan 2019 22:47
Syh Well I would normally say it's because the texture path is incorrect, but to assume it is correct... how did you assign the texture file path?
Manually for thru your modeling app ( like Fragmotion or something ) I take it's a custom weapon not stock.. yes/no? Did you uv map it and
does it show up correctly in your modeling app? Does this have a player weapon hud also or is it just an npc's Vweap?
Also, did you assign a shader to it, one that might require more/special texture's ? More info is needed how this is setup
My games never have bugs. They just develop random features..
Lots and lots of random features...
Location: You know that space between a dresser and the floor ? Yeah, that's where
syh
1
Years of Service
User Offline
Joined: 16th Aug 2017
Location:
Posted: 4th Feb 2019 00:10
Thanks,@ncmako.
And there is another question,how to set the alternative-ammo of an alt-flak weapon?
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 4th Feb 2019 00:51
@ Syh Wow, that reads like two different questions? Are you asking how to set & use (alt) flak, or the amount of flak shots ?
You can increase the amount of rounds by right clicking on the ammo and at bottom of property settings is the Ammo Quantity.
Or how to use/switch to Alt flak ammo? If that's the case here is Gunspec's on it...
My games never have bugs. They just develop random features..
Lots and lots of random features...
Location: You know that space between a dresser and the floor ? Yeah, that's where
syh
1
Years of Service
User Offline
Joined: 16th Aug 2017
Location:
Posted: 10th Feb 2019 14:08
Umm......I still don't know where the Vweap's problem is.So here's the screen shots.

Attachments

Login to view attachments
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 10th Feb 2019 16:23
Syh Is that first pic a screen shot of your Vweaps gamcore\guns folder ? If so where is the gunspec file and gun textures ?
Open another gun/weapons folder and take a look how they are setup. It just seems your missing some files
My games never have bugs. They just develop random features..
Lots and lots of random features...
Location: You know that space between a dresser and the floor ? Yeah, that's where
syh
1
Years of Service
User Offline
Joined: 16th Aug 2017
Location:
Posted: 11th Feb 2019 13:47
Emm...this is Fragmotion's open screen.And here is another screen shot.

Attachments

Login to view attachments
ncmako
7
Years of Service
User Offline
Joined: 19th Feb 2012
Location: Hendersonville,NC
Posted: 11th Feb 2019 21:40 Edited at: 11th Feb 2019 21:42
Syh I think I see the problem. In Fragmotion & the gunspec file, which texture in this folder is used/attached to the weapon?
Except for the "hand_D.dds" textures I don't see another file named gun_D.dds ? Remember a weapons texture in the gun folders
must be named gun_d.dds or gun_d2.dds. This is pretty much a hard coded thing.

Like I said before... open up another stock weapon and see how they are setup ( the texture files especially )
This will help point you in the right direction
My games never have bugs. They just develop random features..
Lots and lots of random features...
Location: You know that space between a dresser and the floor ? Yeah, that's where
syh
1
Years of Service
User Offline
Joined: 16th Aug 2017
Location:
Posted: 12th Feb 2019 14:09
Thanks!,That helps a lot!

Login to post a reply

Server time is: 2019-04-25 09:07:25
Your offset time is: 2019-04-25 09:07:25