Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

AppGameKit Studio Chat / error while trying to compile

Author
Message
Furord
5
Years of Service
User Offline
Joined: 8th Aug 2014
Location:
Posted: 30th Sep 2019 09:25
Luckily I am compiling with AppGameKit, because with Appgamekit Studio I have never managed to compile anything. I have tried it on several computers and it gives me the same error.

Texto original:
Por suerte estoy compilando con AppGameKit, porque con Appgamekit Studio no he conseguido compilar nada nunca. Lo he intentado en varios equipos y me da el mismo error.

Attachments

Login to view attachments
Loktofeit
AGK Developer
Gold Codemaster
11
Years of Service
User Offline
Joined: 21st Jan 2009
Location: Lakewood Ranch, FL
Posted: 1st Oct 2019 03:24 Edited at: 1st Oct 2019 03:26
The errors you are getting seem to be saying it's having trouble either creating the compressed file that it adds to the signed file or that it is having trouble merging the compressed and signed files.

Some things to check:

- Do you have any rather large files it's trying to package? 64Megs or larger?
- Did you change the name of the project (and to an extent, the package) at some point?
- Are and of the directories in the process Read Only or requiring Admin permissions?
- When was the last time you updated Android Studio? Java SDK? (NOTE: This is probably not it, as you said it's working fine in AGK2, but still worth checking anyway.)

Good luck!



Did a translation using Google Translate, so please forgive me if it's a bit gibberishy.

Los errores que está recibiendo parecen indicar que tiene problemas para crear el archivo comprimido que agrega al archivo firmado o que tiene problemas para fusionar los archivos comprimidos y firmados.

Algunas cosas para verificar:

- ¿Tienes algún archivo bastante grande que esté tratando de empaquetar? 64Megs o más grande?
- ¿Cambiaste el nombre del proyecto (y hasta cierto punto, el paquete) en algún momento?
- ¿Son y de los directorios en el proceso de solo lectura o requieren permisos de administrador?
- ¿Cuándo fue la última vez que actualizaste Android Studio? Java SDK? (NOTA: Esto probablemente no sea así, ya que dijiste que funciona bien en AGK2, pero de todos modos vale la pena verificarlo).

¡Buena suerte!
Furord
5
Years of Service
User Offline
Joined: 8th Aug 2014
Location:
Posted: 2nd Oct 2019 11:20
Solved !!!!!!
Thanks Loktofeit, it's not that you gave me the solution but thanks to you I tried a couple of things and it works in the end.
In case someone is the same, simply delete the TheGameCreators folder located in the path "C: \ Users \ Name \ AppData \ Local \ AGKApps \ TheGameCreators".
Create a copy just in case before deleting it. I hope it helps someone, greetings.

Texto original:
Solucionado!!!!!!
Gracias Loktofeit, no es que me dieses la solución pero gracias a ti probé un par de cosas y al final funciona.
Por si a alguien le pasa lo mismo, simplemente borrar la carpeta TheGameCreators situada en la ruta “C:\Users\Nombre\AppData\Local\AGKApps\TheGameCreators”.
Crear una copia por si acaso antes de borrarla. Espero que le sea de ayuda a alguien, un saludo.
PSY
Valued Member
3
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 4th Oct 2019 19:39
Had a similar issue twice with AppGameKit Classic.

First time I deleted the TheGameCreators folder.
Second time the export path didn't exist. I thought it would be created automatically if that was the case...


PSY


PSY LABS Games
Coders don't die, they just gosub without return

Login to post a reply

Server time is: 2020-04-10 01:38:35
Your offset time is: 2020-04-10 01:38:35