Sorry your browser is not supported!

You are using an outdated browser that does not support modern web technologies, in order to use this site please update to a new browser.

Browsers supported include Chrome, FireFox, Safari, Opera, Internet Explorer 10+ or Microsoft Edge.

Android / From November 1, 2019, app updates must target at least Android 9.0 ???

Author
Message
JeZxLee
3
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 11th Oct 2019 15:27
Hi,

I just received an email from Google:
https://developer.android.com/distribute/best-practices/develop/target-sdk
(From November 1, 2019, app updates must target at least Android 9.0)

Am I reading the above right?
Only Android version 9.0 and above devices will be supported?

Can someone explain the above, I am very confused...
Thanks!

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
PSY
Valued Member
4
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 13th Oct 2019 01:20 Edited at: 13th Oct 2019 01:22
Hey JeZxLee,


here's the thread regarding this issue:
https://forum.thegamecreators.com/thread/224785


PSY


PSY LABS Games
Coders don't die, they just gosub without return
JeZxLee
3
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 15th Oct 2019 20:19
Hi,

I have current AppGameKit Classic.
Do I have to do anything to "target" Android OS 9.0 ?
My phone only has Android OS 8.0, will that be a problem?
Let me know, thanks!

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
PSY
Valued Member
4
Years of Service
User Offline
Joined: 3rd Jul 2016
Location: Laniakea Supercluster
Posted: 15th Oct 2019 20:59 Edited at: 15th Oct 2019 21:00
The target SDK and the minimum SDK when exporting are two different things.
The target SDK is updated by TGC. There's nothing you can do about that than wait for updates.
Both Studio and Classic already target Android 9.0 API 28 ( since August )

Android 8.0 on your phone won't be any problem soon. I'm still using 5.x on mine ^^

So there's nothing you need to worry about.


PSY


PSY LABS Games
Coders don't die, they just gosub without return
JeZxLee
3
Years of Service
User Offline
Joined: 15th Mar 2017
Location: Long Island, New York, United States, Earth
Posted: 16th Oct 2019 11:39
Ok, thanks!

Jesse
JeZxLee
Fallen Angel Software
Video Game Design Studio
http://www.FallenAngelSoftware.com
EdzUp
18
Years of Service
User Offline
Joined: 8th Sep 2002
Location: Citadel Cyberspace
Posted: 27th Oct 2019 13:39
Does this API requirement mean it just has to be in the list of 'supported' API's when building or be built for Android 9 and up as if thats is the case it would seriously limit the audience of any produced programs for any previous android version?
-EdzUp

Login to post a reply

Server time is: 2020-09-29 05:50:46
Your offset time is: 2020-09-29 05:50:46